I have discovered that Linux Lite 3.8 allows the 304 drivers, and is supported until 04/21, so I am using that. No display problems at all. For now I'm calling it solved. A year from now, who knows...