Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unable to install boot-repair on 19.10

  1. #1
    Join Date
    Oct 2013
    Location
    Ottawa, Ontario, Canada
    Beans
    124
    Distro
    Ubuntu 19.10 Eoan Ermine

    Question Unable to install boot-repair on 19.10

    I cannot install boot-repair

    sudo add-apt-repository ppa:yannubuntu/boot-repair
    Simple tool to repair frequent boot problems.

    Website: https://sourceforge.net/p/boot-repair/home
    More info: https://launchpad.net/~yannubuntu/+a...tu/boot-repair
    Press [ENTER] to continue or Ctrl-c to cancel adding it.

    Ign:1 cdrom://Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017) eoan InRelease
    Hit:2 cdrom://Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017) eoan Release
    Get:4 http://security.ubuntu.com/ubuntu eoan-security InRelease [97.5 kB]
    Get:5 http://archive.ubuntu.com/ubuntu eoan InRelease [255 kB]
    Get:6 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu eoan InRelease [15.4 kB]
    Get:7 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu eoan/main amd64 Packages [1,704 B]
    Get:8 http://security.ubuntu.com/ubuntu eoan-security/main amd64 Packages [137 kB]
    Get:9 http://archive.ubuntu.com/ubuntu eoan-updates InRelease [97.5 kB]
    Get:10 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu eoan/main Translation-en [1,576 B]
    Get:11 http://archive.ubuntu.com/ubuntu eoan/main amd64 Packages [969 kB]
    Get:12 http://security.ubuntu.com/ubuntu eoan-security/main Translation-en [51.5 kB]
    Get:13 http://security.ubuntu.com/ubuntu eoan-security/main amd64 DEP-11 Metadata [204 B]
    Get:14 http://security.ubuntu.com/ubuntu eoan-security/main DEP-11 48x48 Icons [29 B]
    Get:15 http://security.ubuntu.com/ubuntu eoan-security/main DEP-11 64x64 Icons [29 B]
    Get:16 http://security.ubuntu.com/ubuntu eoan-security/main amd64 c-n-f Metadata [1,940 B]
    Get:17 http://security.ubuntu.com/ubuntu eoan-security/restricted amd64 Packages [8,904 B]
    Get:18 http://security.ubuntu.com/ubuntu eoan-security/restricted Translation-en [1,516 B]
    Get:19 http://archive.ubuntu.com/ubuntu eoan/main amd64 DEP-11 Metadata [510 kB]
    Get:20 http://archive.ubuntu.com/ubuntu eoan/main DEP-11 48x48 Icons [95.4 kB]
    Get:21 http://archive.ubuntu.com/ubuntu eoan/main DEP-11 64x64 Icons [173 kB]
    Get:22 http://archive.ubuntu.com/ubuntu eoan/main amd64 c-n-f Metadata [29.7 kB]
    Get:23 http://archive.ubuntu.com/ubuntu eoan-updates/main amd64 Packages [204 kB]
    Get:24 http://archive.ubuntu.com/ubuntu eoan-updates/main Translation-en [77.5 kB]
    Get:25 http://archive.ubuntu.com/ubuntu eoan-updates/main amd64 DEP-11 Metadata [73.0 kB]
    Get:26 http://archive.ubuntu.com/ubuntu eoan-updates/main DEP-11 48x48 Icons [9,948 B]
    Get:27 http://archive.ubuntu.com/ubuntu eoan-updates/main DEP-11 64x64 Icons [15.1 kB]
    Get:28 http://archive.ubuntu.com/ubuntu eoan-updates/main amd64 c-n-f Metadata [2,932 B]
    Get:29 http://archive.ubuntu.com/ubuntu eoan-updates/restricted amd64 Packages [8,904 B]
    Get:30 http://archive.ubuntu.com/ubuntu eoan-updates/restricted Translation-en [1,516 B]
    Fetched 2,840 kB in 2s (1,339 kB/s)
    Reading package lists... Done
    ubuntu@ubuntu:~$ sudo apt-get update
    Ign:1 cdrom://Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017) eoan InRelease
    Hit:2 cdrom://Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017) eoan Release
    Hit:3 http://security.ubuntu.com/ubuntu eoan-security InRelease
    Hit:5 http://archive.ubuntu.com/ubuntu eoan InRelease
    Hit:6 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu eoan InRelease
    Hit:7 http://archive.ubuntu.com/ubuntu eoan-updates InRelease
    Reading package lists... Done

    ubuntu@ubuntu:~$ sudo apt-get install -y boot-repair && boot-repair
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    boot-repair : Depends: boot-sav but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    ubuntu@ubuntu:~$ sudo apt-get install -y boot-repair
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    boot-repair : Depends: boot-sav but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    ubuntu@ubuntu:~$ sudo apt-get install -y boot-save
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package boot-save
    ubuntu@ubuntu:~$ sudo apt-get install -y boot-sav
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    boot-sav : Depends: glade2script (>= 3) but it is not going to be installed or
    glade2script-gtk2 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    ubuntu@ubuntu:~$ sudo apt-get install -y glade2script-gtk2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    glade2script-gtk2 : Depends: python but it is not installable
    Depends: python-gtk2 but it is not installable
    E: Unable to correct problems, you have held broken packages.
    ubuntu@ubuntu:~$ sudo apt-get install python
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'python' has no installation candidate
    ubuntu@ubuntu:~$ sudo apt-get install python-gtk2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python-gtk2 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'python-gtk2' has no installation candidate
    ubuntu@ubuntu:~$

    python --version

    Command 'python' not found, but can be installed with:

    sudo apt install python3

    You also have python3 installed, you can run 'python3' instead.

    ubuntu@ubuntu:~$ sudo apt install python3
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python3 is already the newest version (3.7.5-1).
    python3 set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 252 not upgraded.



    If python is already installed why is the installation of boot-repair not finding it?

  2. #2
    Join Date
    Sep 2014
    Location
    United States
    Beans
    71
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Unable to install boot-repair on 19.10

    I guess it cannot find python-gtk2 in your repositories, but you can grab the individual package from Ubuntu's packaging website.

    https://packages.ubuntu.com/eoan/python-gtk2

  3. #3
    Join Date
    Oct 2013
    Location
    Ottawa, Ontario, Canada
    Beans
    124
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Unable to install boot-repair on 19.10

    I am not going to bypass standard procedures just because the installation package is incorrectly set up. For all I know once I resolve these immediate problems the install will just demand ANOTHER package which is missing.

    The only reason that I am trying to install boot-repair is because I cannot successfully install Ubuntu 19.10 and the ONLY advice I have been given is to install boot-repair so that it will identify why Ubuntu 19.10 is not coming up. I do not believe this is relevant. I believe that the boot is working because it gets as far as the screen that is displayed while the Linux initialization is proceeding, but that display never completes. I therefore conclude that the problem is in the Linux startup, not in the Boot. So boot-repair is not going to find anything wrong.

  4. #4
    Join Date
    Sep 2014
    Location
    United States
    Beans
    71
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Unable to install boot-repair on 19.10

    I know it's inconvenient. I've installed boot repair 3 times while on the job and have installed it manually. I'm not so sure if it's incorrect or just old. I think it's simply 3 or 4 steps to install via dpkg. No need to take it personally. Good luck.

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Unable to install boot-repair on 19.10

    Do you get grub menu?
    Or if only Ubuntu, and install is UEFI press escape (perhaps several times) to get grub menu. Or if BIOS press & hold shift key from BIOS until menu appears.

    What video card/chip?
    What brand/model system?
    If nVidia, you normally need nomodeset, but newer versions now install nVidia proprietary driver, so nomodeset not required.

    At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.
    How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
    How to add boot parameters, grub menu after install (also grub when UEFI)
    https://wiki.ubuntu.com/Kernel/KernelBootParameters &
    https://help.ubuntu.com/community/Grub2
    http://ubuntuforums.org/showthread.php?t=1613132
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Oct 2013
    Location
    Ottawa, Ontario, Canada
    Beans
    124
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Unable to install boot-repair on 19.10

    I created this thread on boot-repair to focus on how to install boot-repair when it won't install because some of the pre-requisites are not available in the Ubuntu repository. Issues related to Ubuntu 19.10 refusing to run on my platform are on thread 2436558. As you can see from the console log above I am trying to follow the instructions at https://help.ubuntu.com/community/Boot-Repair but they do not work.

  7. #7
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Unable to install boot-repair on 19.10

    I cannot answer why boot-repair does not install but my suggestion (for all PPA management) is to install Y PPA Manager

    launch it (under System Tools category), click on Manage PPA's where you can remove/purge/ PPA's.

    Then you can Add PPA or go to Advanced and test PPA's. Some clues might surface with this tool.

  8. #8
    Join Date
    Oct 2013
    Location
    Ottawa, Ontario, Canada
    Beans
    124
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Unable to install boot-repair on 19.10

    As you can see from the console log I posted I had already included the required PPA for installing boot-repair. However if there are other PPAs which are required for this installation, since for some reason the Ubuntu repositories do not contain pythongtk2, then those PPAs should be part of the documentation of how to install boot-repair. Having a GUI PPA manager is not going to help if I am expected to psychically know what PPAs need to be included to satisfy the installation when the installation documentation does not identify them!

  9. #9
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Unable to install boot-repair on 19.10

    Having a GUI PPA manager is not going to help
    .. I disagree, but that is my opinion since it does identify duplicates, BADSIG errors and the like. But it is your call.

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Unable to install boot-repair on 19.10

    Do these run without error if Boot-Repair not installed.
    Always best to make sure system is up to date, before Boot-Repair as sometimes other software can cause an issue.

    sudo apt update
    sudo apt upgrade

    # If later you do not want ppa, how to uninstall ppa
    sudo add-apt-repository --remove ppa:yannubuntu/boot-repair
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •