Results 1 to 3 of 3

Thread: Detect displays button disappeared ubuntu 18.04

  1. #1
    Join Date
    Feb 2020
    Beans
    2

    Detect displays button disappeared ubuntu 18.04

    I'm running ubuntu 18.04 kernel version 5.3.0-28-generic on my Asus zenbook laptop with Intel UHD 620 graphics. External monitors have worked for 9 months, then suddenly stopped working. In the display settings, there used to be a button labeled "Detect Displays" but that has now disappeared. I've seen a lot of forums about nvidia drivers but can't find anything about the intel card, and since it was working before with the generic driver I don't think this is the issue.

    Output from xrandr:
    HTML Code:
    ethan@muffin:~$ xrandr
    Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
    eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
       1920x1080     60.05*+  60.01    59.97    59.96    59.93    48.04  
       1680x1050     59.95    59.88  
       1600x1024     60.17  
       1400x1050     59.98  
       1600x900      59.99    59.94    59.95    59.82  
       1280x1024     60.02  
       1440x900      59.89  
       1400x900      59.96    59.88  
       1280x960      60.00  
       1440x810      60.00    59.97  
       1368x768      59.88    59.85  
       1360x768      59.80    59.96  
       1280x800      59.99    59.97    59.81    59.91  
       1152x864      60.00  
       1280x720      60.00    59.99    59.86    59.74  
       1024x768      60.04    60.00  
       960x720       60.00  
       928x696       60.05  
       896x672       60.01  
       1024x576      59.95    59.96    59.90    59.82  
       960x600       59.93    60.00  
       960x540       59.96    59.99    59.63    59.82  
       800x600       60.00    60.32    56.25  
       840x525       60.01    59.88  
       864x486       59.92    59.57  
       800x512       60.17  
       700x525       59.98  
       800x450       59.95    59.82  
       640x512       60.02  
       720x450       59.89  
       700x450       59.96    59.88  
       640x480       60.00    59.94  
       720x405       59.51    58.99  
       684x384       59.88    59.85  
       680x384       59.80    59.96  
       640x400       59.88    59.98  
       576x432       60.06  
       640x360       59.86    59.83    59.84    59.32  
       512x384       60.00  
       512x288       60.00    59.92  
       480x270       59.63    59.82  
       400x300       60.32    56.34  
       432x243       59.92    59.57  
       320x240       60.05  
       360x202       59.51    59.13  
       320x180       59.84    59.32  
    DP-1 disconnected (normal left inverted right x axis y axis)
    HDMI-1 disconnected (normal left inverted right x axis y axis)
    DP-2 disconnected (normal left inverted right x axis y axis)
    HDMI-2 disconnected (normal left inverted right x axis y axis)
    It's not detecting the HDMI input (tried both ports 1 and 2). Note this is through a usbc interface to the laptop.

    I've tried different cables and monitors, and tried installing different DMs (I normally use GDM3, tried lightdm and slim), but no luck with any of these (output from xrandr always the same). I also tried booting to an older kernel version 5.3.0-26-generic but that did not help either.

    Any suggestions?

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    455
    Distro
    Ubuntu

    Re: Detect displays button disappeared ubuntu 18.04

    I suggest you try in a live session in order to rule out hardware.

  3. #3
    Join Date
    Feb 2020
    Beans
    2

    Re: Detect displays button disappeared ubuntu 18.04

    I've tried several things with inconsistent results. The next day the display worked as normal all day, even with several hot dock/undocks. But the day after the problem returned. I booted to a live session and it worked, then rebooted to my normal session and it also worked again, telling me it was likely a software problem.

    Next day the display wasn't working again so I tried the live session again, this time it did not work, so a hardware issue? Then why is it intermittent?

    Now after some extensive testing I can report intermittent appearance of the problem for both the live session and normal session. For hardware changes, I have also intermittently seen the problem with multiple monitors, HDMI cables, USBC-HDMI converters, and both USBC ports. All hardware I've tried swapping has both worked and given the problem.

    So if it's a hardware problem, is it the graphics card? Not sure what else it could be.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •