Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Every Thumb Drive owned by ROOT

  1. #11
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Every Thumb Drive owned by ROOT

    Quote Originally Posted by The Cog View Post
    Oh no it isn't!
    For me, it's been that way for a long time.
    It is possible that I changed a desktop setting to stop automount some time in the past.
    But anyway, the default mount path is the important thing here. It mounts under /media/username, not at /media/username.
    A sudden thought; is the USB disk that does not mount automatically always inserted at boot time?

    That is the only time that a USB disk does not automount in my system but if I remove it and re-attach it the mount will occur automatically. If it's always attached it will have to be given a line in /etc/fstab to mount it at boot.
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  2. #12
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,918
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Every Thumb Drive owned by ROOT

    No. I don't insert disks at boot time. I am guessing (haven't tried) that if they automounted, they wouldn't know which user to mount for.
    I do remember (a long time ago) that I found automounting irritating when inserting a disk with multiple partitions. So I am happy to accept that automount is the default and I switched it off. It's an option in Xubuntu settings UI somewhere, under "behaviour" I think. Can't look right now. I keep my home when installing a new release so the setting may have persisted for years.

  3. #13
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Every Thumb Drive owned by ROOT

    So we're both correct, I think.

    The default must be to automount a USB drive as I've never changes that, but it can be turned off as you say, shown in my screenshot, got to from thunar->Edit->Preferences->Advanced->Volume Management.

    I assume this can also be configured in other DE's and file-managers but I've been using Xubuntu now for too many years to bother with anything else.
    Attached Images Attached Images
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •