Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 43

Thread: Broadcom wireless initially worked, now balky

  1. #11
    Join Date
    Jan 2020
    Beans
    48

    Re: Broadcom wireless initially worked, now balky

    Quote Originally Posted by chili555 View Post
    Likewise. May we please have the link?

    Scroll up a few messages and see the one where I pasted the last screen of info from my terminal when I ran the whole process this morning. I've highlighted a link and asked if that's the one y'all are talking about. There was info in the instructions about how the script would be "...
    creating at the same time a link to it in your terminal..."

    Well, that's what I see as a link in my terminal. And I've pasted it and sent it. But if that's not the right link, let me know what link I should be looking for (terminal is still open from this morning).


  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,022
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Broadcom wireless initially worked, now balky

    That is the not so simple shell script that gathers the required information from your system when you actually run it. We need the results. Please open a terminal and do:
    Code:
    pastebinit wireless-info.txt
    It will produce a link, aka URL like this: https://paste.ubuntu.com/p/kcGdQR43qr/

    Please tell us what it s.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #13
    Join Date
    Jan 2020
    Beans
    48

    Re: Broadcom wireless initially worked, now balky

    Just ran that command, got the link and pasted it to paste.ubunto.com

  4. #14
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,022
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Broadcom wireless initially worked, now balky

    Quote Originally Posted by davepool View Post
    Just ran that command, got the link and pasted it to paste.ubunto.com
    We want the link right here in your reply, just like this:


    https://paste.ubuntu.com/p/kcGdQR43qr/
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #15
    Join Date
    Jan 2020
    Beans
    48

    Re: Broadcom wireless initially worked, now balky

    Quote Originally Posted by chili555 View Post
    We want the link right here in your reply

    https://paste.ubuntu.com/p/x6sQ6XWNMH/

  6. #16
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,022
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Broadcom wireless initially worked, now balky

    Let's try a few things. Please open a terminal and do:

    Code:
    sudo -i
    modprobe -r ssb
    modprobe -r b43
    echo "blacklist ssb"  >>  /etc/modprobe.d/blacklist.conf
    echo "blacklist b43"  >>  /etc/modprobe.d/blacklist.conf
    exit
    Is your router set to a fixed channel 1 or is it set to auto channel select? Please be sure it is fixed.

    I notice that you have both wireless and ethernet connected. Please detach the ethernet and tell us if there is any iimprovement.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #17
    Join Date
    Jan 2020
    Beans
    48

    Re: Broadcom wireless initially worked, now balky

    Let me work backwards through your questions:

    I have both ethernet and wireless attached because Jeremy31's instructions said at the very outset that everything that needed to be done there required a hardwire connection. The problems I've been having and reported in the first message were all without ethernet connected. It has now been disconnected.

    I have no idea if my router is set to a fixed channel or auto...but I suspect it's fixed because on the 1-2 occasions when I've had to use a utility on it, there was a list of channels and it showed which one. In any case, nothing about that router has changed in the 2+ years we've lived in this house and there's been no previous problem with wifi until this particular device and even then only very recently.

    I ran what you suggested...no change. Web pages time out. "The site can't be reached"
    Though the network connection panel shows Signal Strength: Excellent and Link speed: 14Mb/s

    I even re-booted. No change.

    Then, in case your commands needed to be re-run after the re-start, I did them again. No change. All pages time out. Speed shown now as 72 Mb/s
    Last edited by davepool; 3 Weeks Ago at 03:23 PM.

  8. #18
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,022
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Broadcom wireless initially worked, now balky

    I have both ethernet and wireless attached because Jeremy31's instructions said at the very outset that everything that needed to be done there required a hardwire connection. The problems I've been having and reported in the first message were all without ethernet connected. It has now been disconnected.
    Excellent.

    I have no idea if my router is set to a fixed channel or auto...but I suspect it's fixed because on the 1-2 occasions when I've had to use a utility on it, there was a list of channels and it showed which one. In any case, nothing about that router has changed in the 2+ years we've lived in this house and there's been no previous problem with wifi until this particular device and even then only very recently.
    Something obviously has changed. Perhaps not in the router, perhaps in the Ubuntu kernel, perhaps in the driver code, I simply don't know. All I am getting at here is to give your wireless the best possible environment in which to work correctly.

    Please go into the router's administrative pages and check the settings. While you are in there, here are some tips that have been extremely helpful in several other cases, including my own setup.

    First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

    Also, please set your regulatory domain explicitly. Check yours:
    Code:
    sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:
    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:
    Code:
    sudo nano /etc/default/crda
    Change the last line to read:
    Code:
    REGDOMAIN=IS
    Proofread carefully, save (Ctrl+o followed by Enter) and close (Ctrl+x) the text editor.

    Then, in case your commands needed to be re-run after the re-start, I did them again. No change. All pages time out. Speed shown now as 72 Mb/s.
    The commands need not be repeated. The changes are permanent unless we affirmatively reverse them.

    Please run these commands and let us see the results:

    Code:
    ping -c3 www.google.com
    dmesg | grep -e brcm -e wlp
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #19
    Join Date
    Jan 2020
    Beans
    48

    Re: Broadcom wireless initially worked, now balky

    Okay, here's the report:

    WPA2-PSK [AES] is where it's set. That seemed close to what you said...I left it alone.

    It *was* set to Auto (this is for the 2.4GHz channel) with it being, at this time, on 1. But I changed it from Auto to 1

    I saw 2.4GHz b/g/n which tells me it's not set for n speed only (correct?)

    The reg domain was, as you suspected, set to 00. It has now been permanently set to the correct country.


    And here's the results of your two commands:

    dave@ThinkPad-X131e:~$ ping -c3 www.google.com
    ping: www.google.com: Temporary failure in name resolution

    dave@ThinkPad-X131e:~$ dmesg | grep -e brcm -e wlp
    [ 10.647046] brcmsmac bcma0:1: mfg 4bf core 812 rev 24 class 0 irq 17
    [ 10.649520] ieee80211 phy0: registered radio enabled led device: brcmsmac-phy0:radio gpio: 499
    [ 10.863698] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21f4.hcd failed with error -2
    [ 10.863713] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21f4.hcd not found
    [ 11.559537] brcmsmac bcma0:1 wlp2s0b1: renamed from wlan0
    [ 22.817326] brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
    [ 22.817353] brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
    [ 24.500949] wlp2s0b1: authenticate with 14:59:c0:84:e3:b3
    [ 24.501356] wlp2s0b1: send auth to 14:59:c0:84:e3:b3 (try 1/3)
    [ 24.503507] wlp2s0b1: authenticated
    [ 24.505746] wlp2s0b1: associate with 14:59:c0:84:e3:b3 (try 1/3)
    [ 24.521017] wlp2s0b1: RX AssocResp from 14:59:c0:84:e3:b3 (capab=0x1411 status=0 aid=6)
    [ 24.521495] brcmsmac bcma0:1: brcmsmac: brcms_ops_bss_info_changed: associated
    [ 24.521511] brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: true (implement)
    [ 24.521542] wlp2s0b1: associated
    [ 24.530118] brcmsmac bcma0:1: wl0: brcms_c_d11hdrs_mac80211: txop exceeded phylen 159/256 dur 1778/1504
    [ 24.564475] brcmsmac bcma0:1: wl0: brcms_c_d11hdrs_mac80211: txop exceeded phylen 137/256 dur 1602/1504
    [ 24.638604] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0b1: link becomes ready
    [ 27.518501] brcmsmac bcma0:1: brcms_ops_bss_info_changed: arp filtering: 1 addresses (implement)
    [ 52.468286] [UFW BLOCK] IN=wlp2s0b1 OUT= MAC= SRC=fe80:0000:0000:0000:6129:96a1:f772:1674 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=617079 PROTO=UDP SPT=8612 DPT=8612 LEN=24
    [ 52.468405] [UFW BLOCK] IN=wlp2s0b1 OUT= MAC= SRC=fe80:0000:0000:0000:6129:96a1:f772:1674 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=919105 PROTO=UDP SPT=8612 DPT=8610 LEN=24
    [ 52.478933] [UFW BLOCK] IN=wlp2s0b1 OUT= MAC= SRC=fe80:0000:0000:0000:6129:96a1:f772:1674 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=617079 PROTO=UDP SPT=8612 DPT=8612 LEN=24
    [ 52.479042] [UFW BLOCK] IN=wlp2s0b1 OUT= MAC= SRC=fe80:0000:0000:0000:6129:96a1:f772:1674 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=919105 PROTO=UDP SPT=8612 DPT=8610 LEN=24
    [ 76.529526] [UFW BLOCK] IN=wlp2s0b1 OUT= MAC=2c:d0:5a:01:5d:aa:c8:1f:66:0c:0d:e5:08:00 SRC=192.168.0.19 DST=192.168.0.31 LEN=44 TOS=0x00 PREC=0x00 TTL=128 ID=5575 PROTO=UDP SPT=50135 DPT=8612 LEN=24

  10. #20
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,022
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: Broadcom wireless initially worked, now balky

    Everything looks perfect until:
    dave@ThinkPad-X131e:~$ ping -c3 www.google.com
    ping: www.google.com: Temporary failure in name resolution
    Let's try to see where it fails.Please run and post the result of:
    Code:
    ping -c3 192.168.0.1
    ping -c3 8.8.8.8
    ping4 -c3 www.google.com
    I hope we see a clue in there!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •