Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: MPD: No Mixer

  1. #11
    Join Date
    Jun 2007
    Beans
    13,822

    Re: MPD: No Mixer

    Quote Originally Posted by TheFu View Post
    I know nothing, but thought mpd was the server and needed a client to actually playback any audio. That would mean the client would be responsible for volume, mixing, etc.
    The client can be on the same machine or over a network.
    OP already stated s/he was using ncmpcpp. I'm assuming it's on the same machine.

  2. #12
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    183
    Distro
    Xubuntu

    Re: MPD: No Mixer

    Quote Originally Posted by Yellow Pasque View Post
    OP already stated s/he was using ncmpcpp. I'm assuming it's on the same machine.
    Yes I am using ncmpcpp with mpd & they are both on the same machine. When I was setting up mpd for the first time I followed the section at the bottom of "this" page for setting up mpd as a user service.. Btw if using pulse would be easier than alsa then I don't mind switching, but I do get the same problem when using pulse. Anyway here's the outputs of those two commands & many many thanks for all of the help so far....


    aplay -l


    Code:
    furycd001 > aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: CX20753/4 Analog [CX20753/4 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
      Subdevices: 1/1
      Subdevice #0: subdevice #0

    amixer scontrols

    Code:
    furycd001 > amixer scontrols
    Simple mixer control 'Master',0
    Simple mixer control 'Headphone',0
    Simple mixer control 'Speaker',0
    Simple mixer control 'PCM',0
    Simple mixer control 'Mic Boost',0
    Simple mixer control 'IEC958',0
    Simple mixer control 'IEC958',1
    Simple mixer control 'IEC958',2
    Simple mixer control 'IEC958',3
    Simple mixer control 'IEC958',4
    Simple mixer control 'Beep',0
    Simple mixer control 'Capture',0
    Simple mixer control 'Auto-Mute Mode',0
    Simple mixer control 'Internal Mic Boost',0
    Last edited by Furycd001; 2 Weeks Ago at 08:31 AM.
    [ R E V I Z I I S ]

  3. #13
    Join Date
    Jun 2007
    Beans
    13,822

    Re: MPD: No Mixer

    Can you describe a little more about what you are trying to do with mpd? Do you want it to be the only program that can access the sound card and play sound? If so, you'll have to do some extra configuration (making sure your user is in the audio group and tha pulseaudio has not grabbed the hardware device (hw:0,0).

  4. #14
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    183
    Distro
    Xubuntu

    Re: MPD: No Mixer

    Quote Originally Posted by Yellow Pasque View Post
    Can you describe a little more about what you are trying to do with mpd? Do you want it to be the only program that can access the sound card and play sound? If so, you'll have to do some extra configuration (making sure your user is in the audio group and tha pulseaudio has not grabbed the hardware device (hw:0,0).
    Just want to play some music in ncmpcpp & be able to adjust the volume when necessary. Hmmm no I don't want that.. I just want playback without any stutter, interruptions or high cpu usage. Sometimes I need to close waterfox, before ncmpcpp / mpd will open, but that doesn't bother me really....
    [ R E V I Z I I S ]

  5. #15
    Join Date
    Jun 2007
    Beans
    13,822

    Re: MPD: No Mixer

    Just want to play some music in ncmpcpp & be able to adjust the volume when necessary. Hmmm no I don't want that.. I just want playback without any stutter, interruptions or high cpu usage.
    Theoretically, that shouldn't happen with pulseaudio, but bugs do exist and sometimes it's easier to work around them.
    So, if you want to try using the hw:0,0 device directly
    1. Check if your user is in the audio group:
    Code:
    groups
    If not, add it:
    Code:
    sudo usermod -a -G audio furycd001
    2. Make sure you uncomment this line in your mpd.conf
    Code:
     group "audio"
    3. Stop all programs playing audio (like waterfox)

    4. Try starting ncmpcpp with pasuspender:
    Code:
    pasuspender ncmpcpp
    I'm not sure about these lines in mpd.conf
    Code:
    mixer_type "hardware"
    mixer_device "default"
    mixer_control	"PCM"
    If you're using onboard audio, you won't have a hardware mixer (that's why only one program can play sound at a time if you don't use a software mixer like pulseaudio).

  6. #16
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    183
    Distro
    Xubuntu

    Re: MPD: No Mixer

    Quote Originally Posted by Yellow Pasque View Post
    Theoretically, that shouldn't happen with pulseaudio, but bugs do exist and sometimes it's easier to work around them.
    So, if you want to try using the hw:0,0 device directly
    1. Check if your user is in the audio group:
    Code:
    groups
    If not, add it:
    Code:
    sudo usermod -a -G audio furycd001
    2. Make sure you uncomment this line in your mpd.conf
    Code:
     group "audio"
    3. Stop all programs playing audio (like waterfox)

    4. Try starting ncmpcpp with pasuspender:
    Code:
    pasuspender ncmpcpp
    I'm not sure about these lines in mpd.conf
    Code:
    mixer_type "hardware"
    mixer_device "default"
    mixer_control    "PCM"
    If you're using onboard audio, you won't have a hardware mixer (that's why only one program can play sound at a time if you don't use a software mixer like pulseaudio).
    Thank you for the detailed reply. Checked and my user is already in the audio group & uncommented that line in my .conf. Tried launching ncmpcpp with that command, but the same thing still happened. I tried also commenting out the alsa_output part of my config & then uncommenting the pulse_output to use that instead, but again got the same message along the bottom. Completely stumped. If I was to switch to a software mixer in my config, would I notice any performance issues or cpu increase ??
    [ R E V I Z I I S ]

  7. #17
    Join Date
    Jun 2007
    Beans
    13,822

    Re: MPD: No Mixer

    Quote Originally Posted by jonny6 View Post
    If I was to switch to a software mixer in my config, would I notice any performance issues or cpu increase ??
    You shouldn't, because you probably don't have a hardware mixer if using onboard Conexant CX2075x audio. Maybe look at alsa info to see some of the more advanced settings for your card: https://wiki.ubuntu.com/Audio/AlsaInfo

  8. #18
    Join Date
    Jan 2014
    Location
    The Endless Ocean
    Beans
    183
    Distro
    Xubuntu

    Re: MPD: No Mixer

    Quote Originally Posted by Yellow Pasque View Post
    You shouldn't, because you probably don't have a hardware mixer if using onboard Conexant CX2075x audio. Maybe look at alsa info to see some of the more advanced settings for your card: https://wiki.ubuntu.com/Audio/AlsaInfo
    Just ran "alsa-info" & here's the output.. Also ran "amixer" & here's it's output.. Read through it both, but don't know what to take from either or what to put in my audio_output section. I feel like a complete noob....
    [ R E V I Z I I S ]

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •