Results 1 to 5 of 5

Thread: Resold Broken

  1. #1
    Join Date
    Jan 2020

    Resold Broken

    I am really sorry if this question is in the wrong place or incorrect but I have now battled for a few weeks and have made no progress.
    I am pretty new to this resolvd stuff.
    The only thing that I have found is that resolvd is broken after an Ubuntu update.
    After very much searching and reading I found the following link.
    From this thread, I searched the UBUNTU forums and found the following link/case.
    I have tried all of the suggested solutions and none seem to have worked for me. There is one thing I did not understand, was the syntax of what the guys says here
    "I got DNS working by explicitly specifying the DNS server in /etc/systemd/resolved.conf"

    with this broken I cannot even do any updates at all. I have tried to add and remove packages and nothing works.

    All I have found say nothing about a resolution. I am completely stumped.
    Is there anyone that can help/advise. ... Please

    Last edited by lslamp; January 15th, 2020 at 10:14 PM. Reason: Title is incorrect. Should be Resolvd Broken

  2. #2
    Join Date
    Mar 2007

    Re: Resold Broken

    Most likely it's simply mis-configured.
    But to help we need more information.
    What version of Ubuntu?
    What is in /etc/systemd/resolved.conf?
    What have you tried to do and what were the results?

  3. #3
    Join Date
    Jan 2020

    Re: Resold Broken

    Strange that you say mis-config because it was all working and then it suddenly stopped resolving. I only noticed the issue because of an installation of a package within wordpress.
    below are the details.
    root@heretic:~# lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 16.04.6 LTS
    Release: 16.04
    Codename: xenial

    root@heretic:~# cat /etc/systemd/resolved.conf
    # This file is part of systemd.
    # systemd is free software; you can redistribute it and/or modify it
    # under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2.1 of the License, or
    # (at your option) any later version.
    # Entries in this file show the compile time defaults.
    # You can change settings by editing this file.
    # Defaults can be restored by simply deleting this file.
    # See resolved.conf(5) for details

    #FallbackDNS= 2001:4860:4860::8888 2001:4860:4860::8844

    I tried the following.
    sudo systemctl disable systemd-resolved.service -- ran successfully
    sudo service systemd-resolved stop -- ran successfully
    Put the following line in the [main] section of your /etc/NetworkManager/NetworkManager.conf:
    dns=default -- Inserted this into the NetworkManager.conf

    ## Tried to do the steps below, but network manager does not seem to be installed.
    Delete the symlink /etc/resolv.conf
    rm /etc/resolv.conf
    Restart network-manager
    sudo service network-manager restart

    root@heretic:~# cat /etc/resolv.conf

    If I try to do an nslookup, below is what I get.

    root@heretic:~# nslookup
    ../../../../lib/isc/unix/socket.c:2881: setsockopt(20, IP_RECVTOS) failed: Protocol not available

    Non-authoritative answer: canonical name =


  4. #4
    Join Date
    Apr 2018

    Re: Resold Broken

    Not sure what the protocol not available is all about, but it looks like it returned the correct answer.

    This is what I get when I do the same nslookup:

    Non-authoritative answer:    canonical name =

  5. #5
    Join Date
    Nov 2008
    Metro Boston
    Kubuntu 19.10 Eoan Ermine

    Re: Resold Broken

    If you edit resolv.conf manually, chances are good the edits will be lost the next time you reboot.

    /etc/resolv.conf should read:
    options edns0
    and it may have a "search" entry if your computers are in a domain.

    In /etc/systemd/resolved.conf you can manually specify name servers with entries like
    Then run "sudo systemctl restart systemd-resolved". This works if the nameserver entry in resolv.conf is

    If the computer gets its DNS information from DHCP during boot, then you shouldn't need to specify DNS entries in resolved.conf at all.
    Last edited by SeijiSensei; January 16th, 2020 at 07:50 PM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts