Results 1 to 4 of 4

Thread: Disable touchpad

  1. #1
    Join Date
    Nov 2009
    Beans
    4

    Disable touchpad

    My touchpad sometime interfere with my writings (probably because of me touching it inadvertedly) so I want to disable it.

    I found this nice setting for Ubuntu: http://ubuntuguide.net/disable-touch...tu-12-04-12-10, but in Lubuntu the setting do not contains something like this in keyboard and mouse section.

    There is a way to do it?

    (I'm on 19.10)

    Thank you

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    668
    Distro
    Ubuntu

    Re: Disable touchpad

    Different Desktop Environments deal differently with input devices and may have different settings. The setting you mentioned seems to be specific to Unity. I couldn't find anything similar in the current Ubuntu 19.10 (Gnome). It may never have been in Lubuntu.

    You can install a third-party software that includes among others the "disable touchpad when typing" called touchpad-indicator that resides in the system tray:

    Code:
    sudo add-apt-repository ppa:atareao/atareao
    sudo apt update
    sudo apt install touchpad-indicator
    Open it from the Accessories menu, right-click the icon and select Preferences. In the Actions tab you can enable the required feature (cf. attached image)
    Attached Images Attached Images
    Last edited by CelticWarrior; January 16th, 2020 at 12:04 AM. Reason: grammar

  3. #3
    Join Date
    Nov 2009
    Beans
    285
    Distro
    Ubuntu Studio 19.04 Disco Dingo

    Re: Disable touchpad

    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

  4. #4
    Join Date
    Nov 2009
    Beans
    4

    Re: Disable touchpad

    Quote Originally Posted by gdesilva View Post
    Yes, this was useful!

    And I also understood the problem with the other solution: my touchpad is recognized as a "keyboard mouse" (so other touchpad solutions seems not working)!

    Code:
    $ xinput
    ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ SINO WEALTH USB KEYBOARD Mouse            id=11   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]                                                                                                                
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]                                                                                                                
        ↳ Power Button                              id=8    [slave  keyboard (3)]                                                                                                                
        ↳ USB 2.0 Camera: USB 2.0 Camera            id=9    [slave  keyboard (3)]                                                                                                                
        ↳ SINO WEALTH USB KEYBOARD                  id=10   [slave  keyboard (3)]                                                                                                                
        ↳ SINO WEALTH USB KEYBOARD System Control   id=12   [slave  keyboard (3)]                                                                                                                
        ↳ SINO WEALTH USB KEYBOARD Wireless Radio Control   id=13   [slave  keyboard (3)]                                                                                                        
        ↳ SINO WEALTH USB KEYBOARD Consumer Control id=14   [slave  keyboard (3)]
        ↳ bytcr-rt5651 Headset                      id=15   [slave  keyboard (3)]
        ↳ Intel HID events                          id=16   [slave  keyboard (3)]
        ↳ gpio-keys                                 id=17   [slave  keyboard (3)]

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •