Results 1 to 3 of 3

Thread: Squid memory usage increase overtime, proxies slows down

  1. #1
    Join Date
    Jan 2020
    Beans
    1

    Squid memory usage increase overtime, proxies slows down

    Hello guys

    Running squid on ubuntu 16

    When I first start the program, the proxies are at a good speed (below
    100ms)

    after about 5 mins then memory usage of squid increases greatly, then the
    proxies slow down to 1000ms+

    my access log is getting spammed by the follow message ( I have no idea what
    this means) I dont have a user named kaiz9n9d9

    1578959115.266 0 216.115.184.251 TCP_DENIED/407 4130 CONNECT
    www.supremenewyork.com:443 kaiz9n9d9 HIER_NONE/- text/html
    1578959115.270 0 216.115.184.251 TCP_DENIED/407 4020 CONNECT
    www.supremenewyork.com:443 - HIER_NONE/- text/html
    1578959115.272 0 216.115.184.251 TCP_DENIED/407 4130 CONNECT
    www.supremenewyork.com:443 kaiz9n9d9 HIER_NONE/- text/html
    1578959115.276 0 216.115.184.251 TCP_DENIED/407 4020 CONNECT
    www.supremenewyork.com:443 - HIER_NONE/- text/html
    1578959115.277 0 216.115.184.251 TCP_DENIED/407 4130 CONNECT
    www.supremenewyork.com:443 kaiz9n9d9 HIER_NONE/- text/html
    1578959115.281 0 216.115.184.251 TCP_DENIED/407 4020 CONNECT
    www.supremenewyork.com:443 - HIER_NONE/- text/html


    Currently I am running "service squid reload", every 300 seconds which keeps
    the proxies at a good speed

    But this is not a permanent fix

    When I first start squid memory usage is around 24mb, then after 5 mins
    increased to 1GB!

    Also, the access log size increases by 500 kb every second, so I have
    disabled access log for now

    Can someone please offer your advise for this issue?

    Thanks!
    Last edited by wildmanne39; 6 Days Ago at 03:06 AM. Reason: Normaolized Fonts

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    27,684
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Squid memory usage increase overtime, proxies slows down

    Hello and welcome to the forum.

    Please use the default font color and properties unless you need to highlight or draw attention to a part of your post.

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,693
    Distro
    Kubuntu Development Release

    Re: Squid memory usage increase overtime, proxies slows down

    First, where is this Squid installation running? Is it on a gateway of some sort with a public-facing IP address? What address is 216.115.184.251? Is it yours? It doesn't have reverse DNS resolution set up.

    It looks like your proxy might be configured to accept requests from outside addresses like 216.115.184.251. Is that correct? If so, I'd take care of that first. In squid.conf you should have an acl that defines your internal network, and an http_access rule that limits access to the addresses in that acl.
    Code:
    acl localnet mynetwork 192.168.50.0/24
    http_access allow mynetwork
    http_access deny all
    Does this machine have a firewall like a set of iptables rules? If so, it must be allowing external connections to port 3128. That's not good either. I'd remove whatever rule permits that from your iptables ruleset. In fact, I'd review your entire ruleset to make sure only authorized connections from external IP addresses are permitted.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •