Results 1 to 2 of 2

Thread: New install, no speaker sound but headphone sound

  1. #1
    Join Date
    Jan 2020

    New install, no speaker sound but headphone sound

    Hi. Iím trying to install Linux for the first time, dual-booting with Windows 10 on my HP laptop. Iíve successfully installed a few times, but Iím having problems with audio. Depending on the distro (Iíve tried Ubntu Gnome, Ubuntu Budgie, Kubuntu and Linux Mint) there is either,

    • no sound
    • Sound when booting from the usb, but not sound after I install
    • Sound via headphones, but not via the usb speakers

    GUIs seem to think sound is being played. For instance, in Ubuntu Budgie the sound settings GUI showed me the audio for a youtube video, even though I couldnít hear it.

    Iíve tried a few things to solve it but I donít really know what Iím doing. Iíve tried:

    • Force-reloading alsamixer
    • Switching sound cards in aslamixer
    • Changing volumes in alsamixer
    • Switching run=YES to run=NO after running the command
      • sudo gedit /etc/default/speech-dispatcher
      • Note: this command opened a blank file, so I think speech-dispatcher didn't previously exist

    • Uninstalling and reinstalling alsa-base and pulseaudio with these commands:
      • sudo apt remove Ėpurge alsa-base pulseaudio
      • sudo apt install alsa-base pulseaudio
      • This broke the desktop system on Kubuntu (and didnít work)

    Iím also having trouble booting into GRUB rather than Windows 10, and right-clicking, but I guess those are stories for other days...

    Currently I have Ubuntu Budgie installed.

    Any help is much appreciated!

  2. #2
    Join Date
    Nov 2008
    Magdalena,New Mexico,USA
    Ubuntu Mate Development Release

    Re: New install, no speaker sound but headphone sound

    are you sure it's not muted in ALSA mixer ??? this is a very common & easily fixed problem

    here is a little troubleshooting primer

    try it & see if this doesn't fix it.....

    here is another tip

    good luck
    Registered Linux User # 529389
    Arch Linux, MX 18.3 Linux
    my personal web page
    "If you're not living on the edge, you're taking up too much space"--Unknown

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts