Results 1 to 1 of 1

Thread: SystemD, systemd-resolved.service, resolv.conf file with „options edns0“

  1. #1
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    SystemD, systemd-resolved.service, resolv.conf file with „options edns0“

    If You use systemd-resolved.service have sudden network slowdowns or similar problems You migh have trouble with
    Code:
    options edns0
    that turns on Extension Mechanisms for DNS (EDNS(0)) (which does not work nice in many countries) in file /etc/resolv.conf. That file is, if You use that service, a symbolic link to file /run/systemd/resolve/stub-resolv.conf that is session-lasting file. If You want to remove that option for ever, restart-safe, just put # in front of that line in file /usr/lib/systemd/resolv.conf and You're done. Yes, bug is submitted several times for quite a while... It's a shame not to use such a nice service just because of this persistentcy of this-service-developer(s)... This patch I've proposed will work for ou until new upgrade of SystemD and You will have to do it again after it if You wish, if bug persists...


    Update₁: /etc/resolv.conf is again updated with unwanted option so the solution, even though edited file is intact , now, is to rename symbolic link file and create new (immutable bit set) /etc/resolv.conf containingCode:

    nameserver 127.0.0.53


    http://forum.ubuntu-rs.org/Thread-ubuntu-20-04-systemd-mreza-resolv-conf-edns0
    Last edited by zika; December 25th, 2019 at 08:51 AM.
    Ignota nulla curatio morbi.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •