Results 1 to 6 of 6

Thread: Deja-Dup not able to connect to Google Drive

  1. #1
    Join Date
    Apr 2008
    Beans
    2

    Deja-Dup not able to connect to Google Drive

    Hello,

    I was previously able to use Deja-Dup to backup to my google drive folder in 18.04. After upgrading to 19.10, I now get this error "Could not log into Google servers. OK" (Picture attached.) This error comes up immediately, prior to being asked for any account information/passwords/etc.

    Screenshot from 2019-12-14 12-49-09.png

    I am already logged into my Google account via Gnome, and can access my Google drive folder in Nautilus.

    I cannot seem to find any additional error messages to clarify what is the problem.

    Any assistance or thoughts would be much appreciated.

    Thanks!

    -kevin

  2. #2
    Join Date
    Dec 2019
    Beans
    2

    Re: Deja-Dup not able to connect to Google Drive

    Same problem here

  3. #3
    Join Date
    Dec 2019
    Beans
    1

    Re: Deja-Dup not able to connect to Google Drive

    I have this problem too:

    Ubuntu 19.10
    Déjà Dup Backup Tool 40.1

  4. #4
    Join Date
    Nov 2017
    Beans
    1

    Re: Deja-Dup not able to connect to Google Drive

    Deja-Dup changed the backend to PyDrive from gvfs to talk to Google Drive.
    As of today Ubuntu has not packaged pydrive and the package is not in the repository.

    To work around this for now, I recommend trying the snap, which does not have this problem:
    snap install deja-dup --classic

    or as I did install PyDrive using pip.
    sudo pip3 install PyDrive

  5. #5
    Join Date
    Dec 2019
    Beans
    2

    Talking Re: Deja-Dup not able to connect to Google Drive

    Quote Originally Posted by lonelasso View Post
    Deja-Dup changed the backend to PyDrive from gvfs to talk to Google Drive.
    As of today Ubuntu has not packaged pydrive and the package is not in the repository.

    To work around this for now, I recommend trying the snap, which does not have this problem:
    snap install deja-dup --classic

    or as I did install PyDrive using pip.
    sudo pip3 install PyDrive
    Thank you very much lonelaso!
    Is there any advantages in using PyDrive? Absolute ignorant here.

  6. #6
    Join Date
    Apr 2008
    Beans
    2

    Re: Deja-Dup not able to connect to Google Drive

    Thanks for the assistance.

    Adding PyDrive was not sufficient. I continued to receive the same error message. Is it possible there is something else I also need to install? (I have a relatively clean install of 19.10.)

    Installing the classic version from snap did work, however. So I'm going with that for now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •