Results 1 to 4 of 4

Thread: Dont Know how to Clasify my Problem

  1. #1
    Join Date
    Dec 2019

    Dont Know how to Clasify my Problem

    I do not have any programming experience neither do I have any experience with Linux
    I am not sure how to explain my problem / issue / ignorance so please bear with me.
    I recently installed Ubuntu 18.04 on my laptop with Windows 7 as a dual boot.
    I am interested in listening to Digital Radio Mondial (DRM) used by many radio broadcasters. For those interested, I use the web site to log into receivers from around the world.
    To listen on Windows 7 there is a Windows specific program which I use successfully.
    To listen to DRM on Ubuntu we need to install a program called DREAM specific to Linux.
    For this I had gone to Github ( and copied and pasted it to my Terminal on Ubuntu. Is this Correct ?
    If this is correct then how do I make DREAM run ?
    If this is wrong then how do I use the code on Github to run DREAM with Ubuntu ?
    Please if someone can help.

  2. #2
    Join Date
    Aug 2011
    51.8° N 5.8° E
    Xubuntu 20.04 Focal Fossa

    Re: Dont Know how to Clasify my Problem

    That script hasn't been updated in over two years, so it's a bit old. Furthermore, it will download, build and install everything manually, which means doing things the hard way and no automatic updates. That is really the last resort to install anything on Ubuntu.

    Dream uses libfaad2 to do the actual decoding of audio streams. The script you linked to will install libfaad2 version 2.7. On Ubuntu 18.04, you can get libfaad2 version 2.8.8 from the repositories. I see that the vlc media player depends on libfaad2, so I assume that vlc can play digital radio mondiale streams. I never tried it myself, but I think that's the best way to make this work.

    BTW, the link in your post doesn't work. You swapped around the target and the link name.

  3. #3
    Join Date
    Jun 2009
    SW Forida

    Re: Dont Know how to Clasify my Problem

    I have a tiny app that used to use qt4 & webkit. My own python browser with some background automation, so I can push a button to change links & display info from local sqlite db.

    But I have updated it to qt5 & webengine, so your link is installing old versions of just about everything.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #4
    Join Date
    Jul 2019
    Beauvais France
    Ubuntu 20.04 Focal Fossa

    Re: Dont Know how to Clasify my Problem

    Thanks for the link.
    It worked for me but I have yet to try the software.
    dream is located in /usr/local/bin
    Another way to receive DRM is swradio here:
    The APPimage file worked for me with an SDRplay device.
    Last edited by hk42; December 21st, 2019 at 10:17 PM.
    Happy user of Ubuntu-20.04 on a Beelink BT3pro mini PC

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts