Results 1 to 2 of 2

Thread: Dell XPS 13 9350 - Only 1.8GiB of RAM recognized out of 8GiB after install

  1. #1
    Join Date
    Dec 2019
    Beans
    1

    Dell XPS 13 9350 - Only 1.8GiB of RAM recognized out of 8GiB after install

    Sort of a weird situation, but I figured someone might have some ideas. I have a Dell XPS 13 9350 that I'd been running Ubuntu on just fine for the past month or so. The system has 8GiB of RAM on it and this previously was recognized just fine. The other day, I decided to tinker and install Manjaro onto the system. After that install, I had issues with the system freezing and Firefox crashing any time I tried to open something. After a day or so of trying to work around this, I decided to reinstall Ubuntu because it was stable and I knew it worked on my system. As I began to install Ubuntu, I started running into an issue where the installer would freeze up randomly and I'd have to exit out and restart. Eventually, I got it to install but when I logged in, I noticed the system was super slow and it was freezing up and crashing apps just like Manjaro previously had. Curious, I looked at my system settings and noticed that Ubuntu was only recognizing 1.8GiB of memory where previously it had recognized 8GiB. So with that, I figured maybe trying to install version 19.10, which had previously worked fine, might be the issue, so I attempted to install 18.04. Same issue came up.

    Next, I tried PureOS, as the installation is quick and was less likely to freeze up on me. After install, same issue, only 1.8GiB of memory recognized. So I tried Manjaro again, but this time went with gnome instead of xfce which I'd previously installed. Same issue. So I ran the Diagnostics from the boot screen and it recognized 8GiB of RAM and passed all tests. Thoroughly confused, I decided to reinstall Windows on the laptop as that would let me see if it was a hardware issue that the tests wasn't detecting. After install Windows, I looked at the system information and it had 8GiB of memory there and ran perfectly fine. So here I am, trying to figure out why Ubuntu (and all other distros) aren't recognizing the RAM on the device suddenly.

    If I run 'free' I see the following:
    total used free shared buff/cache available
    Mem: 1909166 660552 114892 582524 1133672 438040
    Swap: 0 0 0

    If I run 'free -m' I see:

    total used free shared buff/cache available
    Mem: 1864 684 144 518 1035 437
    Swap: 0 0 0

    If I run 'sudo lshw -class memory' I see:

    *-memory
    description: System Memory
    physical id: 39
    slot: System board or motherboard
    size: 8GiB


    So - Anyone have any ideas?

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,238
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Dell XPS 13 9350 - Only 1.8GiB of RAM recognized out of 8GiB after install

    HI, welcome to the fora.

    Code:
    free -h
    is usually easier to read.

    Let's see the complete hardware by running
    Code:
    sudo lshw -sanitize > lshw.txt
    Please post lshw.txt in CODE tags.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •