Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Ubuntu 16.04 GUI not working after upgrade

  1. #11
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,440
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Ubuntu 16.04 GUI not working after upgrade

    Windows 7 is out of support. Are you sure that you want to keep it?
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  2. #12
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,932
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Ubuntu 16.04 GUI not working after upgrade

    It might work, but you'll need the 64-bit version. Replace the i386 in the wget commands with amd64.

    Personally, I'd perform a fresh install. And the fact that that old Windows install still works doesn't guarantee that there's no physical hard drive problem in the Ubuntu partition. It uses a different part of the hard drive. But I agree, the diagnosis "broken hard drive" is a hunch, not a guarantee.
    Last edited by Impavidus; January 15th, 2020 at 05:05 PM.

  3. #13
    Join Date
    Nov 2019
    Beans
    8

    Re: Ubuntu 16.04 GUI not working after upgrade

    oh ok, I thought since I have intel and not AMD I should replace it. With the original command I get some progress

    Code:
    travelshark@Sharkmove:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
    --2020-01-15 21:04:02--  https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
    Resolving launchpad.net (launchpad.net)... 91.189.89.222, 91.189.89.223, 2001:67c:1560:8003::8004, ...
    Connecting to launchpad.net (launchpad.net)|91.189.89.222|:443... connected.
    HTTP request sent, awaiting response... 303 See Other
    Location: https://launchpadlibrarian.net/259142419/libappstream3_0.9.4-1ubuntu1_amd64.deb [following]
    --2020-01-15 21:04:02--  https://launchpadlibrarian.net/259142419/libappstream3_0.9.4-1ubuntu1_amd64.deb
    Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229, 2001:67c:1560:8003::8007, ...
    Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 98708 (96K) [application/x-debian-package]
    Saving to: ‘libappstream3_0.9.4-1ubuntu1_amd64.deb’
    
    libappstream3_0.9.4 100%[===================>]  96.39K  --.-KB/s    in 0.09s   
    
    2020-01-15 21:04:03 (1022 KB/s) - ‘libappstream3_0.9.4-1ubuntu1_amd64.deb’ saved [98708/98708]
    
    travelshark@Sharkmove:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb
    --2020-01-15 21:04:22--  https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb
    Resolving launchpad.net (launchpad.net)... 91.189.89.223, 91.189.89.222, 2001:67c:1560:8003::8003, ...
    Connecting to launchpad.net (launchpad.net)|91.189.89.223|:443... connected.
    HTTP request sent, awaiting response... 303 See Other
    Location: https://launchpadlibrarian.net/259142418/appstream_0.9.4-1ubuntu1_amd64.deb [following]
    --2020-01-15 21:04:22--  https://launchpadlibrarian.net/259142418/appstream_0.9.4-1ubuntu1_amd64.deb
    Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228, 2001:67c:1560:8003::8008, ...
    Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 30134 (29K) [application/x-debian-package]
    Saving to: ‘appstream_0.9.4-1ubuntu1_amd64.deb’
    
    appstream_0.9.4-1ub 100%[===================>]  29.43K  --.-KB/s    in 0.03s   
    
    2020-01-15 21:04:23 (868 KB/s) - ‘appstream_0.9.4-1ubuntu1_amd64.deb’ saved [30134/30134]
    
    travelshark@Sharkmove:~$ sudo dpkg -i *.deb
    [sudo] password for travelshark: 
    (Reading database ... 397531 files and directories currently installed.)
    Preparing to unpack appstream_0.9.4-1ubuntu1_amd64.deb ...
    Unpacking appstream (0.9.4-1ubuntu1) over (0.9.4-1ubuntu1) ...
    dpkg: warning: downgrading apt from 1.2.29ubuntu0.1 to 1.0.1ubuntu2
    Preparing to unpack apt_1.0.1ubuntu2_amd64.deb ...
    Unpacking apt (1.0.1ubuntu2) over (1.2.29ubuntu0.1) ...
    Preparing to unpack libappstream3_0.9.4-1ubuntu1_amd64.deb ...
    Unpacking libappstream3:amd64 (0.9.4-1ubuntu1) over (0.9.4-1) ...
    Selecting previously unselected package teamviewer.
    Preparing to unpack teamviewer_amd64.deb ...
    Unpacking teamviewer (14.4.2669) ...
    dpkg: dependency problems prevent configuration of apt:
     libapt-pkg5.0:amd64 (1.2.29ubuntu0.1) breaks apt (<< 1.1~exp14) and is installed.
      Version of apt to be configured is 1.0.1ubuntu2.
    
    dpkg: error processing package apt (--install):
     dependency problems - leaving unconfigured
    Setting up libappstream3:amd64 (0.9.4-1ubuntu1) ...
    dpkg: dependency problems prevent configuration of teamviewer:
     teamviewer depends on libqt5webkit5 (>= 5.5) | qt56-teamviewer; however:
      Package libqt5webkit5 is not installed.
      Package qt56-teamviewer is not installed.
     teamviewer depends on libqt5x11extras5 (>= 5.5) | qt56-teamviewer; however:
      Package libqt5x11extras5 is not installed.
      Package qt56-teamviewer is not installed.
     teamviewer depends on qml-module-qtquick-controls (>= 5.5) | qt56-teamviewer; however:
      Package qml-module-qtquick-controls is not installed.
      Package qt56-teamviewer is not installed.
     teamviewer depends on qml-module-qtquick-dialogs (>= 5.5) | qt56-teamviewer; however:
      Package qml-module-qtquick-dialogs is not installed.
      Package qt56-teamviewer is not installed.
    
    dpkg: error processing package teamviewer (--install):
     dependency problems - leaving unconfigured
    Setting up appstream (0.9.4-1ubuntu1) ...
    AppStream cache update completed, but some metadata was ignored due to errors.
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for libc-bin (2.23-0ubuntu10) ...
    Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
    Processing triggers for mime-support (3.59ubuntu1) ...
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
    Errors were encountered while processing:
     apt
     teamviewer
    travelshark@Sharkmove:~$ sudo apt-get update
    Hit http://archive.ubuntu.com xenial InRelease
    Get:1 http://security.ubuntu.com xenial-security InRelease [109 kB]            
    Hit http://archive.canonical.com xenial InRelease                              
    Get:2 http://archive.ubuntu.com xenial/main amd64 Packages [1,201 kB]          
    Get:3 http://security.ubuntu.com xenial-security/main amd64 Packages [806 kB]  
    Hit http://archive.canonical.com xenial/partner amd64 Packages                 
    Hit http://archive.canonical.com xenial/partner i386 Packages                  
    Get:4 http://archive.canonical.com xenial/partner Translation-en [1,672 B]     
    Get:5 http://security.ubuntu.com xenial-security/universe amd64 Packages [467 kB]
    Hit http://archive.ubuntu.com xenial/universe amd64 Packages                   
    Get:6 http://security.ubuntu.com xenial-security/main i386 Packages [627 kB]   
    Get:7 http://archive.ubuntu.com xenial/main i386 Packages [1,196 kB]           
    Hit http://archive.ubuntu.com xenial/universe i386 Packages                    
    Get:8 http://archive.ubuntu.com xenial/main Translation-en [568 kB]
    Get:9 http://security.ubuntu.com xenial-security/universe i386 Packages [402 kB]
    Get:10 http://security.ubuntu.com xenial-security/main Translation-en [308 kB] 
    Get:11 http://archive.ubuntu.com xenial/universe Translation-en [4,354 kB]     
    Get:12 http://security.ubuntu.com xenial-security/universe Translation-en [192 kB]
    Fetched 10.2 MB in 11s (877 kB/s)                                              
    AppStream cache update completed, but some metadata was ignored due to errors.
    Reading package lists... Done
    N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
    W: Unknown Multi-Arch type 'no' for package 'compiz-core'
    W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
    W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
    W: Unknown Multi-Arch type 'no' for package 'kwin'
    W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
    W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
    W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
    W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
    W: Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation
    W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
    W: Ignoring Provides line with DepCompareOp for package php-seclib
    W: Ignoring Provides line with DepCompareOp for package php-sabre-http
    W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
    W: Unknown Multi-Arch type 'no' for package 'compiz-core'
    W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
    W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
    W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
    W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
    W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
    W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
    W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
    W: You may want to run apt-get update to correct these problems
    travelshark@Sharkmove:~$

  4. #14
    Join Date
    Nov 2019
    Beans
    8

    Re: Ubuntu 16.04 GUI not working after upgrade

    Making some progress, uninstalled teamviewer and some other programs, on the next boot got a popup about a software upgrade, did that, rebooted again.

    Still have most of the original problems of no taskbar, no title bar on programs, ctrl alt t doesn't work, I can only start programs from the terminal, I can only start one program at a time, and to boot I get a black screen with some text that I have then to CTRL ALT F2, login and use startx to get to the gui. But I can do updates and install and remove programs, so I'll get there

    Recently received this internal error report
    Code:
    atm getting a
    "Sorry, Ubuntu 16.04 has experienced an internal error.
    
    ExecutablePath    
        /sbin/plymouthd
    Package
        plymouth 0.9.2-3ubuntu13
    I'm guessing that might be another big step? any idea how to fix this one?

  5. #15
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,932
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Ubuntu 16.04 GUI not working after upgrade

    The amd64 instruction set for processors was introduced by AMD, hence the name, but the same works on Intel CPUs. This time they though about making things compatible.

    I see that your sudo dpkg -i *.deb tried to install an old version of apt. Maybe you somehow got an old .deb for apt in the current directory? In any case, not a good idea. Installation failed, but it seems apt still works and you managed to install some upgrades. That should have brought apt back the the right version.

  6. #16
    Join Date
    Nov 2019
    Beans
    8

    Re: Ubuntu 16.04 GUI not working after upgrade

    I was thinking, would a dist upgrade to 18.04 maybe be a good idea? At least it would give me a different set problems which are searchable online and maybe one of them would solve it?

  7. #17
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,440
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Ubuntu 16.04 GUI not working after upgrade

    No, a clean install of 19.10 would. It could relieve you from a wrecked Ubuntu and from Windows 7.

    Upgrading itself is a risky project and many posts in the forum deal with upgrades going haywire.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  8. #18
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,932
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Ubuntu 16.04 GUI not working after upgrade

    On a clean system, release upgrades work fine (usually). But on a broken system, release upgrades make things worse. As stated above, try a fresh install. If that doesn't work, nothing works.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •