Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: I don't understant this alert

  1. #1
    Join Date
    Jul 2016
    Beans
    41

    I don't understant this alert

    Ubuntu 16.04 LTS, running Cinnamon desktop.
    In the lower right corner of my status bar, I get an alert - red circle with horizontal white line. Opening it, I get the following message:

    An error occurred, please run Package Manager
    from the right-click menu or apt-get in a
    terminal to see what is wrong.
    The error message was: ‘Error: Opening the
    cache (E:Unable to parse package file /var/lib/
    apt/lists/
    ppa.launchpad.net_libreoffice__ppa__ubuntu__dists_ _xenial__Release
    (1). E:The package lists or status file could not
    be parsed or opened.)’. This usually means that
    your installed packages have unmet
    dependencies.

    I'm not sure what to do with it. Nothing seems to be mis-behaving. The suggestion to run apt-get does not suggest what command line options should be supplied with it. And I don't know what it means by the "right-click menu" Right-click on the 'menu' icon only configures the menu itself.

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: I don't understant this alert

    I suspect the PPA for libreoffice on xenial (16.04) has been killed off. If true, no more updates, fixes, will be available.
    The version I have installed without the PPA is:
    Code:
    libreoffice-gnome   1:5.1.6~rc2-0ubuntu1~xenial10
    Your situation will determine the best corrective action to be taken. Options are:
    • wait a few days and see of the PPA comes back.
    • do nothing. Live with the unpatched version currently installed
    • remove the PPA, update then upgrade and live with whatever version gets installed.


    I would do nothing for a week, then decide from the other two options.

  3. #3
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,408

    Re: I don't understant this alert

    If you are looking for a later version, LibreOffice supplies an appimage that will give you the latest version. I found it works very well.

    https://www.libreoffice.org/download/appimage/

    Also, there is a snap package if that suits you:

    https://snapcraft.io/libreoffice

  4. #4
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: I don't understant this alert

    Some storage limitations with Snaps:
    https://forum.snapcraft.io/t/libreof...hard-disk/6456

    May not be important at all for many people.

  5. #5
    Join Date
    Jul 2016
    Beans
    41

    Re: I don't understant this alert

    Sorry for the very late reply. I've been juggling several chainsaws, and this issue has until now been a low priority. So, how do I 'remove the ppa'? I'm not at the moment looking for updates to LO. But I do have Firefox complaining about not being the latest version and blocking my access to certain web pages - like Amazon My Music. When I try to update that with apt-get, I get the same error as reported at the start of this thread.
    Last edited by edstevens; December 13th, 2019 at 06:44 PM.

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: I don't understant this alert

    Amazon changed their DRM for music which broke all my Linux access last month sometime. I don't use it much, so it isn't the end of the world. Also, have a cheap Fire 8 tablet, so the amazon music stuff works with that. Yep, just tried A-Music and it doesn't work even after I "allow DRM"

    As for removing a PPA, there is a program that does it, or you can go into the Repo settings for the GUI package manager you use or you can go into /etc/apt/sources.d/ and find the libreoffice PPA file there, move it somewhere else.
    sudo apt update
    sudo apt upgrade
    should get the main Canonical repo version installed. In theory.

  7. #7
    Join Date
    Jun 2007
    Beans
    17,218

    Re: I don't understant this alert

    The libreoffice ppa's I see are active for 16.04 but anyway, just
    Open Software & Updates > Other
    Highlight the ppa, click remove.

    Refresh sources & see..

  8. #8
    Join Date
    Jul 2016
    Beans
    41

    Re: I don't understant this alert

    Quote Originally Posted by mc4man View Post
    The libreoffice ppa's I see are active for 16.04 but anyway, just
    Open Software & Updates > Other
    Highlight the ppa, click remove.

    Refresh sources & see..
    Now things a getting real bizzare!
    I'm running the Cinnamon desktop. I click on "menu" in the task bar, then select "Administration", then "Software Updater" ... and absolutely nothing happens. Nothing opens.

  9. #9
    Join Date
    Jul 2016
    Beans
    41

    Re: I don't understant this alert

    Quote Originally Posted by TheFu View Post
    Amazon changed their DRM for music which broke all my Linux access last month sometime. I don't use it much, so it isn't the end of the world. Also, have a cheap Fire 8 tablet, so the amazon music stuff works with that. Yep, just tried A-Music and it doesn't work even after I "allow DRM"

    As for removing a PPA, there is a program that does it, or you can go into the Repo settings for the GUI package manager you use or you can go into /etc/apt/sources.d/ and find the libreoffice PPA file there, move it somewhere else.
    sudo apt update
    sudo apt upgrade
    should get the main Canonical repo version installed. In theory.
    I have no /etc/apt/sources.d, though I do have a /etc/apt/sources.list.d
    ed@ed-Gazelle-00:/etc/apt$ pwd
    /etc/apt
    ed@ed-Gazelle-00:/etc/apt$ ll
    total 56
    drwxr-xr-x 7 root root 4096 Mar 27 2019 ./
    drwxr-xr-x 158 root root 12288 Jun 22 14:27 ../
    drwxr-xr-x 2 root root 4096 Jun 20 06:09 apt.conf.d/
    drwxr-xr-x 2 root root 4096 Mar 14 2019 auth.conf.d/
    drwxr-xr-x 2 root root 4096 Apr 14 2016 preferences.d/
    -rw-rw-r-- 1 root root 3010 Dec 23 2018 sources.list
    drwxr-xr-x 2 root root 4096 Dec 23 2018 sources.list.d/
    -rw-rw-r-- 1 root root 3010 Dec 23 2018 sources.list.save
    -rw-r--r-- 1 root root 12255 Jul 19 2016 trusted.gpg
    drwxr-xr-x 2 root root 4096 Dec 23 2018 trusted.gpg.d/
    ed@ed-Gazelle-00:/etc/apt$

    And within sources.list.d
    ed@ed-Gazelle-00:/etc/apt/sources.list.d$ pwd
    /etc/apt/sources.list.d
    ed@ed-Gazelle-00:/etc/apt/sources.list.d$ ll
    total 36
    drwxr-xr-x 2 root root 4096 Dec 23 2018 ./
    drwxr-xr-x 7 root root 4096 Mar 27 2019 ../
    -rw-r--r-- 1 root root 274 Dec 23 2018 libreoffice-ubuntu-ppa-xenial.list
    -rw-r--r-- 1 root root 274 Dec 23 2018 libreoffice-ubuntu-ppa-xenial.list.save
    -rw-r--r-- 1 root root 140 Dec 23 2018 system76-dev-ubuntu-stable-xenial.list
    -rw-r--r-- 1 root root 140 Dec 23 2018 system76-dev-ubuntu-stable-xenial.list.save
    -rw-r--r-- 1 root root 0 Dec 16 2016 tualatrix-ubuntu-ppa-xenial.list
    -rw-r--r-- 1 root root 0 Dec 16 2016 tualatrix-ubuntu-ppa-xenial.list.save
    -rw-r--r-- 1 root root 136 Dec 23 2018 webupd8team-ubuntu-java-xenial.list
    -rw-r--r-- 1 root root 175 Dec 23 2018 xenial-partner.list
    -rw-r--r-- 1 root root 175 Dec 23 2018 xenial-partner.list.save
    ed@ed-Gazelle-00:/etc/apt/sources.list.d$

    The sudo apt commands returned a variety of errors, which may or may not be expected. Of course they are buried in a very lengthy output.

  10. #10
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: I don't understant this alert

    My mistake. /etc/apt/sources.list.d/ is the directory. I use tab-completion for stuff like this so I don't have to remember exact details, just enough to discover the correct answer while typing.

    I'd move the libreoffice-ubuntu-ppa-xeni* files somewhere else.
    Then do the update/upgrade process I wrote above.

    If everything works ok, delete the 2 files you moved. If not, put them back and do the update/upgrade process again. Shouldn't be any worse than it was.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •