Results 1 to 5 of 5

Thread: kvm machines won't start after upgrade with security patches today

  1. #1
    Join Date
    Nov 2019
    Beans
    3

    kvm machines won't start after upgrade with security patches today

    A heads up that after an `apt upgrade` today of a 16.04 host, two virtual machines would not boot.

    One is a fully-patch updated 16.04 vm and the other is a windows 8.1 vm.

    Nothing obvious in the logs.

    The host is: model name : Intel(R) Core(TM)2 Quad CPU Q9550 @ 2.83GHz

    The vms are not overriding the cpu.

    The 16.04 vm just sticks on the boot screen.

    The windows one goes into a boot repair loop, complaining about:
    SYSTEM THREAD EXCEPTION NOT HANDLED

    Can't take the time now to debug further but thought I might give people a heads-up.

    Here are the changes installed by the update:

    Code:
    committing changes in /etc after apt run
    
    
    Package changes:
    -grub-common 2.02~beta2-36ubuntu3.22 amd64
    +grub-common 2.02~beta2-36ubuntu3.23 amd64
    -grub-pc 2.02~beta2-36ubuntu3.22 amd64
    -grub-pc-bin 2.02~beta2-36ubuntu3.22 amd64
    -grub2-common 2.02~beta2-36ubuntu3.22 amd64
    +grub-pc 2.02~beta2-36ubuntu3.23 amd64
    +grub-pc-bin 2.02~beta2-36ubuntu3.23 amd64
    +grub2-common 2.02~beta2-36ubuntu3.23 amd64
    -intel-microcode 3.20190618.0ubuntu0.16.04.1 amd64
    +intel-microcode 3.20191112-0ubuntu0.16.04.2 amd64
    -linux-generic-hwe-16.04 4.15.0.66.86 amd64
    +linux-generic-hwe-16.04 4.15.0.69.89 amd64
    -linux-headers-generic-hwe-16.04 4.15.0.66.86 amd64
    +linux-headers-4.15.0-69 4.15.0-69.78~16.04.1 all
    +linux-headers-4.15.0-69-generic 4.15.0-69.78~16.04.1 amd64
    +linux-headers-generic-hwe-16.04 4.15.0.69.89 amd64
    +linux-image-4.15.0-69-generic 4.15.0-69.78~16.04.1 amd64
    -linux-image-generic-hwe-16.04 4.15.0.66.86 amd64
    +linux-image-generic-hwe-16.04 4.15.0.69.89 amd64
    +linux-modules-4.15.0-69-generic 4.15.0-69.78~16.04.1 amd64
    +linux-modules-extra-4.15.0-69-generic 4.15.0-69.78~16.04.1 amd64

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,622
    Distro
    Ubuntu

    Re: kvm machines won't start after upgrade with security patches today

    There was a regression fix that came thru:
    https://usn.ubuntu.com/4185-3/
    Seems related.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: kvm machines won't start after upgrade with security patches today

    This sort of issue is why I patch on the weekends, not during the week, except for extreme, active, attacks, that impact a specific deployed package.

  4. #4
    Join Date
    Nov 2019
    Beans
    3

    Re: kvm machines won't start after upgrade with security patches today

    Yes, I can confirm that the update fixed the problem for both vms.

  5. #5
    Join Date
    Nov 2019
    Beans
    3

    Re: kvm machines won't start after upgrade with security patches today

    Yes, I agree. Normally, I would only update on Saturday too.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •