Results 1 to 2 of 2

Thread: Some Character Keys Remapped to Junk Sequences (Ubuntu 18.04)

  1. #1
    Join Date
    Nov 2019
    Beans
    1

    Some Character Keys Remapped to Junk Sequences (Ubuntu 18.04)

    I am running Ubuntu 18.04 on a Lenovo ThinkPad E555 laptop.

    A few weeks after the installation, some (but not all) of my keys have suddenly become "remapped" to "junk sequences". Specifically, the i, k, and comma keys.

    When I press i, the sequence `q*ew6r` is printed. When I press k, the sequence `a7ds2fjk` is printed. This problem persists after reboot and occurs in all applications.

    I have ruled out a hardware issue, as my Win 10 dual boot works fine. After reinstalling Ubuntu 18.04, the keys worked fine again for some time, but the problem has now recurred for a second time.

    I have tried the following:

    • Resetting the console and keyboard configuration: `sudo dpkg-reconfigure -plow console-setup` and `sudo dpkg-reconfigure keyboard-configuration`.
    • Verifying that I do not have conflicting keyboard layout and language settings.
    • When I execute `showkey -k` to test my keyboard, pressing the i and k keys register the same key sequences that I gave above.
    • I verified num lock is off
    • I booted into a live CD, and the i,k, and comma keys work correctly.


    Given the above troubleshooting, I believe that some sort of configuration has been corrupted, perhaps by a package update?

    I understand that there are many layers between a keypress and the final processing of that keypress, and I would appreciate some guidance about how to troubleshoot this.

    Thank you for your help - both for this issue (my first actual post!) and for all the fantastic responses to other posters that have helped me over the years.

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,139
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: Some Character Keys Remapped to Junk Sequences (Ubuntu 18.04)

    Hi, welcome to the fora.

    Quote Originally Posted by akathehidden View Post
    After reinstalling Ubuntu 18.04, the keys worked fine again for some time, but the problem has now recurred for a second time.
    How does it work if you do a fresh install of 19.10?
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •