Results 1 to 7 of 7

Thread: Setting new background color in 19.10

  1. #1
    Join Date
    Apr 2014
    Beans
    79

    Setting new background color in 19.10

    I am running Ubuntu 19.10 using the Ubuntu desktop. I had set a background color for my desktop in Ubuntu 19.04. But when I try to change my background color using Settings | Background I am not given a choice of colors but rather background pictures. How can I set the background to some other color ?

  2. #2
    Join Date
    Feb 2010
    Location
    Summerwind
    Beans
    14,034
    Distro
    Ubuntu Budgie Development Release

    Re: Setting new background color in 19.10

    The option is missing in my installation as well . It looks like that feature has been removed by the Gnome developers. A work around would include creating folder with solid color background images.
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  3. #3
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,427

    Re: Setting new background color in 19.10

    Quote Originally Posted by Edward_Diener View Post
    I am running Ubuntu 19.10 using the Ubuntu desktop. I had set a background color for my desktop in Ubuntu 19.04. But when I try to change my background color using Settings | Background I am not given a choice of colors but rather background pictures. How can I set the background to some other color ?
    Hello Edward;

    For setting a desktop background color in Ubuntu 19.10 a different method is now needed:

    install and use dconf-editor utility:

    disable background images:
    navigate to: org.gnome.desktop.background.picture-options
    Be sure default value switch = off
    Click on custom value box and select 'none'. this will turn off using an image.
    Click 'Apply'

    set color:
    navigate to: org.gnome.desktop.background.primary-color
    Be sure default value switch = off
    Click on custom value and set color hexcode in format #334b32
    Click 'Apply'

    Background will change to custom color instantly.
    Last edited by Dennis N; November 9th, 2019 at 01:04 AM.

  4. #4
    Join Date
    Feb 2010
    Location
    Summerwind
    Beans
    14,034
    Distro
    Ubuntu Budgie Development Release

    Re: Setting new background color in 19.10

    Thanks Dennis, I usually use pictures , but it's good to know how to apply a solid background.
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  5. #5
    Join Date
    Apr 2014
    Beans
    79

    Re: Setting new background color in 19.10

    Quote Originally Posted by Dennis N View Post
    Hello Edward;

    For setting a desktop background color in Ubuntu 19.10 a different method is now needed:

    install and use dconf-editor utility:

    disable background images:
    navigate to: org.gnome.desktop.background.picture-options
    Be sure default value switch = off
    Click on custom value box and select 'none'. this will turn off using an image.
    Click 'Apply'

    set color:
    navigate to: org.gnome.desktop.background.primary-color
    Be sure default value switch = off
    Click on custom value and set color hexcode in format #334b32
    Click 'Apply'

    Background will change to custom color instantly.
    Works fine. Thanks !

  6. #6
    Join Date
    Oct 2008
    Location
    Rezzoaglio (GE) Italy
    Beans
    271
    Distro
    Ubuntu Development Release

    Re: Setting new background color in 19.10

    It looks like that feature has been removed by the Gnome developers
    but in the help I see:
    Attached Images Attached Images

  7. #7
    Join Date
    Oct 2008
    Location
    Rezzoaglio (GE) Italy
    Beans
    271
    Distro
    Ubuntu Development Release

    Re: Setting new background color in 19.10

    To set a solid color background create a small picture (.jpg or .png) of the preferred color in Your Pictures folder, right click on the picture and select 'set as wallpaper'
    I submitted a bug for this problem: https://bugs.launchpad.net/ubuntu/+s...r/+bug/1862945
    if you have the same problem please confirm my bug
    Last edited by corradoventu; 4 Days Ago at 08:42 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •