Results 1 to 9 of 9

Thread: Can not set solid color as backround image GNOME 3.34.1

  1. #1
    Join Date
    Aug 2019
    Beans
    40

    Can not set solid color as backround image GNOME 3.34.1

    Can not set solid color as backround image in GNOME 3.34.1. I know how to do that, but it just does not work. I think it's a bug.

  2. #2
    Join Date
    Dec 2017
    Location
    RockyMts
    Beans
    1,170

    Re: Can not set solid color as backround image GNOME 3.34.1

    I am also running 3.34.1 and willing to give it a try if you would please post how you done this.

  3. #3
    Join Date
    Aug 2019
    Beans
    40

    Background solid color with gsettings

    I did this:

    gsettings set org.gnome.desktop.background primary-color '#000000'
    gsettings set org.gnome.desktop.background secondary-color '#000000'
    gsettings set org.gnome.desktop.background color-shading-type 'solid'

    But no changes: I believe I need to set the picture-uri value to an empty string, but I don't know how to do that.

    What does mean "picture-uri"?

  4. #4
    Join Date
    Feb 2015
    Beans
    Hidden!
    Distro
    Ubuntu Mate 18.04 Bionic Beaver

    Re: Background solid color with gsettings

    I am not on gnome or even ubuntu at the moment but my current install here has the dconf settings for gnome and the next code blanked out the picture-uri setting for me...

    Code:
    gsettings set org.gnome.desktop.background picture-uri ""
    What does mean "picture-uri"?
    A "URI" is "Universal Resource Identifier" as far as I'm aware. Just another name for "address" or "location" of the image being set as the background image.

    Hope it works for you. Cheers, yeti.

  5. #5
    Join Date
    Aug 2019
    Beans
    40

    Re: Background solid color with gsettings

    Quote Originally Posted by yetimon_64 View Post
    I am not on gnome or even ubuntu at the moment but my current install here has the dconf settings for gnome and the next code blanked out the picture-uri setting for me...

    Code:
    gsettings set org.gnome.desktop.background picture-uri ""

    A "URI" is "Universal Resource Identifier" as far as I'm aware. Just another name for "address" or "location" of the image being set as the background image.

    Hope it works for you. Cheers, yeti.
    Thanks. It is supposed to work, but it did not. But I was able to make ot work via dconf-editor.
    Last edited by setonic; October 30th, 2019 at 06:40 AM.

  6. #6
    Join Date
    Aug 2019
    Beans
    40

    Re: Can not set solid color as backround image GNOME 3.34.1

    Quote Originally Posted by cruzer001 View Post
    I am also running 3.34.1 and willing to give it a try if you would please post how you done this.
    It should be pretty easy: just click on the image (where my pointer on screenshot) and you have to have an option replace it with color, but when I click nothing happens.
    Attached Images Attached Images

  7. #7
    Join Date
    Jan 2010
    Location
    Wheeling WV USA
    Beans
    1,609
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: Can not set solid color as backround image GNOME 3.34.1

    i don't know how close to this GNOME is, but in Xfce, right-click on the background and select "Desktop Settings". see if GNOME has something there.
    You can't have my Windows 95 until you pry it from my cold dead 1 GB IDE hard drive.

  8. #8
    Join Date
    Aug 2019
    Beans
    40

    Re: Can not set solid color as backround image GNOME 3.34.1

    I finally did it via dconf-editor.

  9. #9
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Can not set solid color as backround image GNOME 3.34.1

    Threads merged

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •