Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Broken Packages, Unmet Dependencies

  1. #11
    Join Date
    Mar 2007
    Beans
    502

    Re: Broken Packages, Unmet Dependencies

    If you have set your upgrade to use only LTS versions then the upgrade from 16.04 to 18.04 should operate and that is the only version you should be able to upgrade to.
    Check Software & Updates under System Setting and make sure updates is set to "long term support versions"

    You should not attempt up do any upgrade from one version to another until the current version is fully updated and configured.
    What version are you currently running?
    Code:
    lsb_release -a
    Make sure your current system is fully updated
    Code:
    sudo dpkg --configure -a
    Post your output.
    Fix any problems.
    When you post them we can attack the problems.

    I'm afraid you have mixed version on your system.
    Last edited by rsteinmetz70112; October 15th, 2019 at 05:40 AM.

  2. #12
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,751
    Distro
    Xubuntu 19.04 Disco Dingo

    Re: Broken Packages, Unmet Dependencies

    Quote Originally Posted by C.Snyder View Post
    Impavidus,
    Since Feisty Fawn I have spent most of my forum time reading as opposed to posting.
    In the text of posted replies I have seen links used to reference another thread where an issue has already been discussed.
    I do not know how to properly link threads.
    I have noticed the 4th button from the end of this Quick Reply window that does mouse-over identify as "link" but I have yet to see how it behaves.
    Open this thread in one tab of your browser, start your new thread in a second tab of your browser, copy the address in the address bar of the first tab into the text input field in the second.

    Quote Originally Posted by C.Snyder View Post
    The sudo dpkg --configure -a:
    Code:
    dpkg: error: parsing file '/var/lib/dpkg/status' near line 28511 package 'libcdr-0.1-1:amd64':
     'Depends' field, reference to 'zlib1g': error in version: epoch in version is not number
    That's a first for me. I've never seen that error before. Show what's in that file:
    Code:
    grep -A 15 'Package: libcdr' /var/lib/dpkg/status
    Also, check the health of your hard drive. Random file corruption may indicate a problem.
    https://help.ubuntu.com/community/Smartmontools
    https://help.ubuntu.com/stable/ubunt...-check.html.en

    Quote Originally Posted by C.Snyder View Post
    I am trying to fix a reinstall from a live CD of 16.04 that was a response to a highly unsuccessful upgrade to 18.04 .
    I missed that when first reading your first post. So your upgrade from 16.04 to 18.04 failed, then you reinstalled 16.04 and again attempt to upgrade? Would it not be easier to fresh install 18.04?

  3. #13
    Join Date
    Jun 2016
    Beans
    15

    Re: Broken Packages, Unmet Dependencies

    rsteinmetz,
    lsb_release -a
    Code:
    No LSB modules are available.
    Distributor ID:    Ubuntu
    Description:    Ubuntu 16.04.6 LTS
    Release:    16.04
    Codename:    xenial
    sudo dpkg --configure -a:
    Code:
    dpkg: error: parsing file '/var/lib/dpkg/status' near line 28511 package 'libcdr-0.1-1:amd64':
     'Depends' field, reference to 'zlib1g': error in version: epoch in version is not number
    And...last evening I ventured into Ask Ubuntu and read up on the issue that the no-entry symbol shows regarding a "MergeList /var/lib/dpkg/status" and a "libcdr-0.1-1".
    I'll mention it so as to keep the forum apprised of what has been introduced into the process up to this posting.

    One thumbnail mentioned having to repeat the update command or at least what I remember as an "update". I do not remember the exact command I ran twice but each time there were positive responses as in some incremental progress. I have resorted to copying the outputs from Terminal into a document in order to keep things straight, to be accurate when I answer your questions and to avoid being vague about such items.

    Another tackled the MergeList issue with:
    sudo rm -vf /var/lib/apt/lists/*

    and then a:
    sudo apt-get update:
    And at the end of a list of 90 reloaded packages….
    Code:
    Reading package lists... Error! W: The repository 'cdrom://Ubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801) xenial Release' does not have a Release file. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for repository creation and user configuration details. E: Failed to fetch cdrom://Ubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)/dists/xenial/main/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs E: Some index files failed to download. They have been ignored, or old ones used instead. E: Problem parsing dependency Depends E: Error occurred while processing libcdr-0.1-1 (NewVersion2) E: Problem with MergeList /var/lib/dpkg/status E: The package lists or status file could not be parsed or opened.
    I am going to sign off this evening but first answer Impavidus' post
    And to you my Thanks

  4. #14
    Join Date
    Jun 2016
    Beans
    15

    Re: Broken Packages, Unmet Dependencies

    Impavidus,

    Copy that copy it. I thought there was some magic button to push.

    grep -A 15 'Package: libcdr' /var/lib/dpkg/status:
    Code:
    Binary file /var/lib/dpkg/status matches
    "Also, check the health of your hard drive. Random file corruption may indicate a problem."
    When I had to resurrect my Linux partition I did go into the Windoz to get to the UEFI (great the way MS changed that from 8.0 to 8.1) so that I could boot from the optical drive.
    When I got the live CD to boot I did use the Discs function to look into the HDD. I did use the Assessment function and saw all "OK"s. The possibility that I had some hardware problem as the basis of this did cross my mind.
    I appreciate the links to the Smartmontools and the "Check your" page. I'll do some reading there as well.

    The Windoz came with the laptop and I have tried to maintain it's value in the machine. In this instance it did come in handy although I cringe every time I "open the windows".
    I cannot argue with the fresh install approach. I have always had no problems in doing an upgrade through the on-board software updater's upgrade prompt.
    My HDD check with Discs was an attempt to see if the partitioning had been messed up by all of my trips through the Windowz.

    I am a little disappointed with the Package Manager as opposed to my previous experience with Synaptic. I just figure that I still have yet to learn how to get it to function.

    Once again,
    Thank you.

  5. #15
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,751
    Distro
    Xubuntu 19.04 Disco Dingo

    Re: Broken Packages, Unmet Dependencies

    Quote Originally Posted by C.Snyder View Post
    grep -A 15 'Package: libcdr' /var/lib/dpkg/status:
    Code:
    Binary file /var/lib/dpkg/status matches
    ?????
    On my computer that's a plain text file:
    Code:
    $ grep -A 15 'Package: libcdr' /var/lib/dpkg/status
    Package: libcdr-0.1-1
    Status: install ok installed
    Priority: optional
    Section: libs
    Installed-Size: 670
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: amd64
    Multi-Arch: same
    Source: libcdr
    Version: 0.1.5-1
    Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libicu63 (>= 63.1-1~), liblcms2-2 (>= 2.2+git20110628), librevenge-0.0-0, libstdc++6 (>= 5.2), zlib1g (>= 1:1.1.4)
    Description: library for reading and converting Corel DRAW files
     libcdr is a library and a set of tools for reading and converting binary files
     produced by Corel DRAW.
     .
     libcdr currently supports just CDR files from V7 to X3 and the following
    If grep thinks it's a binary file, you may have some serious filesystem corruption. Maybe you can try it again, forcing grep to consider it as a plain text file:
    Code:
    grep -a -A 15 'Package: libcdr' /var/lib/dpkg/status
    Or have a look at it in a text editor. Maybe it's just a very weird encoding issue.

    With this amount of damage, I think a fresh install would be best. And I still don't trust your hard drive. I use smartmontools to occasionally run the extended test (takes about an hour with my hard drive), then view the results.

    BTW, you can disable the cdrom repository.

  6. #16
    Join Date
    Jun 2016
    Beans
    15

    Re: Broken Packages, Unmet Dependencies

    Reading the output from your machine and noting the spacing between characters caused me to try the command again being careful with the spaces and it resulted in the same as before.

    So, moving onto your suggestion of adding the "-a" resulted in:
    Code:
    Package: libcdr-0.1-1
    Status: install ok installed
    Priority: optional
    Section: libs
    Installed-Size: 650
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: amd64
    Multi-Arch: same
    Source: libcdr
    Version: 0.1.2-2ubuntu2
    Replaces: libcdr-0.1-1v5
    Provides: libcdr-0.1-1v5
    Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libicu55 (>=  55.1-1~), liblcms2-2 (>= 2.2+git20110628), librevenge-0.0-0,  libstdc++6 (>= 5.2), zlib1g (>= �:1.1.4)mConflicLs: libcr-0.1-1�5
    Descr�ption: �ibrary �or read�ng and monvertiIg Corel�DRAW fi6es
    lib7dr is a�library�and a s�t of to�ls for 6eading �nd conv�rting b�nary fespro�uced byXCorel DLAW.
    There's that "libcdr" reference. And then, those diamonds with the ? mark inside. Can't say I ever seen that one before.

    I'll see if I can get smartmontools to load, install and dig into the HDD. Maybe not, just tried and got system error and details such as before about the libcdr.
    To disable the repository? Not sure how to go about that. It is now on my reading list.
    The continuing system related errors are warming me up to try another attempt to install the 16.04. I feel that it would be better to just cut to the 18.04 LTS instead.
    Before any of that I will boot to the live CD that I have and see if I can access the smartmontools first. Maybe it is time to replace the HDD before any of this.

    Thanks for the ongoing analysis.

  7. #17
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,751
    Distro
    Xubuntu 19.04 Disco Dingo

    Re: Broken Packages, Unmet Dependencies

    After the zlib1g in your output I see about 30 errors, caused by bytes that got replaced by random other bytes. If this leads to an invalid byte sequence in the expected encoding, the result is a diamond with a question mark. Otherwise, you get random character substitutions (monvertiIg instead of converting, etc.).

    Use the live disk to check the health of your hard drive. Keep in mind that the smart status is an indication, but not a guarantee that the hard drive is either broken or not. How old is that hard drive?

    Do you have backups of your important files? I guess you do, as you recently did a fresh install. If not, try to make them right away, before more data corruption happens.

  8. #18
    Join Date
    Jun 2016
    Beans
    15

    Re: Broken Packages, Unmet Dependencies

    Impavidus,

    Over the weekend I did boot to the Live CD and downloaded the Smartmontools. It took some additional research to work my way into the extracted .gz but I was not successful in getting the application to run in terminal. Insufficient knowledge base and time available.
    While still running the Live CD, I did open the Discs utility and used it's SMART function to the HDD checker's "extended" option. After the wait, the results were all OK.
    And to answer your question, the drive is 5 yrs old. I should note that earlier this year I did have to replace the optical drive in this ASUS laptop.
    I'll try a fresh install later this week.
    Thanks

  9. #19
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    4,751
    Distro
    Xubuntu 19.04 Disco Dingo

    Re: Broken Packages, Unmet Dependencies

    Yes, do that. Just make sure you've got excellent, versioned backups on an external drive.

  10. #20
    Join Date
    Mar 2007
    Beans
    502

    Re: Broken Packages, Unmet Dependencies

    Code:
    apt upgrade
    Only upgrades the current version to the most recent packages.
    It does not upgrade to a new release.

    To upgrade beyond 16.04 you need to do-release-upgrade however if you do that you should make sure you are upgrading to 18.04LTS since all of the intervening versions are EOL. You should probably do that soon since 16.04 is already EOL and may be unavailable soon.

    There still seem to be some things not quite working.
    Redoing the same commands you used to get this far will probably fix the rest of it.

    If you are able to download from the Internet I'd suggest removing the cdrom from your sources, that is an old version and probably not much use.

    You may want to try to reinstall zlib1g - looks like you have an old version then reinstall libcdr-0.1-1:amd64

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •