Results 1 to 6 of 6

Thread: SSH issue

  1. #1
    Join Date
    Jan 2012
    Beans
    4

    SSH issue

    Hello,
    I have an odd situation, when I setup SSH on a Ubuntu Mate 18.04.3 LTS it works fine, I can access the client remotely. if i log off the Ubuntu Mate 18.04.3 LTS client i can no longer ssh it remotly. unless i physically logon to the Ubuntu Mate 18.04.3 LTS client

    tia,
    GFlanagan

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: SSH issue

    Do you have HOME directory encryption enabled?

    What is the ssh server running?

  3. #3
    Join Date
    Jan 2012
    Beans
    4

    Re: SSH issue

    Quote Originally Posted by TheFu View Post
    Do you have HOME directory encryption enabled?

    What is the ssh server running?
    Thanks for you feed back. Home drive is not encrypted. doing a ls -A /home does not show he home drive is encrypted.

    I have two other laptops running the same OS, one wired and one wireless, no problem. However the client giving me the ssh problem is i386, not sure if that is the difference.

    also, i tried the client both wired and wireless and no luck.

    thanks!

  4. #4
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: SSH issue

    I have an i686 desktop running 16.04. i386 support was dropped about 10 yrs ago, methinks. No issues with it ssh'ing into any other systems that support ed25519 ssh-keys.

    Please be EXTREMELY clear. What is the client and what is the server?

    Does ssh -vvvv show anything wrong?

  5. #5
    Join Date
    Jan 2012
    Beans
    4

    Re: SSH issue

    ssh -vvvv tells me I using the wrong otpion
    root@user-1000HE:~/Downloads# ssh -vvvv
    usage: ssh [-46AaCfGgKkMNnqsTtVvXxYy] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-E log_file] [-e escape_char]
    [-F configfile] [-I pkcs11] [-i identity_file]
    [-J [user@]host[ort]] [-L address] [-l login_name] [-m mac_spec]
    [-O ctl_cmd] [-o option] [-p port] [-Q query_option] [-R address]
    [-S ctl_path] [-W hostort] [-w local_tun[:remote_tun]]
    [user@]hostname [command]

    This client I am ssh'ing from is a windows 10 box and the client i am ssh'ing to is an ubuntu 18.04 i386 box

    root@user-1000HE:~/Downloads# lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 18.04.3 LTS
    Release: 18.04
    Codename: bionic
    root@user-1000HE:~/Downloads#

    root@user-1000HE:~/Downloads# sudo systemctl status ssh.service
    ● ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
    Active: active (running) since Sat 2019-10-12 11:24:12 EDT; 2h 15min ago
    Main PID: 971 (sshd)
    Tasks: 1 (limit: 4505)
    CGroup: /system.slice/ssh.service
    └─971 /usr/sbin/sshd -D


    Oct 12 12:50:43 user-1000HE sshd[971]: Received SIGHUP; restarting.
    Oct 12 12:50:44 user-1000HE sshd[971]: Server listening on 0.0.0.0 port 22.
    Oct 12 12:50:44 user-1000HE sshd[971]: Server listening on :: port 22.
    Oct 12 12:50:44 user-1000HE systemd[1]: Reloading OpenBSD Secure Shell server.
    Oct 12 12:50:44 user-1000HE sshd[971]: Received SIGHUP; restarting.
    Oct 12 12:50:44 user-1000HE systemd[1]: Reloaded OpenBSD Secure Shell server.
    Oct 12 12:50:44 user-1000HE sshd[971]: Server listening on 0.0.0.0 port 22.
    Oct 12 12:50:44 user-1000HE sshd[971]: Server listening on :: port 22.
    Oct 12 12:51:01 user-1000HE sshd[5676]: Accepted password for user from 172.16.0.11 port 53348 ssh2
    Oct 12 12:51:01 user-1000HE sshd[5676]: pam_unix(sshd:session): session opened for user user by (uid=0)

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: SSH issue

    Sorry, I don't know **anything** about win10, but if you don't provide the correct options to ssh, it isn't going to attempt any connection.

    ssh -vvvv userid@remote-system

    The userid needs to be the Server userid.
    The remote-system should be either an IP or DNS name that can be used to "ping". This is not necessarily the same name as 'hostname' returns or what network file sharing uses. Windows is non-standard in broadcasting that data.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •