Results 1 to 4 of 4

Thread: Wireless connection issue on particular network (19.04)

  1. #1
    Join Date
    Oct 2019
    Beans
    3

    Wireless connection issue on particular network (19.04)

    I'm experiencing issues connecting to a particular wireless network on Ubuntu 19.04. The machine works fine on other networks, and even on the problematic network via a wifi hotspot on my phone. Other devices work fine on the problematic network, including a machine running 18.04.

    I'm almost certain I've connected successfully to this network with this machine in the past, but recently seem to be experiencing issues related to the network manager - at least, if I restart the network-manager service I can connect to websites for about 30 seconds before they start hanging infinitely. Once the issues set in I can't even ping -c 4 8.8.8.8 successfully. I've checked my /etc/network/interfaces and /etc/resolv.conf against my working machine and I can't see anything obviously different, so I'm not sure where the problem lies.

    (This may be a red herring, but the problem may have started after I tried to connect to an VPN. However, it could also be that I just didn't notice until after I did that.)

    See attached for the output of the wifi diagnostic script. If anyone can point me in the right direction, it would be much appreciated.
    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2019
    Beans
    3

    Re: Wireless connection issue on particular network (19.04)

    As an additional data point, I've now tested on the same machine with an Ubuntu 19.04 live USB with no issues, so this is presumably some kind of configuration issue which only affects this network, and not a problem with the machine hardware or the router.
    Last edited by bk6u; 1 Week Ago at 11:36 AM.

  3. #3
    Join Date
    May 2014
    Location
    /home
    Beans
    8,030
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Wireless connection issue on particular network (19.04)

    See if
    Code:
    sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    systemctl restart network-manager.service
    Fixes the disconnects

  4. #4
    Join Date
    Oct 2019
    Beans
    3

    Re: Wireless connection issue on particular network (19.04)

    Thanks for the suggestion. Unfortunately that hasn't helped, but I think I've figured out why this particular network has issues (although not what's the underlying cause). In trying to ascertain what I can connect to I tried connecting to my router's admin page at 192.168.0.1 and got...the Apache server that's running on my local machine. Presumably this is the cause of all the issues, and explains why it's only an issue on this network, because it happens to use that address for DNS lookups.

    What I don't know is why this is the case. Presumably something is binding to that IP (my first thought was something in /etc/hosts or my apache config but nothing jumped out). Any suggestions as to how can I track down what is using this IP address?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •