Results 1 to 7 of 7

Thread: x11vnc fails from autoexec

  1. #1
    Join Date
    Jan 2009
    Beans
    40

    x11vnc fails from autoexec

    Kubuntu 18.04 LTS. The x11vnc starts from KDE Autoexec folder in script:

    #! /bin/sh
    x11vnc -forever -noxfixes -noxrecord -noxdamage

    After some activity in 5-10 minutes x11vnc fails. Then I start it with all same options from KDE console - it works without problem.

    What can be wrong?

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: x11vnc fails from autoexec

    I haven't a clue, but perhaps it needs to be launched detached from the parent process?
    Also it is a best practice to fully specify the complete path to any programs called in a script, not trusting the PATH. I dont use vnc, but would guess the program is in /usr/bin/

    https://www.tecmint.com/linux-process-management/ is a reference for process control. Just add an '&' to the end of the command line.

    Just a guess.

  3. #3
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    9,689

    Re: x11vnc fails from autoexec

    You can try to put a "sleep 10;" in front of it, to allow the network dust to settle before it tries to start.

  4. #4
    Join Date
    Jan 2009
    Beans
    40

    Re: x11vnc fails from autoexec

    Quote Originally Posted by TheFu View Post
    fully specify the complete path to any programs called in a script, not trusting the PATH
    But it starts nevertheless. Proper binary file - I checked. And from command line without path too.

    Quote Originally Posted by TheFu View Post
    Just add an '&' to the end of the command line.

    Just a guess.
    Added. Did not help.

    Quote Originally Posted by HermanAB View Post
    You can try to put a "sleep 10;" in front of it, to allow the network dust to settle before it tries to start.
    Interesting idea... But as you can notice - I start it from KDE Autoexec folder. That means all dust must settle. But I will try your suggestion.
    Last edited by Gourmand; 6 Days Ago at 11:32 AM.

  5. #5
    Join Date
    Jan 2009
    Beans
    40

    Re: x11vnc fails from autoexec

    Quote Originally Posted by HermanAB View Post
    You can try to put a "sleep 10;" in front of it, to allow the network dust to settle before it tries to start.
    Nope. It fails with sleep 10 before.

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: x11vnc fails from autoexec

    Perhaps this is a dumb question, but are you trying to run the client VNC or the server VNC? I vaguely remember the server was called "vnc-server".

  7. #7
    Join Date
    Jan 2009
    Beans
    40

    Re: x11vnc fails from autoexec

    Quote Originally Posted by TheFu View Post
    Perhaps this is a dumb question, but are you trying to run the client VNC or the server VNC? I vaguely remember the server was called "vnc-server".
    The problem is with VNC server called as x11vnc. It's name is properly written in thread topic.

    I did not tell first - in prev installation Kubuntu 14.04 it worked almost fine (some keyboard issues found). After OS upgrade it was upgraded to last stable version too.
    Last edited by Gourmand; 6 Days Ago at 03:53 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •