I know that a number of new Ubuntu users installing Ubuntu after Windows 10 have reported that their USB keyboard isn't powered when GRUB displays its boot options (Ubuntu, Advanced options..., Windows etc), and in the last 2 days I was one of them.

This post descibes the (relatively) simple fix that worked in my case. I'll jump to the fix, and then describe the situation I had, what approaches didn't work, and how I got to the fix.

Fix: in BIOS, change BIOS Fast Boot from "Ultra Fast" to "Enabled", save and reboot.
Reason: I suspect Gigabyte's "Ultra Fast" setting for Fast Boot delays the activation of the USB slots until after the point where the OS is selected.
Note: this fix is fairly specific to Gigabyte motherboards, but motherboards from other manufacturers with something like the "Fast Boot" feature might also be able to use this fix.

System Components:
Gigabyte X399 Aorus Extreme motherboard
Thermaltake Core W100 case
USB 2.0 Keyboards: Microsoft Wired 600, Logitech K120
USB 2.0 flashdrives: generic 4GB, sandisk 32 GB

Windows 10 v1903
Ubuntu 18.04.3 LTS

Preceding Installation:
  • Downloaded Gigabyte App Center, and used Fast Boot app to get into the BIOS (because even before installing Ubuntu, DEL key was not opening BIOS during boot)
  • Had created a bootable Windows 10 USB stick.
  • On one of my other PCs had created a separate bootable Ubuntu (18.04.3 LTS) USB stick with Rufus.
  • In BIOS, changed the sequence of drive checking for boot so that it read from the USB stick first.
  • Successfully installed Ubuntu 18.04.3 LTS using the bootable USB stick:

- installed alongside Windows 10
- used manual partitions tool

The Issue: When GRUB's options popped up about what OS should be booted to, and asked for the arrow keys to be used to move between options, none of the keyboard keys worked. AND, because none of the keys were working, the system couldn't be forced into BIOS to check or change configurations such as USB support.

What attempted fixes did not work: (assume attempted fix = change and reboot to see if fix worked)

  1. using any of the other USB slots on the case
  2. using a different USB keyboard (the Core W100 does not have PS/2 slots)
  3. inserting the bootable Windows 10 USB stick
  4. inserting the bootable Ubuntu USB stick
  5. extending the selection time in GRUB from 10 seconds to 40 seconds to give the system more time to recognise the keyboard

The actual fix
: (in my case)

  1. In Ubuntu, change the default selection in GRUB from Ubuntu to Windows 10 using these instructions:
    HTML Code:
  2. After Rebooting in Windows 10, go into Gigabyte's Fast Boot app and select Enter BIOS Setup now (the system will reboot into BIOS)
  3. Change the BIOS Fast Boot setting from "Ultra Fast" to "Enabled", save and accept changes to the boot managers (the system will reboot again)

In my case, this change to the BIOS Fast Boot setting led to the USB keyboard being powered and available when the GRUB menu pops up.

I also then went back and change the GRUB default option back to Ubuntu.

Hope this helps anyone else installing a Ubuntu dual boot alongside Windows 10 who finds they can't use the arrow keys to select which OS gets booted to.

kind regards,