Results 1 to 9 of 9

Thread: cannot install python-gtk2

  1. #1
    Join Date
    Mar 2007
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    cannot install python-gtk2

    I am trying to install gnome-schedule. The ./configure stops with

    Code:
    checking for PYGTK... no
    configure: error: Package requirements (pygtk-2.0 >= 2.6) were not met:
    
    No package 'pygtk-2.0' found
    I have python-gtk2 installed, but when I try to reisnatll I get an error:

    Code:
    (Reading database ... 437971 files and directories currently installed.)
    Preparing to unpack .../python-gtk2_2.24.0-4ubuntu1_amd64.deb ...
    Unpacking python-gtk2 (2.24.0-4ubuntu1) over (2.24.0-4ubuntu1) ...
    Setting up python-gtk2 (2.24.0-4ubuntu1) ...
    Setting up python-gtk2-dev (2.24.0-4ubuntu1) ...
      File "/usr/bin/pyversions", line 20
        except IOError, msg:
                      ^
    SyntaxError: invalid syntax
    dpkg: error processing package python-gtk2-dev (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     python-gtk2-dev
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Setting up python-gtk2-dev (2.24.0-4ubuntu1) ...
      File "/usr/bin/pyversions", line 20
        except IOError, msg:
                      ^
    SyntaxError: invalid syntax
    dpkg: error processing package python-gtk2-dev (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    What can I do?
    Last edited by slickymaster; 2 Weeks Ago at 09:51 AM. Reason: code tags

  2. #2
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,394
    Distro
    Ubuntu Budgie

    Re: cannot install python-gtk2

    What does this get you?

    Code:
    sudo apt-get --reinstall install python-gtk2-dev
    /path/to/Truth

  3. #3
    Join Date
    Mar 2007
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: cannot install python-gtk2

    Quote Originally Posted by Xian View Post
    What does this get you?

    Code:
    sudo apt-get --reinstall install python-gtk2-dev
    E: Internal Error, No file name for python-gtk2-dev:amd64

  4. #4
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,394
    Distro
    Ubuntu Budgie

    Re: cannot install python-gtk2

    Okay you've likely got a broken package that will need this type of fix:

    https://stackoverflow.com/questions/...=votes#tab-top

    Which is to say you'll need to empty files from /var/lib/dpkg/info

    And then issue the command:

    Code:
    sudo dpkg --remove --force-remove-reinstreq python-gtk2-dev
    /path/to/Truth

  5. #5
    Join Date
    Mar 2007
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: cannot install python-gtk2

    Thanks

    That just leads to loads of missing dpkg errors, ending up with

    Code:
    suming package has no files currently installed
    dpkg: warning: files list file for package 'libxcb-xkb1:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libavahi-core7:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'python3-pygments' missing; assuming package has no files currently installed
    (Reading database ... 154 files and directories currently installed.)
    Removing python-gtk2-dev (2.24.0-4ubuntu1) ...
      File "/usr/bin/pyversions", line 20
        except IOError, msg:
                      ^
    SyntaxError: invalid syntax
    dpkg: error processing package python-gtk2-dev (--remove):
     subprocess installed pre-removal script returned error exit status 1
      File "/usr/bin/pyversions", line 20
        except IOError, msg:
                      ^
    SyntaxError: invalid syntax
    dpkg: error while cleaning up:
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    Last edited by slickymaster; 2 Weeks Ago at 09:52 AM. Reason: code tags

  6. #6
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,394
    Distro
    Ubuntu Budgie

    Re: cannot install python-gtk2

    Believe it or not progress is being made.

    There are currently at least 3 broken packages to be repaired.
    So you'll need to remove each one from the /var/lib/dpkg/info directory:

    For example:

    Code:
    sudo rm /var/lib/dpkg/info/libxcb-xkb1*
    Do this for each of the broken packages.


    Next issue the command:
    Code:
    sudo dpkg --configure -a
    Finally reinstall each/all of the packages -- for example:

    Code:
    sudo apt-get install --reinstall libxcb-xkb1
    /path/to/Truth

  7. #7
    Join Date
    Mar 2007
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: cannot install python-gtk2

    No not 3, hundreds! here's a sample

    Code:
    dpkg: warning: files list file for package 'brasero-common' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libhpmud0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'gnome-font-viewer' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'unity-lens-applications' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'python3.5-dev' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libunity-gtk2-parser0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'ruby' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'mate-utils' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'xdg-utils' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'python-ipaddress' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libsub-name-perl' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libxxf86vm-dev:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libieee1284-3:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'docker-ce-cli' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'yelp' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'uno-libs3' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'iputils-arping' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'ca-certificates' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libgstreamer-plugins-good1.0-0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libkf5sonnet5-data' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'fonts-tlwg-loma' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'texlive' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'fonts-tibetan-machine' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'avahi-discover' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libaudgui5:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libpango-perl' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libacl1:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libschroedinger-1.0-0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'geany-plugin-prj' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'manpages-dev' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libtheora0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'unity-greeter' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'gstreamer0.10-plugins-base:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'language-selector-gnome' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libxfixes-dev:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'openssh-client' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libqt4-test:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libvte9' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libjreen1:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'ncurses-bin' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'dirmngr' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'texlive-generic-recommended' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libyaml-libyaml-perl' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'python3-matplotlib' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libprocps4:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libwebp5:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libmpg123-0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libfile-mimeinfo-perl' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'bluez' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'gir1.2-totem-1.0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libopencore-amrwb0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'hicolor-icon-theme' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'acl' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libshout3:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libgs9:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'fonts-kacst' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'irqbalance' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'rhythmbox-data' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libharfbuzz-dev:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'qml-module-qtfeedback:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libsecret-1-0:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'dh-python' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'geany-plugin-git-changebar' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libglib2.0-bin' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'dconf-gsettings-backend:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libreoffice-style-breeze' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libc6-dev:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'libslang2:amd64' missing; assuming package has no files currently installed
    dpkg: warning: files list file for package 'python3-decorator' missing; assuming package has no files c

  8. #8
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,394
    Distro
    Ubuntu Budgie

    Re: cannot install python-gtk2

    There have been some command scripts posted to deal with such issues.

    Here's a link to one such example for you to review:

    https://askubuntu.com/questions/9497...=votes#tab-top
    /path/to/Truth

  9. #9
    Join Date
    Mar 2007
    Beans
    35
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: cannot install python-gtk2

    I am using the command

    for package in $(sudo apt-get upgrade 2>&1 | grep "warning: files list file for package '" | grep -Po "[^'\n ]+'" | grep -Po "[^']+"); do sudo apt-get install --reinstall "$package"; done
    24 hours later it's still running. No feedback. Is this OK?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •