I have fully updated Ubuntu 18.04.3 LTS and I am using Gnome Calendar 3.28.2.

I an using Google calendar, which is synchronized with my mobile phone (iPhone).

Now the problem is, that when I enter new event sometimes (not always), timezone for event is set as Algiers (I assume, this is the first timezone on a list). However, I should should have Vienna timezone.

Unfortunately, Ubuntu tries to be too user friendly and "advanced" options are hidden from the user. So I cannot set the timezone manually.

How to do that.

P. S. It is nice that machines are user friendly... but when they are plain stupid, this user-friendliness turns out to be a real party breaker!