Results 1 to 6 of 6

Thread: Headphone Jack Doesn't Work

  1. #1
    Join Date
    Sep 2019
    Beans
    5

    Headphone Jack Doesn't Work

    I'm using ubuntu 16.04 LTS on my hp pavilion 15-cb012tx.

    The laptop needs to be restarted with volume 100% to get built in speakers working. If restarted with volume 0% no sounds on built in speaker. I tried installing pulseaudio, alsamixer but in vain. No output in headphone jack no matter what.
    here is the detailed information regarding alsa: http://alsa-project.org/db/?f=0fde87...4614e7578a47d1

  2. #2
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    2,819
    Distro
    Xubuntu

    Re: Headphone Jack Doesn't Work

    Since no one else has jumped in, let me give you a trick that has worked for me in the past. Put your volume somewhere around 50%. Power off the machine. Plug headphones in. Power back up. Do the headphones work now? How about when you unplug them: do the speakers function?

    I had a machine that I avtually had to do that 3 or 4 times on before everything worked properly. Once it decided to work, I never did have a problem with it after that.

  3. #3
    Join Date
    Sep 2019
    Beans
    5

    Re: Headphone Jack Doesn't Work

    Thanks Autodave, I will try this and let you know.

  4. #4
    Join Date
    Sep 2019
    Beans
    5

    Re: Headphone Jack Doesn't Work

    Quote Originally Posted by Autodave View Post
    Since no one else has jumped in, let me give you a trick that has worked for me in the past. Put your volume somewhere around 50%. Power off the machine. Plug headphones in. Power back up. Do the headphones work now? How about when you unplug them: do the speakers function?

    I had a machine that I avtually had to do that 3 or 4 times on before everything worked properly. Once it decided to work, I never did have a problem with it after that.
    I tried this today, steps that I tried:

    1. Put my volume to around 50% (speakers were working) shut down the laptop. It did shutdown properly.
    2. Plugged headphone in and turned on the laptop using power button. The headphone worked!
    3. Unplugged the headphone. Tested the speaker by increasing / decreasing volumes the speakers didn't work. Plugged back headphone in it was still working. Unplugged it again, tested speakers it didn't work. Plugged headphone in headphone no longer works!
    4. Brought volume back to 50% and shut down laptop. It didn't shut down properly it was stuck with a blinking caps lock key (it was in panic mode) Powered off by press and hold the power button.
    5. Plugged headphone back in. And turned on laptop again this time both headphone and speakers were not working. Unplugged headphone again, brought volume back to 50% and shut down laptop again this time it didn't panic.
    6. Plugged headphone in turned on laptop headphone worked again, but no speakers yet. Unplugged and plugged headphone multiple times it didn't stop working this time. Turned off laptop it stuck in panic mode again.
    7. Forcefully turned off laptop plugged headphone in turned it on again, headphone still works but no sound in speakers...

    I wonder why does it go to panic mode! The panic mode is random some time it does go to panic sometime it doesn't.

  5. #5
    Join Date
    Sep 2019
    Beans
    5

    Re: Headphone Jack Doesn't Work

    Update: Only left headphone is working. Not both, The right one has some kind of radio like beeping sound.

  6. #6
    Join Date
    Sep 2019
    Beans
    5

    Re: Headphone Jack Doesn't Work

    I tried another stackexchange solution:

    #!/bin/bash
    hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
    hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000
    But it didn't work.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •