Results 1 to 10 of 10

Thread: Virtualbox with Kernel 5.3

  1. #1
    Join Date
    Sep 2019
    Beans
    9

    Virtualbox with Kernel 5.3

    Is it possible to run Virtualbox with the mainline 5.3 kernel? I run qemu for most things, but I need virtualbox for anbox. I'm not able to run /sbin/vboxconfig without errors

    Code:
    WARNING: The vboxdrv kernel module is not loaded. Either there is no module
             available for the current kernel (5.3.0-050300rc6-generic) or it failed to
             load. Please recompile the kernel module and install it by
    
               sudo /sbin/vboxconfig
    
             You will not be able to start VMs until this problem is fixed.
    
    

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Virtualbox with Kernel 5.3

    Why not follow the recommended anbox installation by anbox developers:
    https://docs.anbox.io/userguide/install.html
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Sep 2019
    Beans
    9

    Re: Virtualbox with Kernel 5.3

    Awesome! Thanks! I thought I needed virtual box

  4. #4
    Join Date
    Aug 2017
    Beans
    39

    Re: Virtualbox with Kernel 5.3

    I get this all the time, off and on. I attempt to run the suggested command, still broken. The only thing that seems to work is to uninstall and reinstall VB. The good news is it doesn't lose the machines I've configured.

    Be sure to mark your thread as solved, if it is.

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,437
    Distro
    Kubuntu Development Release

    Re: Virtualbox with Kernel 5.3

    I've never had a problem using the Oracle repository for VirtualBox: https://www.virtualbox.org/wiki/Linu...xdistributions

    Installing that will bring in the compiler and DKMS which are need to create the kernel module.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Jun 2018
    Beans
    17

    Re: Virtualbox with Kernel 5.3

    I need help getting virtualbox 6.0.12 with kernel 5.3 as well it wont build with this kernel does anybody know how to get it to work?

  7. #7
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,437
    Distro
    Kubuntu Development Release

    Re: Virtualbox with Kernel 5.3

    I installed a test build successfully on 19.10 with 5.3.0-13-generic.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  8. #8
    Join Date
    Oct 2006
    Location
    Dawlish, Devon, UK
    Beans
    647
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Virtualbox with Kernel 5.3

    Quote Originally Posted by madscintist View Post
    I need help getting virtualbox 6.0.12 with kernel 5.3 as well it wont build with this kernel does anybody know how to get it to work?
    VB does not work with kernel 5.3 and this is a known problem. I have started using VM Ware Player instead - much faster as well.
    $> cd /pub
    $> more beer

  9. #9
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    145
    Distro
    Lubuntu Development Release

    Re: Virtualbox with Kernel 5.3

    fyi: I use the standard Ubuntu packaged version of virtualbox (6.0.12-dfsg-1), and have no issues running using 5.3 kernel (5.3.0-17-generic though it'll be -18 when I allow reboot), nor have I since the 5.3 upgrade. I've used on this box doing `do-release-upgrade -d` testing for the upcoming 19.10 release in the last week.

  10. #10
    Join Date
    Jun 2018
    Beans
    17

    Re: Virtualbox with Kernel 5.3



    Thank you all for your help i will try it out again with kernel 5.3 SeijiSenseitimgoodguiverc

    I was running kernel 5.3.6 on ubuntu 18.04 and couldn't get virtualbox to run with that kernel? I shoulkd have been more specific

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •