Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: can't resolve conflicts with apt

  1. #1
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Question can't resolve conflicts with apt

    Hi

    I have conflicts with apt that I have not been able to resolve: I'm running on 16.04 LTS and wanted to upgrade but got stuck and now I need to install an additional piece of software but of course am getting the same kind of apt troubles from before:
    Code:
    $ sudo apt install aftp
    [sudo] password for ron:
    ron@jpax-build07:~/scripts$ sudo apt install atftp
    [sudo] password for ron:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     apt-xapian-index : Depends: python3-xapian (>= 1.4.3-1)
     cmake : Depends: cmake-data (= 3.5.1-1ubuntu3) but 3.13.4-1 is to be installed
     libcairo2-dev:i386 : Depends: libfontconfig1-dev:i386 (>= 2.2.95) but it is not going to be installed
     libglib2.0-bin : Depends: libglib2.0-0 (= 2.60.0-1) but 2.48.2-0ubuntu4.4 is to be installed
     libglib2.0-dev:i386 : Depends: libglib2.0-bin:i386 (= 2.48.2-0ubuntu4.4)
     python3 : PreDepends: python3-minimal (= 3.5.1-3) but 3.7.3-1 is to be installed
               Depends: libpython3-stdlib (= 3.5.1-3) but 3.7.3-1 is to be installed
     python3-apt : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
     python3-brlapi : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
     python3-dev : Depends: python3 (= 3.7.3-1) but 3.5.1-3 is to be installed
     python3-distutils : Depends: python3 (>= 3.7.1-1~) but 3.5.1-3 is to be installed
     python3-lib2to3 : Depends: python3 (>= 3.7.1-1~) but 3.5.1-3 is to be installed
     python3-libapparmor : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
     python3-lxml : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
     python3-pil : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
                   Recommends: python3-olefile but it is not installable
     testdrive-common : Depends: qemu-kvm or
                                 kvm (>= 1:84+dfsg-0ubuntu12.4) or
                                 virtualbox (>= 4.0) but it is not going to be installed
                        Recommends: kvm-pxe but it is not installable
     virtualbox-ext-pack : Depends: virtualbox (< 5.1.38-dfsg-z) but it is not going to be installed or
                                    virtualbox-5.1 but it is not installable
                           Depends: virtualbox (>= 5.1.38-dfsg-0~) but it is not going to be installed or
                                    virtualbox-5.1 but it is not installable
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    $ sudo apt --fix-broken install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     apt-xapian-index : Depends: python3-xapian (>= 1.4.3-1)
     cmake : Depends: cmake-data (= 3.5.1-1ubuntu3) but 3.13.4-1 is installed
     libcairo2-dev:i386 : Depends: libfontconfig1-dev:i386 (>= 2.2.95) but it is not installed
     libglib2.0-bin : Depends: libglib2.0-0 (= 2.60.0-1) but 2.48.2-0ubuntu4.4 is installed
     libglib2.0-dev:i386 : Depends: libglib2.0-bin:i386 (= 2.48.2-0ubuntu4.4)
     python3 : PreDepends: python3-minimal (= 3.5.1-3) but 3.7.3-1 is installed
               Depends: libpython3-stdlib (= 3.5.1-3) but 3.7.3-1 is installed
     python3-apt : Depends: python3 (>= 3.7~) but 3.5.1-3 is installed
     python3-brlapi : Depends: python3 (>= 3.7~) but 3.5.1-3 is installed
     python3-dev : Depends: python3 (= 3.7.3-1) but 3.5.1-3 is installed
     python3-distutils : Depends: python3 (>= 3.7.1-1~) but 3.5.1-3 is installed
     python3-lib2to3 : Depends: python3 (>= 3.7.1-1~) but 3.5.1-3 is installed
     python3-libapparmor : Depends: python3 (>= 3.7~) but 3.5.1-3 is installed
     python3-lxml : Depends: python3 (>= 3.7~) but 3.5.1-3 is installed
     python3-pil : Depends: python3 (>= 3.7~) but 3.5.1-3 is installed
                   Recommends: python3-olefile but it is not installable
     testdrive-common : Depends: qemu-kvm or
                                 kvm (>= 1:84+dfsg-0ubuntu12.4) or
                                 virtualbox (>= 4.0) but it is not installed
                        Recommends: kvm-pxe but it is not installable
     virtualbox-ext-pack : Depends: virtualbox (< 5.1.38-dfsg-z) but it is not installed or
                                    virtualbox-5.1 but it is not installable
                           Depends: virtualbox (>= 5.1.38-dfsg-0~) but it is not installed or
                                    virtualbox-5.1 but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    I also have an opopen thread on askubuntu.com but didn't get it resolved....
    It looks like I'm having two offending packages: python3-xapian1.3 & python3-xapian which I don't think I need anymore anyways but I'm unclear of how I correctly remove them without screwing my system up further.
    Can anyone here provide me some further help? I'll make sure to cross update the two open threads when there's any updates on either side.

    Thank you!

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,429
    Distro
    Kubuntu Development Release

    Re: can't resolve conflicts with apt

    First, did you try running "sudo apt --fix-broken install"?

    Also did you run "sudo apt update" before trying to install?
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    Yes and yes, I pastyed the results of "sudo apt --fix-broken install" above too and here's what i get from update:
    Code:
    $ sudo apt update
    [sudo] password for ron:
    Hit:1 http://ca.archive.ubuntu.com/ubuntu xenial InRelease
    Hit:2 http://ca.archive.ubuntu.com/ubuntu xenial-updates InRelease
    Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
    Hit:4 http://ca.archive.ubuntu.com/ubuntu xenial-backports InRelease
    Get:5 http://security.ubuntu.com/ubuntu xenial-security/universe Sources [111 kB]
    Get:6 http://security.ubuntu.com/ubuntu xenial-security/main Sources [154 kB]
    Get:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [739 kB]
    Get:8 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [591 kB]
    Get:9 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [289 kB]
    Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [76.1 kB]
    Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [76.1 kB]
    Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [76.1 kB]
    Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [76.1 kB]
    Get:14 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [79.7 kB]
    Get:15 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [124 kB]
    Get:16 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [194 kB]
    Fetched 583 kB in 6s (89.8 kB/s)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    39 packages can be upgraded. Run 'apt list --upgradable' to see them.

  4. #4
    Join Date
    Jun 2007
    Beans
    17,202

    Re: can't resolve conflicts with apt

    How did you try to upgrade 16.04?
    It appears you added some disco packages somehow, probably a very poor idea...

  5. #5
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    Quote Originally Posted by mc4man View Post
    How did you try to upgrade 16.04?
    It appears you added some disco packages somehow, probably a very poor idea...
    I first tried to dist-upgrade and when that failed, I tried sudo apt update then sudo apt full-upgrade but that kept failing too. I don't know if that first dist-upgrade I ran messed up everything...?

  6. #6
    Join Date
    Jun 2007
    Beans
    17,202

    Re: can't resolve conflicts with apt

    For info sake post
    Code:
    apt-cache policy cmake-data libglib2.0-bin libglib2.0-0 python3-minimal python3-apt python3

  7. #7
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    Code:
    s$ apt-cache policy cmake-data libglib2.0-bin libglib2.0-0 python3-minimal python3-apt python3
    cmake-data:
      Installed: 3.13.4-1
      Candidate: 3.13.4-1
      Version table:
     *** 3.13.4-1 100
            100 /var/lib/dpkg/status
         3.5.1-1ubuntu3 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
         3.5.1-1ubuntu1 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main i386 Packages
    libglib2.0-bin:
      Installed: 2.60.0-1
      Candidate: 2.60.0-1
      Version table:
     *** 2.60.0-1 100
            100 /var/lib/dpkg/status
         2.48.2-0ubuntu4.4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
         2.48.0-1ubuntu4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    libglib2.0-0:
      Installed: 2.48.2-0ubuntu4.4
      Candidate: 2.48.2-0ubuntu4.4
      Version table:
     *** 2.48.2-0ubuntu4.4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
            100 /var/lib/dpkg/status
         2.48.0-1ubuntu4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    python3-minimal:
      Installed: 3.7.3-1
      Candidate: 3.7.3-1
      Version table:
     *** 3.7.3-1 100
            100 /var/lib/dpkg/status
         3.5.1-3 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    python3-apt:
      Installed: 1.8.4
      Candidate: 1.8.4
      Version table:
     *** 1.8.4 100
            100 /var/lib/dpkg/status
         1.1.0~beta1ubuntu0.16.04.5 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
         1.1.0~beta1build1 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    python3:
      Installed: 3.5.1-3
      Candidate: 3.5.1-3
      Version table:
     *** 3.5.1-3 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
            100 /var/lib/dpkg/status
    What does the "priority" number mean?

  8. #8
    Join Date
    Jun 2007
    Beans
    17,202

    Re: can't resolve conflicts with apt

    You've installed a number of packages that didn't come from xenial repos. They didn't install themselves so what did you do?

    The cmake-data is no big deal, it could just be removed..
    However the glib and python3 packages that are wrong versions would be much trickier, one method would be to identify all of the wrong version package and acquire the proper xenial ones. It then might be possible to install them as a group.
    If you handle the replacement wrong you'll probably not be able to reboot and log in..

    A bit of a chore and mess you've created.
    Atm cmake-data, libglib2.0-bin, python3-apt & python3-minimal are wrong versions, likely some other python3 wrong packages, maybe another glib package or 2..

  9. #9
    Join Date
    Mar 2007
    Beans
    467

    Re: can't resolve conflicts with apt

    It appears you are still running 16.04 packages. I think you will need to configure the packages that are already downloaded to get the system working

    Try
    Code:
    sudo dpkg --configure -a
    Post the output, that may configure some of the packages and you will probably still have some broken packages.
    Then run:

    Code:
    apt install -f
    The above command is the same as
    Code:
    apt --fix-broken install
    That might fix some more.

    You may have to update the libraries again and continue to chip away at the errors.

    The basic problem seems to be a bunch of python stuff is not configured and a bunch of stuff depends on python.
    What most likely happened was that after downloading the packages do-release-upgrade failed leaving a bunch of unmet dependencies.

    You most likely can get it to work if you keep at it. I've been able to work through similar problems.

  10. #10
    Join Date
    Jun 2007
    Beans
    17,202

    Re: can't resolve conflicts with apt

    Please post,
    Code:
    apt-cache show libglib2.0-bin python3-minimal

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •