Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: can't resolve conflicts with apt

  1. #21
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    Quote Originally Posted by mc4man View Post
    Your best bet is to acquire ALL of the Disco era (19.04/19.10) packages you've either installed or were attempted to install but were not configured, for example with glib you need
    libglib2.0-bin 2.48.2-0ubuntu4.4
    for python3-minimal,
    python3-minimal 3.5.1-3
    ect., ect.
    Still don't think you're telling all, those disco era (19.04/19.10) packages didn't show up thru any upgrade command, you either downloaded them or more likely edited your sources in an initial attempt to Upgrade 16.04 to ....?
    So if I understand right, you suggest to manually download & upgrade all the files where @rsteinmetz70112 suggests to backup to the starting point and upgrade from there, what's the best thing to proceed?
    If I chose the method suggested in this post, would I go to https://packages.ubuntu.com/, search the package (libglib2) and download the am64 version of the deb package, e.g. http://security.ubuntu.com/ubuntu/po...u0.1_amd64.deb only the version doesn't seem to align with what you entered above... and then install the packages using sudo dpkg -i file.deb?

  2. #22
    Join Date
    Mar 2007
    Beans
    462

    Re: can't resolve conflicts with apt

    Before we do anything dangerour lets find out a little more about the state of your system. Run the following commands and post the results.
    Code:
    $ ls /usr/lib | grep python
    $ ls -ld /usr/bin/python
    $ ls -ld /usr/bin/python3
    $ which python
    $ python --version
    To remove a package:
    Code:
    sudo apt remove <package name>
    I'm not sure if that will work on partially installed packages if not try.
    Code:
    sudo apt purge <package name>
    or combine the two
    Code:
    sudo apt remove --purge <package name>
    I'd be careful and remove them one at a time.
    The command should include the version number the standard Ubuntu would be something like apt-python3.7

    Python-minimal is a pretty important package breaking it could break all sorts of stuff.

    This seems to me likely to be the most critical package holding up the works since the 3.7 version is already installed.

    python3 : PreDepends: python3-minimal (= 3.5.1-3) but 3.7.3-1 is installed
    Depends: libpython3-stdlib (= 3.5.1-3) but 3.7.3-1 is installed
    Before doing anything irreversible you might want to try:
    Code:
    sudo apt install python3-minimal libpython3-stdlib --reinstall --simulate
    This should run the command without actually doing anything but should also show you what the command would do without the --simulate
    to make sure it will try to download and install 3.5.1-3 over the existing 3.7 packages.

    In fact you might want to download the debs for python3-minimal or get a Ubuntu 16.04 iso and add it to your sources before you attempt to remove anything so if apt breaks you will still have them available
    Last edited by rsteinmetz70112; 2 Weeks Ago at 05:50 PM.

  3. #23
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    [QUOTE=rsteinmetz70112;13891049]Before we do anything dangerour lets find out a little more about the state of your system. Run the following commands and post the results.
    Code:
    $ ls /usr/lib | grep python
    $ ls -ld /usr/bin/python
    $ ls -ld /usr/bin/python3
    $ which python
    $ python --version
    To remove a package:
    Code:
    sudo apt remove <package name>
    I'm not sure if that will work on partially installed packages if not try.
    Code:
    sudo apt purge <package name>
    or combine the two
    Code:
    sudo apt remove --purge <package name>
    I'd be careful and remove them one at a time.
    The command should include the version number the standard Ubuntu would be something like apt-python3.7

    Python-minimal is a pretty important package breaking it could break all sorts of stuff.

    This seems to me likely to be the most critical package holding up the works since the 3.7 version is already installed.
    [/QOTE]
    Code:
    $ ls /usr/lib |grep python
    python2.7
    python3
    python3.5
    python3.7
    python3.8
    $ ls -ld /usr/bin/python
    lrwxrwxrwx 1 root root 9 Nov 23  2017 /usr/bin/python -> python2.7
    $ ls -ld /usr/bin/python3
    lrwxrwxrwx 1 root root 9 Mar 26 03:25 /usr/bin/python3 -> python3.7
    $ which python
    /usr/bin/python
    $ python --version
    Python 2.7.12
    Let's see, just making sure that I understand. the Python3.8 library seems to be a bit out of place, why does Python3 not link to the 3.8, should it?

    Now, I have not gone ahead and removed or purged anything else yet. I've also got the following:
    Code:
    $ ls -l /usr/bin/python*
    lrwxrwxrwx 1 root root       9 Nov 23  2017 /usr/bin/python -> python2.7
    lrwxrwxrwx 1 root root       9 Nov 23  2017 /usr/bin/python2 -> python2.7
    lrwxrwxrwx 1 root root      15 Jul 25 09:29 /usr/bin/python2.5 -> /usr/bin/python
    -rwxr-xr-x 1 root root 3492656 Aug 22 12:43 /usr/bin/python2.7
    lrwxrwxrwx 1 root root      33 Aug 22 12:43 /usr/bin/python2.7-config -> x86_64-linux-gnu-python2.7-config
    lrwxrwxrwx 1 root root      16 Nov 23  2017 /usr/bin/python2-config -> python2.7-config
    lrwxrwxrwx 1 root root       9 Mar 26 03:25 /usr/bin/python3 -> python3.7
    -rwxr-xr-x 2 root root 4460272 Aug 20 13:08 /usr/bin/python3.5
    lrwxrwxrwx 1 root root      33 Aug 20 13:08 /usr/bin/python3.5-config -> x86_64-linux-gnu-python3.5-config
    -rwxr-xr-x 2 root root 4460272 Aug 20 13:08 /usr/bin/python3.5m
    lrwxrwxrwx 1 root root      34 Aug 20 13:08 /usr/bin/python3.5m-config -> x86_64-linux-gnu-python3.5m-config
    -rwxr-xr-x 2 root root 4877888 Apr  2 22:39 /usr/bin/python3.7
    lrwxrwxrwx 1 root root      33 Apr  2 22:39 /usr/bin/python3.7-config -> x86_64-linux-gnu-python3.7-config
    -rwxr-xr-x 2 root root 4877888 Apr  2 22:39 /usr/bin/python3.7m
    lrwxrwxrwx 1 root root      34 Apr  2 22:39 /usr/bin/python3.7m-config -> x86_64-linux-gnu-python3.7m-config
    lrwxrwxrwx 1 root root      16 Mar 26 03:25 /usr/bin/python3-config -> python3.7-config
    lrwxrwxrwx 1 root root      10 Mar 26 03:25 /usr/bin/python3m -> python3.7m
    lrwxrwxrwx 1 root root      17 Mar 26 03:25 /usr/bin/python3m-config -> python3.7m-config
    lrwxrwxrwx 1 root root      16 Nov 23  2017 /usr/bin/python-config -> python2.7-config

    Quote Originally Posted by rsteinmetz70112 View Post
    Before doing anything irreversible you might want to try:
    Code:
    sudo apt install python3-minimal libpython3-stdlib --reinstall --simulate
    This should run the command without actually doing anything but should also show you what the command would do without the --simulate
    to make sure it will try to download and install 3.5.1-3 over the existing 3.7 packages.
    Cool, I didn't even know about the --simulate option. Great, Thanks!
    Quote Originally Posted by rsteinmetz70112 View Post
    In fact you might want to download the debs for python3-minimal or get a Ubuntu 16.04 iso and add it to your sources before you attempt to remove anything so if apt breaks you will still have them available
    Yes, I will download a 16.04 iso and mount it!

    Thanks!

  4. #24
    Join Date
    Mar 2007
    Beans
    462

    Re: can't resolve conflicts with apt

    This is getting tricky and you could do real damage to your system if it doesn't work. We're getting into an area I'm not too familiar with. You might want to consider posting a question to launchpad, the people over there seem have more in depth knowledge.

    At least part of the problem is that python3 is linked to python3.7.
    Code:
    lrwxrwxrwx 1 root root 9 Mar 26 03:25 /usr/bin/python3 -> python3.7
    In 16.04 the default is to link to python3.5. Simply changing that link may fix it. Since Python is so important for many things you need to be sure before you do anything or at least be prepared for the concequences. You can really mess up your system.

    If a reinstall of python3-minimal from the Ubuntu repositories fixes the python3 link you will probably be fine.

    You could try renaming the python3 link (python3.7?) and create a new link python3 to python 3.5 and reboot.
    If that doesn't work you could boot into a recovery shell or an iso and fix it. This option offers the possibility of returning the system to its current state.

    You could also try removing python3.7

    The real question is are you feeling lucky?

    I also think you also want to basically remove all of this:
    -rwxr-xr-x 2 root root 4877888 Apr 2 22:39 /usr/bin/python3.7
    lrwxrwxrwx 1 root root 33 Apr 2 22:39 /usr/bin/python3.7-config -> x86_64-linux-gnu-python3.7-config
    -rwxr-xr-x 2 root root 4877888 Apr 2 22:39 /usr/bin/python3.7m
    lrwxrwxrwx 1 root root 34 Apr 2 22:39 /usr/bin/python3.7m-config -> x86_64-linux-gnu-python3.7m-config
    lrwxrwxrwx 1 root root 16 Mar 26 03:25 /usr/bin/python3-config -> python3.7-config
    lrwxrwxrwx 1 root root 10 Mar 26 03:25 /usr/bin/python3m -> python3.7m
    lrwxrwxrwx 1 root root 17 Mar 26 03:25 /usr/bin/python3m-config -> python3.7m-config
    lrwxrwxrwx 1 root root 16 Nov 23 2017 /usr/bin/python-config -> python2.7-config
    In any event good luck.
    Last edited by rsteinmetz70112; 2 Weeks Ago at 09:44 PM.

  5. #25
    Join Date
    Nov 2008
    Location
    Vancouver, Canada
    Beans
    86
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: can't resolve conflicts with apt

    Okay,

    I've openbed a thread on launchpad using the same title at https://answers.launchpad.net/ubuntu/+question/684315 .
    The firs request was:
    For diagnostic purposes please provide the output of the following commands (even if that information partly is already available on ubuntuforums):

    uname -a
    lsb_release -crid
    grep '^deb ' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
    sudo dpkg --audit
    apt-cache policy python3 python3-minimal libglib2.0-bin libglib2.0-0

    My first conclusion: There are packages from other sources or for higher releases on your system.
    Upon which I responded with the following:
    okay,
    Here's the requested data:
    Code:
    ron@jpax-build07:~/Downloads$ uname -a
    Linux jpax-build07 4.15.0-54-generic #58~16.04.1-Ubuntu SMP Mon Jun 24 13:21:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    ron@jpax-build07:~/Downloads$ lsb_release -crid
    Distributor ID: Ubuntu
    Description: Ubuntu 19.04
    Release: 19.04
    Codename: disco
    ron@jpax-build07:~/Downloads$ grep '^deb ' /etc/apt/sources.list /etc/apt/sources.list.d/*.list
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial universe
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates universe
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial multiverse
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    /etc/apt/sources.list:deb http://ca.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security main restricted
    /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security universe
    /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security multiverse
    grep: /etc/apt/sources.list.d/*.list: No such file or directory
    ron@jpax-build07:~/Downloads$ sudo dpkg --audit
    [sudo] password for ron:
    The following packages have been unpacked but not yet configured.
    They must be configured using dpkg --configure or the configure
    menu option in dselect for them to work:
     apt-xapian-index maintenance and search tools for a Xapian index of Debian
     cmake-data CMake data files (modules, templates and documentation)
     dwz DWARF compression tool
     libcomerr2:i386 transitional package
     libffi-dev:i386 Foreign Function Interface library (development files)
     libglib2.0-bin Programs for the GLib library
     libpsl5:amd64 Library for Public Suffix List (shared libraries)
     python3-apt Python 3 interface to libapt-pkg
     python3-brlapi:amd64 Braille display access via BRLTTY - Python3 bindings
     python3-dev header files and a static library for Python (default)
     python3-distutils distutils package for Python 3.x
     python3-lib2to3 Interactive high-level object-oriented language (2to3, ve
     python3-libapparmor AppArmor library Python3 bindings
     python3-lxml:amd64 pythonic binding for the libxml2 and libxslt libraries
     python3-pil:amd64 Python Imaging Library (Python3)
     uuid-dev:i386 Universally Unique ID library - headers and static librar
    
    ron@jpax-build07:~/Downloads$ apt-cache policy python3 python3-minimal libglib2.0-bin libglib2.0-0
    python3:
      Installed: 3.5.1-3
      Candidate: 3.5.1-3
      Version table:
     *** 3.5.1-3 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
            100 /var/lib/dpkg/status
    python3-minimal:
      Installed: 3.7.3-1
      Candidate: 3.7.3-1
      Version table:
     *** 3.7.3-1 100
            100 /var/lib/dpkg/status
         3.5.1-3 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    libglib2.0-bin:
      Installed: 2.60.0-1
      Candidate: 2.60.0-1
      Version table:
     *** 2.60.0-1 100
            100 /var/lib/dpkg/status
         2.48.2-0ubuntu4.4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
      500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
         2.48.0-1ubuntu4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    libglib2.0-0:
      Installed: 2.48.2-0ubuntu4.4
      Candidate: 2.48.2-0ubuntu4.4
      Version table:
     *** 2.48.2-0ubuntu4.4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
            500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
            100 /var/lib/dpkg/status
         2.48.0-1ubuntu4 500
            500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
    Yes, I realize that I somehow got other packages onto my system butI'm not sure how to resolve this mess.
    Hence I appreciate any help I might receive in these regards!

  6. #26
    Join Date
    Jun 2007
    Beans
    17,197

    Re: can't resolve conflicts with apt

    Well most likely you, in some apparently unknown manner, tried to release upgrade from 16.04 to 19.04,.
    Obviously not going to work out well.

    I'd think you could, in some manner, identify all disco packages and downgrade them to 16.04 packages. Maybe aptitude would be useful (assuming you can install it..) or you could just do manually.
    As long as you have internet and don't break apt/dpkg you can afford to break some packages along the way.
    Just don't log out or restart till it's completely fixed.

    Or take about 30 min., some backup media like a flash drive & copy out file/folders of interest & do a fresh install of 18.04
    If so and needing to preserve permissions on any files/folders, then compress them before copying, extract after placing in desired location on new install

  7. #27
    Join Date
    Mar 2007
    Beans
    462

    Re: can't resolve conflicts with apt

    Can you reboot successfully? If you don't know don't try.

    Do you have a 16.04 kernel on your machine you could boot into?
    Last edited by rsteinmetz70112; 2 Weeks Ago at 11:20 PM.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •