Results 1 to 4 of 4

Thread: New 18.04 Freezes on Boot. Halp!

  1. #1
    Join Date
    Sep 2017
    Beans
    6

    New 18.04 Freezes on Boot. Halp!

    Hi,

    Long time no see. : )

    I've installed a 18.04 on a secure disk, and there is one thing in the way - ubuntu freezes after passing the crypt. White static dust appears around the top, and the lower half of the screen becomes pixelated. There is no obvious option for me to do something. Here is a video of it:

    https://www.youtube.com/watch?v=JsFqQ9Rv9Ak

    Now, I do have access to the disk from my 16.04. The file system looks wholly formed. Here is some stuff I've taken out from the syslog.

    Code:
    Sep 11 20:34:31 Enterprise kernel: [   39.955385] nouveau 0000:65:00.0: disp:   0e20: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955388] nouveau 0000:65:00.0: disp:   0e24: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955391] nouveau 0000:65:00.0: disp:   0e2c: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955394] nouveau 0000:65:00.0: disp:   0e30: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955398] nouveau 0000:65:00.0: disp:   0e4c: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955401] nouveau 0000:65:00.0: disp:   0e50: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955404] nouveau 0000:65:00.0: disp:   0e54: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955407] nouveau 0000:65:00.0: disp:   0e58: 00000000
    Sep 11 20:34:31 Enterprise kernel: [   39.955411] nouveau 0000:65:00.0: disp:   0e5c: 00000001
    Sep 11 20:34:33 Enterprise kernel: [   41.954299] nouveau 0000:65:00.0: DRM: core notifier timeout
    Sep 11 20:34:35 Enterprise kernel: [   43.958350] nouveau 0000:65:00.0: DRM: base-0: timeout
    Sep 11 20:34:35 Enterprise kernel: [   43.959331] nouveau 0000:65:00.0: DRM: base-1: timeout
    Sep 11 20:34:37 Enterprise kernel: [   45.971777] nouveau 0000:65:00.0: DRM: base-0: timeout
    Sep 11 20:34:37 Enterprise kernel: [   45.972765] nouveau 0000:65:00.0: DRM: base-1: timeout
    Sep 11 20:34:42 Enterprise systemd-timesyncd[926]: Synchronized to time server 91.189.89.199:123 (ntp.ubuntu.com).
    Sep 11 20:35:02 Enterprise kernel: [   70.370816] nouveau 0000:65:00.0: DRM: base-0: timeout
    Sep 11 20:35:14 Enterprise systemd[1]: Starting Stop ureadahead data collection...
    Sep 11 20:35:14 Enterprise systemd[1]: Started Stop ureadahead data collection.
    To me it looks like we are at the video hardware thing again. I'm with a GTX 1080 Ti Strix Gaming. In 16.04, I was able to edit grub menu to make my way in. Here I don't have that. What can I do?

    Thanks!

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    6,717
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: New 18.04 Freezes on Boot. Halp!

    If you're able to chroot to that install you could use that to install the nvidia driver; nouveau's hampered in bringing up post-Maxwell cards by the lack of firmware signing.

  3. #3
    Join Date
    Sep 2017
    Beans
    6

    Re: New 18.04 Freezes on Boot. Halp!

    Quote Originally Posted by CatKiller View Post
    If you're able to chroot to that install you could use that to install the nvidia driver; nouveau's hampered in bringing up post-Maxwell cards by the lack of firmware signing.
    If I recall correctly, there was the radio button in update window, where one can choose NVIDIA driver. Selecting that would solve things, but I don't have access there.
    Also, adding "nomodeset" to grub would work, but my grub seems to not know where to look.

    Btw, Defiant is the 16.04 installation. I named the 18.04 as "Enterprise".

    Am I doing the choroot right? How would doing what you suggest look like?

    Code:
    martine@Defiant:~$ sudo chroot /media/martine/adfbaef7-c5be-4593-bafb-214648712f72/ /bin/bash 
    [sudo] password for martine: 
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    bash: /dev/null: Permission denied
    root@Defiant:/# whoami
    root
    root@Defiant:/# cd /etcbash: /dev/null: Permission denied
    bash: _upvars: `-a2': invalid number specifier
    bash: /dev/null: Permission denied
    bash: _upvars: `-a0': invalid number specifier
    ^C
    root@Defiant:/# cd /etc/default/
    root@Defiant:/etc/default# nano grub
    root@Defiant:/etc/default# sudo update-grub
    /usr/sbin/grub-mkconfig: 37: /usr/share/grub/grub-mkconfig_lib: cannot create /dev/null: Permission denied
    /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
    root@Defiant:/etc/default# sudo -- su
    root@Defiant:/etc/default# update-grub
    /usr/sbin/grub-mkconfig: 37: /usr/share/grub/grub-mkconfig_lib: cannot create /dev/null: Permission denied
    /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
    root@Defiant:/etc/default#
    Last edited by martine-dee; 1 Week Ago at 09:03 PM.

  4. #4
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    6,717
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: New 18.04 Freezes on Boot. Halp!

    I have no idea what it is that's trying (and failing) to use /dev/null.

    When I've had to do it (because tinkering) it's been really straightforward: boot from the install image, mount the Ubuntu installation, chroot and fix whatever it was that I'd broken. In my case, the drive isn't encrypted and I'm using the same version of Ubuntu (modulo updates). I have no idea if either of those, or something else entirely, is causing you the trouble. Did you mount the installed partition in a weird way? The mount point you're using is in your Home folder using the UUID in the path rather than, say, /mnt/enterprise, which suggests that you've used something black-boxy.

    If you've got a dual-boot going on then you should have a Grub menu, so you should be able to edit the entry at boot-time to add nomodeset as an option. I've never played with encrypted partitions, though, so maybe there's something there that stops you doing that.

    If you can't chroot in to install the proprietary driver, and you can't change your boot options to allow it to boot properly with the nouveau driver, then I'm out of ideas. Sorry.
    None but ourselves can free our minds

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •