Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [19.04] Black screen immediately after user login validated, error image attached

  1. #1
    Join Date
    Sep 2019
    Beans
    5

    [19.04] Black screen immediately after user login validated, error image attached

    Hello,

    After authenticating my login with a fresh install of 19.04, 90% of the time I will immediately be met with a black background and a frozen cursor. The system has another partition that has Windows 10 installed. I have previously ran boot-repair to try and fix an issue with GRUB not appearing on startup, but remedied it by using the command prompt in Windows and changing the boot path to shimx64. Other than that, the system is basically untouched. One last piece of information that may or may not help is that I chose to go with the minimal install, and no third party tools or software.

    I believe the issue is related to my GPU, listed in my specs below:

    MSI GL62M-7REX
    ------------------
    i7-7700HQ
    GTX 1050 Ti
    16GB DDR4-24000MHz
    512GB M.2 NVMe SSD
    I have allocated 4GB to a swap partition for the system
    ------------------

    Please see the attached image that depicts the error I am met with! The image is not of great quality as I had to try to capture it quickly, just in case you are unable to read it, here is the meat and potatoes:

    Code:
    nouveau 0000:01:00.0: systemd-logind[877]: failed to idle channel 2
    Thanks for any and all help given towards this issue, I am very new to Linux.
    Attached Images Attached Images
    Last edited by vdflux; 1 Week Ago at 09:37 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,358
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: [19.04] Black screen immediately after user login validated, error image attached

    vdflux; Hello - Welcome to the forum

    Let's see what we have working/
    Post back - Between code tags - the outputs of terminal commands:
    Code:
    sudo lshw -C display
    cat /var/log/gpu-manager.log
    Maybe give consideration to installing the proprietary Nvidia graphic's driver.

    But gots to be a reason why - nouveau works well for me.
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Sep 2019
    Beans
    5

    Re: [19.04] Black screen immediately after user login validated, error image attached

    I was able to get to a console by booting with a live USB, but not sure if that produces the same result as the one you are requesting. Here are the logs produced by that terminal:

    Code:
    ubuntu@ubuntu:~$ sudo lshw -C display
      *-display UNCLAIMED       
           description: 3D controller
           product: GP107M [GeForce GTX 1050 Ti Mobile]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: latency=0
           resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
      *-display UNCLAIMED
           description: VGA compatible controller
           product: Intel Corporation
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 04
           width: 64 bits
           clock: 33MHz
           capabilities: pciexpress msi pm vga_controller bus_master cap_list
           configuration: latency=0
           resources: memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff
    
    
    ubuntu@ubuntu:~$ cat /var/log/gpu-manager.log
    log_file: /var/log/gpu-manager.log
    last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    can't access /run/u-d-c-nvidia-was-loaded file
    can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
    Looking for nvidia modules in /lib/modules/5.0.0-13-generic/updates/dkms
    Looking for amdgpu modules in /lib/modules/5.0.0-13-generic/updates/dkms
    Is nvidia loaded? no
    Was nvidia unloaded? no
    Is nvidia blacklisted? no
    Is intel loaded? yes
    Is radeon loaded? no
    Is radeon blacklisted? no
    Is amdgpu loaded? no
    Is amdgpu blacklisted? no
    Is amdgpu versioned? no
    Is amdgpu pro stack? no
    Is nouveau loaded? yes
    Is nouveau blacklisted? no
    Is nvidia kernel module available? no
    Is amdgpu kernel module available? no
    Vendor/Device Id: 8086:591b
    BusID "PCI:0@0:2:0"
    Is boot vga? yes
    Error: can't access /sys/bus/pci/devices/0000:00:02.0/driver
    The device is not bound to any driver.
    Vendor/Device Id: 10de:1c8c
    BusID "PCI:1@0:0:0"
    Is boot vga? no
    Error: can't access /sys/bus/pci/devices/0000:01:00.0/driver
    The device is not bound to any driver.
    Error : Failed to open /dev/dri
    Error : Failed to open /dev/dri
    Error : Failed to open /dev/dri
    Error : Failed to open /dev/dri
    Does it require offloading? no
    I couldn't open /var/lib/ubuntu-drivers-common/last_gfx_boot for reading.
    Create /var/lib/ubuntu-drivers-common/last_gfx_boot for the 1st time
    last cards number = 1
    Has amd? no
    Has intel? yes
    Has nvidia? yes
    How many cards? 2
    The number of cards has changed!
    Has the system changed? Yes
    System configuration has changed
    Intel IGP detected
    Desktop system detected
    or laptop with open drivers
    Nothing to do
    Another bit of info that might be significant is that I am unable to use the live USB unless I decide to go with the safe graphics version.

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,358
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: [19.04] Black screen immediately after user login validated, error image attached

    vdflux; Hummm ...

    Surprising result for a liveUSB query ,,,

    Boot the normal install, do you get to the login screen ?

    If so at the login, key combo ctl+alt+F2 to gain a console interface.
    log in with user name and pass word - there is no response to the screen when the pass word is entered, Enter your password blindly and hit the enter key.

    If you can get to a console, we run the diagnostics as before - and maybe others; see if we can learn why the driver is not bound.

    all in the process
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  5. #5
    Join Date
    Sep 2019
    Beans
    5

    Re: [19.04] Black screen immediately after user login validated, error image attached

    I had to type some of these lines as some of them changed so hopefully there are no errors

    Code:
    alexander@alexander-GL62M-7REX:~$ sudo lshw -C display
      *-display        
           description: 3D controller
           product: GP107M [GeForce GTX 1050 Ti Mobile]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list rom
           configuration: driver=nouveau latency=0
           resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff
      *-display 
           description: VGA compatible controller
           product: Intel Corporation
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 04
           width: 64 bits
           clock: 33MHz
           capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff
    	   
    alexander@alexander-GL62M-7REX:~$ cat /var/log/gpu-manager.log
    log_file: /var/log/gpu-manager.log
    last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
    can't access /run/u-d-c-nvidia-was-loaded file
    can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
    Looking for nvidia modules in /lib/modules/5.0.0-13-generic/updates/dkms
    Looking for amdgpu modules in /lib/modules/5.0.0-13-generic/updates/dkms
    Is nvidia loaded? no
    Was nvidia unloaded? no
    Is nvidia blacklisted? no
    Is intel loaded? yes
    Is radeon loaded? no
    Is radeon blacklisted? no
    Is amdgpu loaded? no
    Is amdgpu blacklisted? no
    Is amdgpu versioned? no
    Is amdgpu pro stack? no
    Is nouveau loaded? yes
    Is nouveau blacklisted? no
    Is nvidia kernel module available? no
    Is amdgpu kernel module available? no
    Vendor/Device Id: 8086:591b
    BusID "PCI:0@0:2:0"
    Is boot vga? no
    Skipping "/dev/dri/card1", driven by "nouveau"
    Skipping "/dev/dri/card0", driven by "i915"
    Skipping "/dev/dri/card1", driven by "nouveau"
    Skipping "/dev/dri/card0", driven by "i915"
    Found "/dev/dri/card0", driven by "nouveau"
    Number of connected outputs for /dev/dri/card0: 1
    Does it require offloading? yes
    last cards number = 2
    Has amd? no
    Has intel? yes
    Has nvidia? yes
    How many cards? 2
    Has the system changed? No
    Intel IGP detected
    Desktop system detected
    or laptop with open drivers
    Nothing to do
    alexander@alexander-GL62M-7REX:~$

  6. #6
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,358
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: [19.04] Black screen immediately after user login validated, error image attached

    vdflux; Well -

    No problems seen there.

    How about we install the nvidia driver and see then what happens to the display ?
    Code:
    sudo apt update
    sudo apt upgrade
    sudo ubuntu-drivers autoinstall
    reboot for the new driver to take effect.

    just might be a solution
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  7. #7
    Join Date
    Sep 2019
    Beans
    5

    Re: [19.04] Black screen immediately after user login validated, error image attached

    It took a bunch of attempts to get to the console consistently:
    - the first time, after the third command, an infinite loop with an error saying a driver was unsigned
    - sometimes trying to open the console would immediately crash the graphics

    Now I am able to boot every time so far and get past the login screen!

    There is only one issue now that has just popped up, if I close the lid of my laptop, the lock screen and background wallpaper turn white with odd, weird colored pixels everywhere. They only appear on the elements that are part of the wallpaper, it does not affect the favorites bar. If this is a common problem and you know of any quick fixes then feel free to let me know, but other than that I can finally boot which I am super happy about.

    Thanks so much for your help thus far.

    EDIT: a better word to describe the wallpaper and lock screen colors would be "corrupted"

  8. #8
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,358
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: [19.04] Black screen immediately after user login validated, error image attached

    vdflux; Hey hey !

    Moving forward

    Erkkk -- I did not think of "secure boot" !
    Let's do this:
    In bios disabbble secure boot temporarily to re-intall the driver:
    thus:
    Code:
    sudo apt --purge remove nvidia*
    sudo rm /usr/share/X11/xorg.conf.d/10-nvidia.conf
    sudo ubuntu-drivers autoinstall
    As to the corruption after a resume - I have seen a lot of bug reports in that respect.

    As this is a laptop - one thing to try:
    http://iam.tj/prototype/enhancements...-acpi_osi.html

    hope this helps
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  9. #9
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,358
    Distro
    Xubuntu 18.04 Bionic Beaver

    Re: [19.04] Black screen immediately after user login validated, error image attached

    hridoyrdx; Hello -

    exactly ?

    which problem ?

    Oh what to do
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  10. #10
    Join Date
    Sep 2019
    Beans
    5

    Re: [19.04] Black screen immediately after user login validated, error image attached

    After trying the above commands, when executing the last line I ran into the same looping console issue about an unsigned driver. After restarting and moving to the console again and executing the same last line in your snippet, it says no changes were needed. The result is the same as last time, and I am able to log in properly. Am I good to go?

    It was annoying having the console stall out after purging the nvidia drivers lol

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •