Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Cannot get lock for updates

  1. #1
    Join Date
    Apr 2016
    Beans
    Hidden!

    Cannot get lock for updates

    Updates do not work via software centre or terminal

    Have tried the following:

    Code:
    sudo apt update && sudo apt upgrade -y
    
    
    
    
    sudo apt clean
    sudo apt update -m
    sudo dpkg --configure -a
    sudo apt install -f
    sudo apt dist-upgrade
    sudo apt autoremove --purge

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Cannot get lock for updates

    Post the output you get when running
    Code:
    sudo apt full-upgrade
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Cannot get lock for updates

    Try and post back:
    Code:
    sudo killall apt apt-get
    Niinja'd by deadflowr
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  4. #4
    Join Date
    Apr 2016
    Beans
    Hidden!

    Re: Cannot get lock for updates

    Code:
    Reading package lists... DoneBuilding dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following NEW packages will be installed
      linux-headers-4.15.0-62 linux-headers-4.15.0-62-generic
      linux-image-4.15.0-62-generic linux-modules-4.15.0-62-generic
      linux-modules-extra-4.15.0-62-generic
    The following packages will be upgraded:
      appstream-data-pop appstream-data-pop-icons firmware-manager-notify
      firmware-manager-shared libfirmware-manager libpython2.7
      libpython2.7-minimal libpython2.7-stdlib libpython3.6 libpython3.6-minimal
      libpython3.6-stdlib linux-generic linux-headers-generic linux-image-generic
      pop-shop python2.7 python2.7-minimal python3.6 python3.6-minimal
    The following packages will be DOWNGRADED:
      geary
    19 to upgrade, 5 to newly install, 1 to downgrade, 0 to remove and 0 not to upgrade.
    Need to get 82.4 MB of archives.
    After this operation, 331 MB of additional disk space will be used.
    Do you want to continue? [Y/n]
    NOTE:
    It does go through the update process of 331mb and looks successful, but I can run the same command and get the same output at a later time.
    Last edited by ray42; September 9th, 2019 at 08:48 PM.

  5. #5
    Join Date
    Apr 2016
    Beans
    Hidden!

    Re: Cannot get lock for updates

    Code:
    sudo killall apt apt-get
    apt: no process found
    apt-get: no process found

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Cannot get lock for updates

    Looks fine with the exception of downgrading geary.
    Not sure what's happening with that.
    What does
    Code:
    apt policy geary
    show?
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Apr 2016
    Beans
    Hidden!

    Re: Cannot get lock for updates

    Quote Originally Posted by deadflowr View Post
    Looks fine with the exception of downgrading geary.
    Not sure what's happening with that.
    What does
    Code:
    apt policy geary
    show?
    Code:
    apt policy gearygeary:
      Installed: 0.13.3-1~bionic1
      Candidate: 0.13.3-1~bionic1
      Version table:
     *** 0.13.3-1~bionic1 500
            500 http://ppa.launchpad.net/geary-team/releases/ubuntu bionic/main amd64 Packages
            100 /var/lib/dpkg/status
         0.13.3-1~bionic1 1001
           1001 http://ppa.launchpad.net/system76/pop/ubuntu bionic/main amd64 Packages

  8. #8
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Cannot get lock for updates

    Interesting.
    Seems the system76 ppa has a higher priority (1001) over the geary-team ppa (500)
    So it wants to replace the package with that from system76.
    Looks like they shows as the same package version.

    (looking at the ppa home pages they were even uploaded by the same maintainer for both, one week apart from each other)

    If you run the apt full-upgrade command again and select Y what happens?
    Does it still fail to get a lock?
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  9. #9
    Join Date
    Apr 2016
    Beans
    Hidden!

    Re: Cannot get lock for updates

    Quote Originally Posted by deadflowr View Post
    Interesting.
    Seems the system76 ppa has a higher priority (1001) over the geary-team ppa (500)
    So it wants to replace the package with that from system76.
    Looks like they shows as the same package version.

    (looking at the ppa home pages they were even uploaded by the same maintainer for both, one week apart from each other)

    If you run the apt full-upgrade command again and select Y what happens?
    Does it still fail to get a lock?
    NOTE:
    It does go through the update process of 331mb and looks successful, but I can run the same command and get the same output at a later time.

  10. #10
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,461
    Distro
    Ubuntu

    Re: Cannot get lock for updates

    Next time it happens perhaps check top and see if apt or dpkg or even unattended-upgrades is running.
    If anyone of those is running then it can cause it to lock.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •