Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Intel M.2 SSD 660p not detected in ubuntu

  1. #11
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Intel M.2 SSD 660p not detected in ubuntu

    This has several links into Acer, but you have to log into Acer to see them.

    https://community.acer.com/en/discus...recovery-drive
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  2. #12
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,226

    Re: Intel M.2 SSD 660p not detected in ubuntu

    Does UEFI bios have a section for managing PCIe devices? That may have options to change the mode of the m.2 device connector. Could be set to 'Auto' (automatically detect from device) but maybe it's set otherwise by Acer; possibly you need to make manual setting instead of Auto.

    NVMe devices don't use AHCI. But SATA devices (like the HDD or SATA SSDs) do.
    Last edited by Dennis N; 4 Days Ago at 04:55 PM.

  3. #13
    Join Date
    Jun 2007
    Beans
    13,730

    Re: Intel M.2 SSD 660p not detected in ubuntu

    Does lscpi see it? Any mention in dmesg?
    Code:
    sudo update-pciids
    lspci
    dmesg | grep -i nvm
    It should look like:
    Code:
    07:00.0 Non-Volatile memory controller: Intel Corporation SSDPEKNW020T8 [660p, 2TB] (rev 03)

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •