Dude, re-read post #6. You have a hardware issue that won't get better until you fix it.

Also, ubuntu 14.04 is EOL and has been a few years. 18.04, probably the Lubuntu version, is what you should start with today - AFTER - fixing the hardware issue.