Results 1 to 3 of 3

Thread: Failed to install wine 4.12 instead of the latest one on Ubuntu 18.04

  1. #1
    Join Date
    Sep 2019
    Beans
    1

    Failed to install wine 4.12 instead of the latest one on Ubuntu 18.04

    Hi,

    We are developing a custom application on 64Bit in Windows and we need to run it in Ubuntu 18.04
    With wine 4.12 our application worked. The wineprefix used was 64.

    With wine 4.15 the same application (no changes were done in the code) is not working anymore.
    How can I downgrade from wine-devel 4.15 to wine-devel 4.12?

    Thank you,
    Lavinia

  2. #2
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,394
    Distro
    Ubuntu Budgie

    Re: Failed to install wine 4.12 instead of the latest one on Ubuntu 18.04

    You could just go direct to the repo to download & install the version you want:

    https://dl.winehq.org/wine-builds/ub.../binary-amd64/

    Read this as well regarding wine-devel 4.15: http://ubuntuhandbook.org/index.php/...mplementation/

    Or you can use apt to do this for you.
    See what versions are available in the repo:

    Code:
    # apt-cache policy wine-devel
    For example with the program apache2:

    Code:
    # apt-cache policy apache2
    apache2:
      Installed: (none)
      Candidate: 2.4.38-2ubuntu2.2
      Version table:
         2.4.38-2ubuntu2.2 500
            500 http://archive.ubuntu.com/ubuntu disco-updates/main amd64 Packages
            500 http://security.ubuntu.com/ubuntu disco-security/main amd64 Packages
         2.4.38-2ubuntu2 500
            500 http://archive.ubuntu.com/ubuntu disco/main amd64 Packages
    Install the version you want:
    Code:
    # apt-get install apache2=2.4.38-2ubuntu2.2
    If you don't want newer versions to be installed on updates, pin the package:

    Code:
    # apt-mark hold wine-devel
    /path/to/Truth

  3. #3
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    6,858
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Failed to install wine 4.12 instead of the latest one on Ubuntu 18.04

    As well as getting the earlier version installed for your own needs it would be nice to start a dialogue with the Wine devs to identify what it is that the application you're writing does that causes problems with the later version. Since it's your own application you are uniquely placed to find the regression.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •