Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Minitube 32-bit Install Issues

  1. #1
    Join Date
    May 2018
    Beans
    40

    Minitube 32-bit Install Issues

    I use minitube on my pentium 4 as it supports 720p (whereas browser too slow) and has easy to use interface for my kids.

    Recently it quit working, showing search results but not actual playing videos, and research online tells me I need version 3.1 to solve this.

    Ubuntu bionic repos have 2.5.2 or something old.

    Official Minitube website only has 3.1 as 64-bit deb for Ubuntu 18.10.

    So I tried to build 3.1 myself on 32-bit 18.04 base. It requires libmpv-dev version 29, which has a whole bunch of other dependencies (as I first just tried installing that manually) not in bionic repos. So I cheated - I changed bionic to cosmic in my apt sources.list to sudo apt install libmpv-dev (then restored sources file back to bionic).

    Minitube make was successful. However, when I execute, I get the initial search screen, then segfault.

    For further experimentation, since I now have the necessary libs installed, I installed minitube3.1-1_i386.deb from debian sid, and it does the exact same thing as the one I built, intro screen then segfault. For the heck of it I also tried version 2.9-1_i386.deb from debian buster and that runs without crashing, but it has the same issue as the one from ubuntu repos.

    Any ideas?

  2. #2
    Join Date
    Jun 2007
    Beans
    17,199

    Re: Minitube 32-bit Install Issues

    run minitube from a terminal, likely issue is wrong version of qt5 or some useless message about mpv failed to initialize
    Last edited by mc4man; September 4th, 2019 at 10:49 PM.

  3. #3
    Join Date
    May 2018
    Beans
    40

    Re: Minitube 32-bit Install Issues

    It's just the segfault. That QT message I see often and think its irrelevant...shot-2019-09-04_14-52-47.jpg

  4. #4
    Join Date
    Jun 2007
    Beans
    17,199

    Re: Minitube 32-bit Install Issues

    Well I just built the 3.1 source here in 18.04 using a google api key I generated, works fine.

    Used libmpv-dev for bionic from here - https://launchpad.net/~mc3man/+archi...u/bionic-media
    It uses the ppa's ffmpeg-shared libs so if you were tempted to use you'd need to first remove all cosmic packages you installed, particularly any cosmic ffmpeg shared libs..
    (- The ppa llibmpv will be getting an update in near future..

    screen reflects choosing Browse > music..
    Attached Images Attached Images

  5. #5
    Join Date
    May 2018
    Beans
    40

    Re: Minitube 32-bit Install Issues

    Quote Originally Posted by mc4man View Post
    Well I just built the 3.1 source here in 18.04 using a google api key I generated, works fine.
    Just confirming 32-bit, right?

  6. #6
    Join Date
    Jun 2007
    Beans
    17,199

    Re: Minitube 32-bit Install Issues

    Quote Originally Posted by enigma9o7 View Post
    Just confirming 32-bit, right?
    I use amd64 bit but that's irrelevant, all the sources have i386 packages.

  7. #7
    Join Date
    May 2018
    Beans
    40

    Re: Minitube 32-bit Install Issues

    Ok will give it a try with that ppa (on another 32-bit 18.04 machine) and report back later today, that would be great if it works.

    Note - PPA includes what I need, making now. On both machines. To attempt to fix my cosmic install, I executed this command to reinstall the package I installed from cosmic and it's dependencies.
    Code:
    sudo apt-cache depends libmpv-dev | grep '[ |]Depends: [^<]' | cut -d: -f2 | tr -d ' ' | xargs sudo apt --reinstall install -y
    Last edited by enigma9o7; September 6th, 2019 at 07:43 AM.

  8. #8
    Join Date
    May 2018
    Beans
    40

    Re: Minitube 32-bit Install Issues

    <dupe dont see how to delete>
    Last edited by enigma9o7; September 6th, 2019 at 06:46 PM.

  9. #9
    Join Date
    May 2018
    Beans
    40

    Re: Minitube 32-bit Install Issues

    So 2nd machine finished make, it starts playing. Audio only. No video. Terminal shows '[unknown] Error disabling idle display sleep "The name org.freedesktop.ScreenSaver was not provided by any .service files"

    edit:Installed libcuda1 to eliminate that error, didn't change anything.

    Machine 1 finished make, still segfault.

  10. #10
    Join Date
    Jun 2007
    Beans
    17,199

    Re: Minitube 32-bit Install Issues

    Please post
    Code:
    apt-cache policy libavcodec-dev libavcodec58 libmpv-dev

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •