Results 1 to 2 of 2

Thread: MapleStory v62 part 2

  1. #1
    Join Date
    Jul 2018

    MapleStory v62 part 2


    I want to resurface this problem here

    I am able to get it working on a Mint 18.3 VM. See the screenshots.

    Essentially I just do
    sudo apt-get update
    sudo apt-get install -y wine
    And the wine version is 1.6.2.

    Then I get the MapleStory files and also the ws2 DLLs into the .wine directory. Then I do
    wine Clean_Localhost_v62.exe 8484
    But as it is possible to run GUI applications using docker, I have tried to replicate it with no success. The Dockerfile is as follows

    FROM linuxmintd/mint18-i386
    RUN apt-get update
    RUN apt-get install -y wine
    COPY MapleStory MapleStory
    COPY Clean_Localhost_v62.exe MapleStory/Clean_Localhost_v62.exe
    It will install Mint 18.3 and also wine 1.6.2. Now to run it, the commands are as follows.

    docker run -it -e DISPLAY=$DISPLAY -e USER_UID=1000 -e USER_GID=1000 -e USER_NAME=foobar -e PULSE_SERVER=/run/pulse/native -v /tmp/.X11-unix:/tmp/.X11-unix -v /run/user/1000/pulse:/run/pulse --rm foo bash
    groupadd -f -g $USER_GID $USER_NAME
    adduser --disabled-login --uid $USER_UID --gid $USER_GID --gecos '' $USER_NAME
    sudo -HEu $USER_NAME winecfg
    Windows 98 is selected

    Host (to get the 2 DLLs into the container)
    docker cp ws2_32.dll $CID:/home/foobar/.wine/drive_c/windows/system32/
    docker cp ws2help.dll $CID:/home/foobar/.wine/drive_c/windows/system32/
    Then finally in the container
    cd MapleStory
    sudo -HEu $USER_NAME wine Clean_Localhost_v62.exe 8484
    And this is where the error comes up

    Is there something that I'm missing? It is totally possible to run GUIs on docker (even with audio), see:
    Any help is appreciated.
    Last edited by DuckHook; September 1st, 2019 at 04:34 AM. Reason: Convert large images to links

  2. #2
    Join Date
    Jul 2018

    Re: MapleStory v62 part 2

    The VM solution curiously seems to work with only Mint 18.3 with wine 1.6.2. I've tried VMs using the latest Ubuntus as of the time of this writing (18.04 LTS and 19.04) with wine 4, but both cases lead to the runtime error.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts