Results 1 to 5 of 5

Thread: Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

  1. #1
    Join Date
    Aug 2019
    Beans
    2

    Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

    Hello,

    I recently purchased the Ryzen 3900x and ASUS RT 5700 XT largely due to the reports of built in kernel support. So far I have been unable to install Ubuntu successfully. I have trying running the live installer for 18.04.2, 18.04.3 as well as 19.04 to no avail.

    I am seeing the following errors when trying to boot into the live install:

    UbuntuInstallError2.PNG

    My hardware is as follows:

    Motherboard: MSI MPG x570 Gaming Pro Carbon Wifi
    Processor: AMD Ryzen 3900X
    Graphics: ASUS Radeon RT 5700 XT
    RAM: 32GB

    I have updated the BIOS to the latest version as of 8/26 as I have read that the previous issues had been resolved.

    MSIStatus.PNG

    I have ensured that secure boot is not enabled.

    I have seen multiple articles that seem to indicate people have gotten this working with the processor / graphics combo.

    https://level1techs.com/article/ryze...xt-ready-linux

    https://forum.manjaro.org/t/amd-ryze...-support/94005

    https://www.reddit.com/r/linux_gamin...xt_on_manjaro/

    I am hoping that someone has indeed gotten this to work and can help troubleshoot the issue.

    Thank you.

  2. #2
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,266
    Distro
    Xubuntu

    Re: Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

    Have you enabled AHCI in the BIOS? That is the error that you are getting. Spinned HDs must have that enabled, SSDs will work w/o it, but should be enabled anyhow.

  3. #3
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,266
    Distro
    Xubuntu

    Re: Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

    After that, you may need to refer to this link for the graphics card: https://ubuntuforums.org/showthread.php?t=2425799

  4. #4
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

    Have you updated UEFI?

    AMD UEFI/BIOS update for Ryzen 3000 series
    https://www.phoronix.com/scan.php?pa...OS-Update-Good
    AMD Releases BIOS Fix To Motherboard Partners For Booting Newer Linux Distributions July 2019
    https://www.phoronix.com/scan.php?pa...Linux-Zen2-Fix
    https://www.phoronix.com/scan.php?pa...0x-linux&num=2
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  5. #5
    Join Date
    Aug 2019
    Beans
    2

    Re: Unable to install on Ryzen 3900x with Asus Radeon rx 5700 xt

    Hi Autodave,

    The AHCI is enabled in the BIOS.

    BIOS_Integrated.PNG

    Thanks for the link regarding the graphics card. At the moment I can't even get it to boot to a terminal in Ubuntu though, so I'm not sure how I'm going to run the apt install.

    @oldfred I saw those posts on Phoronix and I believe I have the latest BIOS from MSI with the 7B93v124(Beta version) that was released on the 26th. I have tried installing with all three of the release versions mentioned in my original post after updating the BIOS to the latest.

    I have a bad feeling that there is still something needing fixed in the BIOS as I did manage to get Windows installed but am seeing an issue with Destiny 2. Prior to the latest BIOS update it wouldn't even show up on the screen when trying to run Destiny 2. After the update I thought it was working but I was only able to play for about 5 minutes or so before the machine rebooted. I think the graphics card got too hot but I'm not sure. I know Destiny 2 has also been an issue with this processor and graphics card.

    Perhaps others that got this to work were using different motherboards with a better BIOS fix?

    For full disclosure, I've also tried installing Manjaro KDE 18.1.0rc8 as well as 18.04-stable, Debian 9.9.0, 10.0.0 and PopOS 19.04 to no avail. I did see somewhere that apparently FreeBSD installs great on it out of the box but I haven't tried it yet.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •