Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Incompatibility between rstudio and virtualbox dependencies

  1. #1
    Join Date
    Jan 2017
    Beans
    14

    Incompatibility between rstudio and virtualbox dependencies

    Rstudio files (.R, .Rmd, etc) do not open from nautilus (or console xdg...) , or, Rstudio does not open at all with segmentation fault. dmesg error:
    traps: rstudio[16450] general protection fault ip:7f9f343a6a99 sp:7fffe73b6190 error:0 in libQt5XcbQpa.so.5.9.5[7f9f3434a000+fb000]

    After removing libqt5core5a
    sudo apt-get remove libqt5core5a


    Which also unistalls:
    libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
    libqt5printsupport5 libqt5svg5 libqt5widgets5 libqt5x11extras5
    qt5-gtk-platformtheme virtualbox-qt

    The nautilus opening problem or segmentation fault disappears.

    If I reinstall

    sudo apt-get install libqt5core5a

    Rstudio coutinues working well.

    I installed several versions of virtualbox, and each one breaks the functionally of Rstudio. Anyone having the last Rstudio and virtualbox working?
    Last edited by firthu; August 27th, 2019 at 03:01 AM.

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,501
    Distro
    Kubuntu Development Release

    Re: Incompatibility between rstudio and virtualbox dependencies

    Are you running Ubuntu and RStudio in a VirtualBox VM? Or are you running it on the host machine?

    Have you tried installing Kubuntu in a VM instead of vanilla Ubuntu? Kubuntu uses KDE which is built on Qt. It might have fewer problems.

    Also, I suggest installing the version of VirtualBox in the Oracle repositories. It always works flawlessly for me.

    https://www.virtualbox.org/wiki/Linu...xdistributions
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Incompatibility between rstudio and virtualbox dependencies

    Would you consider not using virtualbox? There are other options.

  4. #4
    Join Date
    Jan 2017
    Beans
    14

    Re: Incompatibility between rstudio and virtualbox dependencies

    @seijisensei They are not running in a virtualbox. Problem happens with the latest version in the virtualbox page also.

  5. #5
    Join Date
    Jan 2017
    Beans
    14

    Re: Incompatibility between rstudio and virtualbox dependencies

    @theFu, problem is I have already created a virtualdisk in virtualbox and would like to use again. Should I quit virtualbox?

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Incompatibility between rstudio and virtualbox dependencies

    Quote Originally Posted by firthu View Post
    @theFu, problem is I have already created a virtualdisk in virtualbox and would like to use again. Should I quit virtualbox?
    Just offering an alternative. Moving to a different hypervisor might be easy or it might need a fresh install or anything in-between. Just depends on the VM setup and the OS involved.

  7. #7
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,501
    Distro
    Kubuntu Development Release

    Re: Incompatibility between rstudio and virtualbox dependencies

    Quote Originally Posted by firthu View Post
    @seijisensei They are not running in a virtualbox. Problem happens with the latest version in the virtualbox page also.
    So if you uninstall VirtualBox, the problem disappears?

    Again I suggest installing Kubuntu in a VM, and see if that's any better.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  8. #8
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Incompatibility between rstudio and virtualbox dependencies

    Thread moved to Virtualisation for a better fit.

  9. #9
    Join Date
    Jan 2017
    Beans
    14

    Re: Incompatibility between rstudio and virtualbox dependencies

    @seijisensei, I am not talking about guests. problem is in host ubuntu 18 with rstudio and virtualbox. uninstalling virtualbox problem disappears yes.

  10. #10
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,501
    Distro
    Kubuntu Development Release

    Re: Incompatibility between rstudio and virtualbox dependencies

    I'm running Kubuntu 19.04 with both RStudio and the Oracle version of VirtualBox installed. I don't have these issues.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •