Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the OS in

  1. #1
    Join Date
    Aug 2019
    Beans
    8

    Question Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the OS in

    Hi guys!

    Firstly, let me inroduce the main characters (at least I think so):
    PC: Asus Vivobook F510QA
    OS: Kubuntu 19.04 (latest one, fully updated and upragded).
    WIFI/Bluetooth module: Realtek 8822be

    The problem itself: I wanted to install the latest version of Kubuntu on my new laptop. Before doing this, I decided to run a demo version of this OS from the bootable USB drive using the "Try Kubuntu" feature and everything worked fine for me so I decided to move on. However, after installing the Kubuntu, I found out that my WIFI wasn't working (while Bluetooth running the same module was totally OK). I've checked the module and everything seems to be fine: the module isn't bloked by neither the hard- nor the software, it has the power supply, the driver and so on. Seems like the module is working but doesn't scan for any networks (connection via the command line doesn't work as well).

    I started digging the issue through the web but wans't able to find any matching case with the solution.The only difference between the "Try Kubuntu" and the installed OS I managed to find if that the installed one is missing this part when I check the dmesg:

    Code:
    [  133.558397] wlp1s0: authenticate with 06:18:d6:cd:fa:fb
    [  134.086760] wlp1s0: send auth to 06:18:d6:cd:fa:fb (try 1/3)
    [  134.094195] wlp1s0: authenticated
    [  134.094790] wlp1s0: associating with AP with corrupt beacon
    [  134.098331] wlp1s0: associate with 06:18:d6:cd:fa:fb (try 1/3)
    [  134.105964] wlp1s0: RX AssocResp from 06:18:d6:cd:fa:fb (capab=0x31 status=0 aid=8)
    [  134.106479] wlp1s0: associated
    [  138.117900] wlp1s0: deauthenticated from 06:18:d6:cd:fa:fb (Reason: 2=PREV_AUTH_NOT_VALID)
    [  173.512044] wlp1s0: authenticate with 06:18:d6:cd:fa:fb
    [  173.512363] wlp1s0: send auth to 06:18:d6:cd:fa:fb (try 1/3)
    [  173.520196] wlp1s0: authenticated
    [  173.520464] wlp1s0: associating with AP with corrupt beacon
    [  173.522184] wlp1s0: associate with 06:18:d6:cd:fa:fb (try 1/3)
    [  173.530060] wlp1s0: RX AssocResp from 06:18:d6:cd:fa:fb (capab=0x31 status=0 aid=9)
    [  173.530316] wlp1s0: associated
    [  173.570946] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
    The output of wildmanne39's "Wireless Script" is attached.

    Any help will be appreciated.
    Attached Files Attached Files

  2. #2
    Join Date
    Aug 2018
    Beans
    21

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    sashatheduckling, I had some recent experience with this driver (pre-release version). It appears from your wireless-info.tar.gz post that the rtw88 module may not be loaded. Can you try running modprobe rtw88 and post back the results?

  3. #3
    Join Date
    Aug 2019
    Beans
    8

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    Hi @dbergst,

    Sure. I tried running "modprobe rtw88" and "modprobe r8822be" but had no output for none:
    Last edited by sashatheduckling; August 25th, 2019 at 06:10 AM. Reason: Trying to reference a user

  4. #4
    Join Date
    Aug 2018
    Beans
    21

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    Quote Originally Posted by sashatheduckling View Post
    Hi @dbergst,

    Sure. I tried running "modprobe rtw88" and "modprobe r8822be" but had no output for none:
    Hi sashatheduckling. r9922be is the old driver for the card, so you probably don't want it loaded at the same time as rtw88. I believe the rtwpci driver may also need to be loaded first, so you may want to try:

    modprobe rtwpci
    modprobe rtw88

  5. #5
    Join Date
    Aug 2019
    Beans
    8

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    Hi, thanks for getting back to me.

    I tried running the suggested commands and restarted the network manager -- unfortunately, it didn't help.

  6. #6
    Join Date
    Aug 2018
    Beans
    21

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    On second thought you should need to run those commands as root, i.e.,
    sudo modprobe rtwpci
    sudo modprobe rtw88

    Aside from that have you checked to see if your wireless interface is enabled in your UEFI / BIOS?

  7. #7
    Join Date
    Aug 2019
    Beans
    8

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    Sure, I tried running the commands as root.
    As for the BIOS settings, the only thing related to the network looks like this:


    [/URL]

    [/url"]http://pix.toile-libre.org/?img=1566990632.png][/url]

  8. #8
    Join Date
    Aug 2018
    Beans
    21

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    As I remember I had to blacklist the old r8822be driver in order for the new rtw88 driver to work. Also, if you could post the output of the rfkill command we can see if your wifi interface is beling blocked.
    Last edited by dbergst; August 28th, 2019 at 06:20 PM. Reason: typo

  9. #9
    Join Date
    Aug 2019
    Beans
    8

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    Thanks for not leaving me alone

    I’ve blacklisted the module you mentioned. To install the new module , I tried “sudo modprobe ***” (as shown in my previous replies). Was it a correct way to install the new modules?

    According to the output of rfkill, my “WiFi” isn’t being blocked by neither the software nor the hardware.

    Actually, this issue could have been resolved by getting a USB adapter for the wireless network, but it’s pretty strange so I decided to figure it out. The WiFi works perfectly on windows 7/10 and with “try Kubuntu (Ubuntu)” option, but fails to work once I install one of these OS. This odd behavior got me curious, confused and a bit angry at the same time
    Last edited by sashatheduckling; August 28th, 2019 at 08:40 PM.

  10. #10
    Join Date
    Aug 2018
    Beans
    21

    Re: Realtek 8822be Kubuntu 19.04 WIFI works with "Try Kubuntu" but doesn't once the O

    It sounds like you are close to getting the wifi working. I'm a bit perplexed that we have not solved the issue though. Looking back at my notes it appears that I gave you some inaccurate instructions. Please use the lsmod command to confirm that the r8822be (blacklisted) is not loaded. You can then load/unload the rtw88 module using the rtwpci module.

    Sorry for any confusion on my part.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •