Results 1 to 5 of 5

Thread: GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

  1. #1
    Join Date
    Sep 2014
    Beans
    13

    GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

    Hello,
    Was just hoping to ask some advice, as am having trouble getting GRUB to load. Have installed Ubuntu alongside Windows 10 on an HP Envy x360. Many solutions are listed on the web, and have already tried many. The laptop is very new.
    Have tried the following solutions...

    1. Have entered this command into DOS as an admin: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
    2. Tried disabling fast boot
    3. Tried disabling secure boot
    4. Tried booting in legacy mode
    5. Tried booting in Windows' advanced startup (Ubuntu doesn't show as an option)
    6. In the BIOS boot settings, neither Ubuntu or Windows appear as options
    7. Installed Ubuntu choosing the 'something else' option. Created a swap partition. Installed Ubuntu on the free space. Chose the partition with Windows boot loader to install the boot loader. On the Ubuntu installation, noticed that the EFI partition say that it has the Windows boot loader. On the Windows disk management utility, it seems that the boot loader is on the C drive (/dev/nvme0n1p3). Wasn't sure if should have installed the boot loader in the Ubuntu. Will plan to attach photos.

      IMG_20190815_085908.jpgIMG_20190815_144950.jpgIMG_20190815_144358.jpgWas hoping to see if anyone might have any thoughts?

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

    If Windows is UEFI, do not turn on Legacy/BIOS/CSM mode. Only use UEFI.
    CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off.

    Have you updated UEFI and SSD firmware. Many with various models of HP say UEFI update solves many issues.

    Have you seen these?
    HP Pavillion X360 13-a220nw
    https://ubuntuforums.org/showthread.php?t=2359510 &
    [Guide] Install Ubuntu 18.04 on HP Spectre x360 13"
    https://ubuntuforums.org/showthread.php?t=2414086
    https://ubuntuforums.org/showthread.php?t=2422113
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Jun 2014
    Beans
    5,335

    Re: GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

    I would suggest you read the Ubuntu documentation on dual booting with windows 10 at the link below which should clarify some things for you.

    https://help.ubuntu.com/community/UEFI

    As pointed out above, you have an EFI system so do not use Legacy/CSM.
    I'm not sure what windows advanced startup is or why that would allow access to boot Ubuntu?
    On my HP notebook, I can access boot options by hitting the Esc key then F9 on boot, or BIOS setup by hitting Esc and F10 keys. Do you have the same or similar options? Are you saying that you do not see either Ubuntu or windows as an option here? Does anything boot?

    Installing the boot loader to the windows partition from Ubuntu was mistakes as the boot files should go on the EFI partition and the Ubuntu partition. There should be separate directories in the EFI partition for windows and Ubuntu boot files and there will also be boot files for each on their respective partitions.

    Reviewing the link above should clarify some of the questions but if you continue to have questions/problems, post back.
    Last edited by yancek; 2 Days Ago at 12:06 PM.

  4. #4
    Join Date
    Sep 2014
    Beans
    13

    Re: GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

    Hi Olfred,

    Kind of you to pass along this advice. Checked the HP support assistant and it says that everything is up to date. Think this laptop was just purchased last week or so. Have secure boot off and am booting in UEFI, but still no GRUB.

  5. #5
    Join Date
    Sep 2014
    Beans
    13

    Re: GRUB doesn't show in Ubuntu / Windows 10 dual boot (tried most solutions)

    Hello Olfred and Yancek,

    Kind of you to pass along these answers. Had installed the boot loader in the EFI parition. As it turned out, was pressing F10 to enter BIOS, when needed to press F9 to enter the boot order. Kind of you to pass along that suggestion Yancek. After that, changed the default boot order to put Ubuntu's boot manager first, using efi boot manager (https://www.lifewire.com/fix-uefi-bo...ooting-2200655). So, now everthing is working fine.

    Was great to get this advice. Am planning to mark this thread as solved.

    WIshing you all the best.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •