Hi Community,

I bought a new laptop Asus Vivobook S14 S430FN with following configuration
  • Intel Core i7 Processor
  • Nvdia Geforce MX150 2 GB
  • SSD 512 GB
  • RAM 8GB
  • Genuine Windows 10 Home Edition


Now, I want to use Ubuntu 18.04.03 in dual boot. But while installing Ubuntu, I am facing problems. I followed following steps.

  1. From BIOS I make sure it that Fast Boot is disabled
  2. There is no UEFI or Enable CSM option in the boot menu
  3. When start my computer I clicked esc and then choose the USB bootable stick
  4. After that I found the GRUB option [ 1. Try Ubuntu without Installing, 2. Install Ubuntu, 3. OEM Install, 4. Check disk for defects]
  5. When I choose any option from the Grub menu, it contains black screen. I tried all the possible solution which I find in the community
    1. https://askubuntu.com/questions/1620...have-to-fix-it , tried clicking button `e` while choosing option and adding the nomodeset in the command. But still not working
    2. I tried the usb to install it in the other laptop [MSI FX600, Nvdia GT 325M, 8GB RAM, 512 HDD]. It was smoothly installed in to that laptop.


Please let me know if there is anything missing from my side.

Thank you.