Results 1 to 7 of 7

Thread: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

  1. #1
    Join Date
    Aug 2019
    Beans
    3

    AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    The needful pastebin is here.

    This is an odd corner case which may or may not be relevant. I've got an Intel AX200 on the Jetson Nano, and I compiled the core 45 release of the iwlwifi driver as follows:

    Code:
    git clone --single-branch --branch release/core45 https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
    make defconfig-iwlwifi-public
    sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
    make -j4 sudo make install
    And the card does work. iw commands see it, and I was able to somewhat get it in monitor mode. Definitely was able to pass traffic with it.

    However, iwconfig can't talk to it. It says "no wireless extensions" and I'm not sure why or what to troubleshoot. (I'm trying to get Kismet working, and I suspect/wonder if this issue is why Kismet is unhappy.)

    Does it look like I've done anything obviously wrong?
    Last edited by meatwad650; August 6th, 2019 at 01:06 AM.

  2. #2
    Join Date
    Aug 2019
    Beans
    3

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    Also, I did update to the latest firmware (iwlwifi-cc-a0-48.ucode) if that helps.

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,966
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    I've read your very long and very interesting list of GRUB command options and this appears twice, as do several other parameters:
    Code:
    net.ifnames=0
    I suggest that you thoroughly examine your GRUB commands and after you eliminate duplicates, that you change this:
    Code:
    net.ifnames=0
    To this:
    Code:
    net.ifnames=0 biosdevname=0
    Reboot and tell us if there is any improvement.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  4. #4
    Join Date
    Aug 2019
    Beans
    3

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    This platform doesn't really have grub, given that it's embedded. So I'll have to investigate how it does that.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,966
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    Quote Originally Posted by meatwad650 View Post
    This platform doesn't really have grub, given that it's embedded. So I'll have to investigate how it does that.
    What does this report?
    Code:
    cat /etc/default/grub
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #6
    Join Date
    Dec 2019
    Beans
    1

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    Quote Originally Posted by chili555 View Post
    What does this report?
    Code:
    cat /etc/default/grub
    This file does not exists on the Jetson Nano.


    Any solution on this?

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    24,966
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: AX200 on Jetson Nano - iwconfig says "no wireless extensions"

    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •