Results 1 to 5 of 5

Thread: Video playback not smooth: Chromium, MPV, anything

  1. #1

    Video playback not smooth: Chromium, MPV, anything

    Hi everyone,

    I'm having a problem with playing back videos. It doesn't seem to matter if it's in Chrome or MPV. It freezes for about half a second about once every twenty or thirty seconds. It doesn't seem to matter if the video is h264, mp4 or whatever. I've checked
    Code:
    glxinfo | grep "direct rendering"
    and it returns,
    Code:
    direct rendering: Yes
    . Chromium reports it is using MojoDecoder and MPV
    Code:
    hwdec: vaapi
    . Top also reports that MPV is using about 10% processor when playing, I'm using Intel Integrated graphics on X11.

    Any help would be much appreciated.

    System:
    Surface Book with Performance Base i7
    RAM 8GB
    Ubuntu 19.04

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    26,813
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Video playback not smooth: Chromium, MPV, anything

    Thread moved to Multimedia Software a more appropriate sub-forum.

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,205
    Distro
    Kubuntu 19.04 Disco Dingo

    Re: Video playback not smooth: Chromium, MPV, anything

    Is the file on the local machine or being played over the network?

    If it's on the network, are you connecting using NFS (preferred) or CIFS/Windows networking? If you are using a network, copy the file to your local machine and play it from there. Any better?
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4

    Re: Video playback not smooth: Chromium, MPV, anything

    Thanks very much for the advice. The files are playing from the local ssd. It does look like they're playing over a network, though.

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,205
    Distro
    Kubuntu 19.04 Disco Dingo

    Re: Video playback not smooth: Chromium, MPV, anything

    I don't really understand that. If they're on the local drive, they're not going over a network.

    You're basically using something like
    Code:
    mpv /path/to/my/file.mkv
    right? I've never had glitches doing that.

    You could try installing smplayer as a front-end to mpv. In Options > Preferences > Video you can choose among the various video drivers available. Even with just the xv driver, I had no problem playing a 1080p video with Hi-10 encoding and AC3 audio.

    This is on a fairly old HP laptop with generic Intel hardware.
    Last edited by SeijiSensei; 1 Week Ago at 02:02 PM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •