Results 1 to 2 of 2

Thread: DISPLAY=:0 gnome-terminal & not opening terminal in Ubuntu 18.04

  1. #1
    Join Date
    Jul 2019
    Beans
    0

    DISPLAY=:0 gnome-terminal & not opening terminal in Ubuntu 18.04

    In the earlier versions, I was able to open a terminal session in the Ubuntu environment using ssh protocol via putty. I noticed that once I upgraded to graphical gui Ubuntu 18.04 DISPLAY=:0 gnome-terminal & or DISPLAY=:1 gnome-terminal & does not open a terminal session in the Ubuntu. These instructions do not return an error however it doesn't do anything either. This is scenario:
    - Using windows computer via putty I ssh into Ubuntu computer
    - I then run this command nano DISPLAY... command
    - I am expecting in the remote computer the ssh terminal should pop-up but it does not.

    Your help is greatly appreciated.

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    17,154
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: DISPLAY=:0 gnome-terminal & not opening terminal in Ubuntu 18.04

    Is your Windows desktop running an X/Server?
    I understand that putty has X-Forward capabilities now, is that enabled for the specific connection?
    You shouldn't need to touch the DISPLAY environment variable. Putty+ssh should handle that for you.

    Just saw an article specifically about this somewhere today.

    Of course, if you are doing a Linux desktop with X/Windows running (I don't know if Wayland works or not) to a remote server, then you can just do something like this:
    Code:
    uxterm  -sb -geometry 80x25+820+60 $XTERM_OPTS -e ssh -X userid@remote-server-name
    Which terminal you use is completely up to you. I've never used gnome-terminal.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •