Results 1 to 7 of 7

Thread: Lubuntu is having problems udating system

  1. #1
    Join Date
    Apr 2010
    Beans
    30

    Lubuntu is having problems udating system

    I am a newbie. I am using the newest version of Lubuntu. I like the distro a lot but I have one big problem. I am unable to update my computer. in the Discover App it says:

    Cannot Obtain Lock
    E:dpkg was interrupted, you must manualy run 'dpkg --configure-a' to correct the problem.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Lubuntu is having problems udating system

    So did you run in the terminal:
    Code:
    sudo dpkg --configure -a
    Post back any fails so we can help better.
    Last edited by 1fallen; June 28th, 2019 at 09:15 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  3. #3
    Join Date
    Apr 2010
    Beans
    30

    Re: Lubuntu is having problems udating system

    It says

    dpkg: error: unknown option --configure-a
    Last edited by sketchme; June 28th, 2019 at 09:13 PM.

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Lubuntu is having problems udating system

    Maybe entered it wrong, copy and paste the below to be sure:
    Code:
    sudo dpkg --configure -a
    And Please use code tags when replying with terminal out-puts.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  5. #5
    Join Date
    Apr 2010
    Beans
    30

    Re: Lubuntu is having problems udating system

    I tried again and got this. It still doesn't work...

    Setting up linux-headers-5.0.0-20-generic (5.0.0-20.21) ...
    /etc/kernel/header_postinst.d/dkms:
    * dkms: running auto installation service for kernel 5.0.0-20-generic

    Kernel preparation unnecessary for this kernel. Skipping...

    Building module:
    cleaning build area...
    unset ARCH; env NV_VERBOSE=1 'make' -j8 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.0.0-20-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.0.0-20-generic/build LD=/usr/bin/ld.bfd modules.......
    cleaning build area...

    DKMS: build completed.

    nvidia.ko:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/5.0.0-20-generic/updates/dkms/

    nvidia-modeset.ko:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/5.0.0-20-generic/updates/dkms/

    nvidia-drm.ko:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/5.0.0-20-generic/updates/dkms/

    nvidia-uvm.ko:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/5.0.0-20-generic/updates/dkms/

    depmod...

    DKMS: install completed.
    ...done.
    Setting up liblvm2app2.2:amd64 (2.02.176-4.1ubuntu4.1) ...
    Setting up firefox (67.0.4+build1-0ubuntu0.19.04.1) ...
    Please restart all running instances of firefox, or you will experience problems.
    Setting up libsnapd-qt1:amd64 (1.48-0ubuntu0.19.04.0) ...
    Setting up libglib2.0-bin (2.60.4-0ubuntu0.19.04.1) ...
    Setting up samba-libs:amd64 (2:4.10.0+dfsg-0ubuntu2.2) ...
    Setting up libnss-systemd:amd64 (240-6ubuntu5.1) ...
    Setting up linux-image-5.0.0-20-generic (5.0.0-20.21) ...
    I: /vmlinuz is now a symlink to boot/vmlinuz-5.0.0-20-generic
    I: /initrd.img is now a symlink to boot/initrd.img-5.0.0-20-generic
    Setting up linux-headers-generic (5.0.0.20.21) ...
    Setting up vim-tiny (2:8.1.0320-1ubuntu3.1) ...
    Setting up libswresample3:amd64 (7:4.1.3-0ubuntu1) ...
    Setting up libcupsimage2:amd64 (2.2.10-4ubuntu2) ...
    Setting up wpasupplicant (2:2.6-21ubuntu3.1) ...
    Setting up libglib2.0-dev:amd64 (2.60.4-0ubuntu0.19.04.1) ...
    Setting up ubuntu-release-upgrader-qt (1:19.04.16.5) ...
    Setting up cups-daemon (2.2.10-4ubuntu2) ...
    Setting up libsmbclient:amd64 (2:4.10.0+dfsg-0ubuntu2.2) ...
    Setting up libpam-systemd:amd64 (240-6ubuntu5.1) ...
    Setting up ure (6.2.4-0ubuntu0.19.04.1) ...
    Setting up libavcodec58:amd64 (7:4.1.3-0ubuntu1) ...
    Setting up console-setup-linux (1.178ubuntu12.1) ...
    Setting up libisccfg163:amd64 (1:9.11.5.P1+dfsg-1ubuntu2.5) ...
    Setting up poppler-utils (0.74.0-0ubuntu1.2) ...
    Setting up initramfs-tools-core (0.131ubuntu19.1) ...
    Setting up linux-modules-extra-5.0.0-20-generic (5.0.0-20.21) ...
    Setting up linux-image-generic (5.0.0.20.21) ...
    Setting up cups-core-drivers (2.2.10-4ubuntu2) ...
    Setting up console-setup (1.178ubuntu12.1) ...
    update-initramfs: deferring update (trigger activated)
    Setting up initramfs-tools (0.131ubuntu19.1) ...
    update-initramfs: deferring update (trigger activated)
    Setting up libgs9:amd64 (9.26~dfsg+0-0ubuntu7.1) ...
    Setting up linux-generic (5.0.0.20.21) ...
    Setting up libavformat58:amd64 (7:4.1.3-0ubuntu1) ...
    Setting up libbind9-161:amd64 (1:9.11.5.P1+dfsg-1ubuntu2.5) ...
    Setting up libirs161:amd64 (1:9.11.5.P1+dfsg-1ubuntu2.5) ...
    Setting up ghostscript (9.26~dfsg+0-0ubuntu7.1) ...
    Setting up cups-client (2.2.10-4ubuntu2) ...
    Setting up dbus-user-session (1.12.12-1ubuntu1.1) ...
    Setting up linux-signed-generic (5.0.0.20.21) ...
    Setting up libavfilter7:amd64 (7:4.1.3-0ubuntu1) ...
    Setting up bind9-host (1:9.11.5.P1+dfsg-1ubuntu2.5) ...
    Setting up cups (2.2.10-4ubuntu2) ...
    Updating PPD files for cups ...
    Updating PPD files for cups-filters ...
    Updating PPD files for foomatic-db-compressed-ppds ...
    Updating PPD files for openprinting-ppds ...
    Updating PPD files for brlaser ...
    Updating PPD files for c2esp ...
    Updating PPD files for foo2zjs-common ...
    Updating PPD files for gutenprint ...
    Updating PPD files for hpcups ...
    Updating PPD files for m2300w ...
    Updating PPD files for postscript-hp ...
    Updating PPD files for ptouch ...
    Updating PPD files for pxljr ...
    Updating PPD files for sag-gdi ...
    Updating PPD files for splix ...
    Setting up cups-bsd (2.2.10-4ubuntu2) ...
    Setting up ghostscript-x (9.26~dfsg+0-0ubuntu7.1) ...
    Setting up dnsutils (1:9.11.5.P1+dfsg-1ubuntu2.5) ...
    Setting up libreoffice-style-colibre (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up liblvm2cmd2.02:amd64 (2.02.176-4.1ubuntu4.1) ...
    Setting up dmeventd (2:1.02.145-4.1ubuntu4.1) ...
    dm-event.service is a disabled or a static unit not running, not starting it.
    Setting up libreoffice-style-tango (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up lvm2 (2.02.176-4.1ubuntu4.1) ...
    update-initramfs: deferring update (trigger activated)
    Setting up libreoffice-common (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-style-breeze (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-core (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-math (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-gtk3 (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-draw (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-avmedia-backend-gstreamer (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-impress (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-base-core (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up python3-uno (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-calc (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-writer (1:6.2.4-0ubuntu0.19.04.1) ...
    Setting up libreoffice-help-en-us (1:6.2.4-0ubuntu0.19.04.1) ...
    Processing triggers for install-info (6.5.0.dfsg.1-4build1) ...
    Processing triggers for fontconfig (2.13.1-2ubuntu2) ...
    Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
    Processing triggers for mime-support (3.60ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for libc-bin (2.29-0ubuntu2) ...
    Processing triggers for ufw (0.36-1ubuntu1) ...
    Processing triggers for man-db (2.8.5-2) ...
    Processing triggers for gnome-icon-theme (3.12.0-3) ...
    Processing triggers for shared-mime-info (1.10-1) ...
    Processing triggers for linux-image-5.0.0-20-generic (5.0.0-20.21) ...
    /etc/kernel/postinst.d/dkms:
    * dkms: running auto installation service for kernel 5.0.0-20-generic
    ...done.
    /etc/kernel/postinst.d/initramfs-tools:
    update-initramfs: Generating /boot/initrd.img-5.0.0-20-generic
    cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
    nor crypto modules. If that's on purpose, you may want to uninstall the
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
    integration and avoid this warning.
    /etc/kernel/postinst.d/zz-update-grub:
    Sourcing file `/etc/default/grub'
    Sourcing file `/etc/default/grub.d/init-select.cfg'
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-5.0.0-20-generic
    Found initrd image: /boot/initrd.img-5.0.0-20-generic
    Found linux image: /boot/vmlinuz-5.0.0-13-generic
    Found initrd image: /boot/initrd.img-5.0.0-13-generic
    Found memtest86+ image: /boot/memtest86+.elf
    Found memtest86+ image: /boot/memtest86+.bin
    done
    Processing triggers for initramfs-tools (0.131ubuntu19.1) ...
    update-initramfs: Generating /boot/initrd.img-5.0.0-20-generic
    cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries
    nor crypto modules. If that's on purpose, you may want to uninstall the
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs
    integration and avoid this warning.

  6. #6
    Join Date
    Apr 2010
    Beans
    30

    Re: Lubuntu is having problems udating system

    Ok I gave it some time to updare and everything works now thanks.

  7. #7
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Lubuntu is having problems udating system

    Your Welcome
    The first error was my bad, and corrected now.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •