Results 1 to 3 of 3

Thread: cant mount a hdd or see the partition that i need to recover

  1. #1
    Join Date
    Jun 2019
    Beans
    1

    cant mount a hdd or see the partition that i need to recover

    i have a hard disk hooked to my laptop one day i got back from work to see it wont boot had windows installed on it tried accessing it from another computer using windows it reads there is a hdd in windows manager but nothing shows up in file explorer i heard from a friend i can use ubuntu from a usb stick and try to access the hard disk from the os did that on a different laptop and successfully booted to ubuntu using "try without installing" when i try to access my plugged hard disk using a sata to usb dongle i get the following
    https://drive.google.com/open?id=1qHoWMIHTtd4whITR7RE2quTHb26ZBaIJ


    i tried to get a list of hard disks connected to the laptop it shows up using only the command line "sudo lshw -class disk -short"
    https://drive.google.com/open?id=1jv...Y4svHTln_MWnnn
    it shows there that my hard disk

    tried to pinpoint the correct partition but no other command work idk why and i have 0% knowledge as how to know the correct partition to mount it to directory so i can access the hard and get my files back
    https://drive.google.com/open?id=1vl...dp1C1bgTdgmiOW

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: cant mount a hdd or see the partition that i need to recover

    Since Windows, moved to Windows sub-forum.

    The commands for fdisk & parted use -l, that is dash lower case el, L not 1 (one) or cap I.
    sudo parted -l
    sudo fdisk -l

    Windows normal shutdown uses fast start up which sets the hibernation flag. The Linux NTFS driver will not default mount a hibernated NTFS partition to prevent damage. You may be able to force mount in read only mode.
    Fast Start up off (always on hibernation), note that Windows turns this back on with updates
    http://ubuntuforums.org/showthread.p...2#post13488472
    http://www.tenforums.com/tutorials/4...dows-10-a.html
    http://www.tenforums.com/tutorials/2...dows-10-a.html

    If not hibernation flag, NTFS may need chkdsk or other repairs. Those cannot be done from Linux, but only from your Windows or a Windows repair disk.

    Windows 10 repair disk
    http://www.tenforums.com/tutorials/4...dows-10-a.html
    http://www.tenforums.com/tutorials/3...dows-10-a.html
    Repair/backup/restore
    https://support.microsoft.com/en-us/...recovery-drive
    http://windows.microsoft.com/en-us/w...covery-options


    Force mount, read only (ro), change example with sda3 to your correct NTFS partition:
    sudo mkdir /media/windows
    sudo mount -t ntfs-3g -o ro /dev/sda3 /media/windows
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    6,881
    Distro
    Xubuntu 19.10 Eoan Ermine

    Re: cant mount a hdd or see the partition that i need to recover

    Well, I'm not convinced this post should have been moved to Windows just because it's an ntfs disk, but never mind.

    I assume the disk you are trying to read is /dev/sdd - the one you plugged in partway through (earlier lshw didn't list it).
    Replace sda3 in the instructions that oldfred gave you with sdd5 (guessing based on the first error popup you posted):
    Code:
    sudo mkdir /media/windows
    sudo mount -t ntfs-3g -o ro /dev/sdd5 /media/windows
    However, the IO errors worry me. I think the disk may have developed a fault and be basically unusable. That's probably why windows stopped booting from it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •