Results 1 to 7 of 7

Thread: Conky 1.10.8 does not start properly during autostart

  1. #1
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    149
    Distro
    Lubuntu 19.04 Disco Dingo

    Conky 1.10.8 does not start properly during autostart

    When Conky started using Autostart feature of LXQt, it does not show the window.

    I have defined conky in LXQt as an Autostart. I have logged out and logged in and conky window is not shown.

    conky is defined as autostart in /usr/bin/lxqt-config-session. following file was created:
    Code:
    [Desktop Entry]
    Version=1.0
    Name=Conky
    Exec=conky -d
    Terminal=false
    Type=Application
    I see that conky was started during autoststart as daemon successfully. I have killed that process and then started conky -d manually in terminal again and then Conky windows is shown.

    There is something wrong with LXQt settings.

    Is there anyone who has conky running on Lubuntu? If yes, how does the Conky.desktop file above look like on your side?
    Last edited by pencuse; June 17th, 2019 at 05:13 PM. Reason: removed apport.log issue, not relevant, problem still there
    Dell Latitude E7440 (since Dec 2017). CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: PM851 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400
    Dual-boot /dev/sda5: Lubuntu 19.04, /dev/sda6: Arch Linux

  2. #2
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    149
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Conky 1.10.8 does start properly during autostart

    I have taken exactly the same conky.desktop file in the Conky page in Arch Linux, also changed background=true in .config/conky/conky.conf. No success, i.e. autostart starts the process correctly (I can see in the process list), but the window is not drawn. If I kill the process and start in command line again, it works.

    There is something wrong with the Autostart of Conky.
    Dell Latitude E7440 (since Dec 2017). CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: PM851 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400
    Dual-boot /dev/sda5: Lubuntu 19.04, /dev/sda6: Arch Linux

  3. #3
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Conky 1.10.8 does start properly during autostart

    In Lubuntu, but I don't use Lubuntu.(FTR)
    I run mine with a 30 sec delay>>>sleep 30s<<<
    Run the following commands in a terminal:
    Code:
    mkdir -p ~/.config/lxsession/Lubuntu/
    touch ~/.config/lxsessions/Lubuntu/autostart
    leafpad autostart
    Add this line to the autostart file:
    Code:
    @conky
    Once you have achieved your desired config, you then add multiple scripts also:
    To set multiple Conky to run at startup, create a folder called .conky.
    Code:
    mkdir ~/.conky
    Save your different Conky config files in there. You may want to name them .conkyrc_top, .conkyrc_bottom, etc. You should save all your Conky config files there. Next create a script that will execute all these Conky files. Something like the following:
    Code:
     #!/bin/bash
    conky -c ~/.conky/.conkyrc_top &
    conky -c ~/.conky/.conkyrc_bottom
    Note that all commands except the last must be appended with an ampersand (&) so that the script will not stop at the first command.
    The "conky -c random_file" command simply tells conky to use random_file for configuration instead of the default ~/.conkyrc. Save this file as conky_start in ~/bin; if the folder does not already exist, create it.
    All this is found here: https://help.ubuntu.com/community/SettingUpConky
    Last edited by 1fallen; June 15th, 2019 at 05:57 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  4. #4
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    149
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Conky 1.10.8 does start properly during autostart

    No, that doesn't work, either. With the guidance of the help you mentioned, It even cannot start the conky process, much worse.

    It's because I have Lubuntu 19.04, which looks at .config/autostart (because I see that the process is started by autostart). The Help page of Ubuntu for Conky you mention belongs to very old versions of Lubuntu (.config/lxsession/Lubuntu). This is another proof that help pages of Ubuntu are not updated frequently...

    For more about this, take a look at https://askubuntu.com/questions/1108...-lubuntu-18-10

    I have tried https://unix.stackexchange.com/quest...p-in-fedora-28 , even a Japanese page (with Google translation) http://www.fuukemn.biz/page82-lubuntu-1005pe.html . None of them work.

    Anybody tried conky with a recent Lubuntu where .config/autostart is used?
    Last edited by pencuse; June 15th, 2019 at 06:24 PM. Reason: more information
    Dell Latitude E7440 (since Dec 2017). CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: PM851 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400
    Dual-boot /dev/sda5: Lubuntu 19.04, /dev/sda6: Arch Linux

  5. #5
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Conky 1.10.8 does start properly during autostart

    Well it dose work at least here anyway, maybe have a look at the conky.rc script your using.
    And autostart on Lubuntu 19.04: https://manual.lubuntu.me/3/3.2/3.2...._settings.html
    You seem very frustrated, and this will not help you in gaining users to help here.
    Good Luck though.
    BTW: If needed Conky Manager is a little more straight forward, and has an option for AutoStart.
    You can install it with a .run file from GitHub.
    You will need to install "realpath" first:
    Code:
    sudo apt install realpath
    For Conky Manager For 64 bit:
    Code:
    wget --no-check-certificate https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-amd64.run
    chmod +x conky-manager-v2.4-amd64.run
    sudo ./conky-manager-v2.4-amd64.run
    For 32 bit:
    Code:
    wget --no-check-certificate https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-i386.run
    chmod +x conky-manager-v2.4-i386.run
    sudo ./conky-manager-v2.4-i386.run
    I have also used the .deb with:
    Code:
    sudo apt install conky-all
    sudo apt install realpath
    wget https://github.com/teejee2008/conky-manager/releases/download/v2.4/conky-manager-v2.4-amd64.deb
    sudo dpkg -i conky-manager-v2.4-amd64.deb
    The pre-packaged software is found here: https://github.com/teejee2008/conky-manager/releases
    Last edited by 1fallen; June 15th, 2019 at 07:14 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  6. #6
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Conky 1.10.8 does start properly during autostart

    At cold boot you really need to add an option to pause the actual start of conky (as shown in man conky)
    -p | --pause= SECONDS
    Time to pause/wait before actually starting Conky.
    as it will not start properly if the DE is not fully up and running. I personally use a 20 second delay with command conky -p 20 and that is fine for Xubuntu-18.04 but I have no real experience of Lubuntu with LXQt. However, it must use a command at some place in the startup of conky where you could add the necessary pause, such as that desktop file you show in your opening post.
    DISTRO: Xubuntu 18.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  7. #7
    Join Date
    Dec 2006
    Location
    Hamburg, Germany
    Beans
    149
    Distro
    Lubuntu 19.04 Disco Dingo

    Re: Conky 1.10.8 does start properly during autostart

    Quote Originally Posted by ajgreeny View Post
    At cold boot you really need to add an option to pause the actual start of conky (as shown in man conky)
    as it will not start properly if the DE is not fully up and running. I personally use a 20 second delay with command conky -p 20 and that is fine for Xubuntu-18.04 but I have no real experience of Lubuntu with LXQt. However, it must use a command at some place in the startup of conky where you could add the necessary pause, such as that desktop file you show in your opening post.
    Thanks for this hint! At Lubuntu 19.04, conky 1.10.8 finally works with the option you mentioned above. I have given conky -p 60 in Autostart.

    For documentation purposes: Someone who wants to run conky on LXQt (and at Lubuntu), copy-paste /etc/conky/conky.conf to $HOME/.config/conky/conky.conf (create the directory if there isn't any). And set following variables in this file:
    Code:
    alignment = 'top_right',
    own_window_argb_visual = true,
    own_window_transparent = true,
    own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
    double_buffer = true, -- works at Openbox stacking window manager. To be checked whether it is also working for compositing window manager.
    I am setting this SOLVED.
    Last edited by pencuse; June 17th, 2019 at 05:14 PM. Reason: more information
    Dell Latitude E7440 (since Dec 2017). CPU: Intel Core i7-4600U, 2 cores, 4 threads; HDD: PM851 256 GB SSD; RAM: 8 GB DDR3L; Graphics: Intel HD 4400
    Dual-boot /dev/sda5: Lubuntu 19.04, /dev/sda6: Arch Linux

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •